X
Tap here to go to the mobile version of the site.

Support Forum

How do you disable the scrolll wheel click from going back to a previous site?

Posted

This has been bugging me for a while now. I click on links using my scroll wheel to open them up in a new tab. If I accidentally click outside of the link, Firefox will take me back to the website that I last visited. Here's an example. I go to google and then go to youtube. If I click anywhere on the page that isn't a link using the scroll wheel, it takes me back to google. I've checked the about:config mousewheel settings and to my understanding, the "2" value is what makes the mousewheel do this. However, none of the options in my about:config have the "2" value. I don't believe it's a driver issue because I use Linux and am provided with the default drivers. Does anyone know how to fix this? I'd greatly appreciate any help I can get.

This has been bugging me for a while now. I click on links using my scroll wheel to open them up in a new tab. If I accidentally click outside of the link, Firefox will take me back to the website that I last visited. Here's an example. I go to google and then go to youtube. If I click anywhere on the page that isn't a link using the scroll wheel, it takes me back to google. I've checked the about:config mousewheel settings and to my understanding, the "2" value is what makes the mousewheel do this. However, none of the options in my about:config have the "2" value. I don't believe it's a driver issue because I use Linux and am provided with the default drivers. Does anyone know how to fix this? I'd greatly appreciate any help I can get.

Chosen solution

Thank you. Unfortunately, changing those settings didn't help, but I believe I found the solution. In the about:config page there's an option named middlemouse.contentLoadURL. If you set that to false, it seems to stop the middle mouse click from going back to the previous visited website.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The IcedTea-Web Plugin executes Java applets.

Application

  • Pale Moon 26.1.0
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.9) Gecko/20100101 Goanna/2.0 Firefox/38.9 PaleMoon/26.1.0
  • Support URL: http://www.palemoon.org/support/

Extensions

  • Encrypted Web 5.1.2 ({4bf973fe-f2b7-43e1-b2ca-52f9c6f6fddf})
  • Imagus 0.9.8.37 ({00000f2a-7cde-4f20-83ed-434fcb420d71})
  • MEGA 3.4.2 (firefox@mega.co.nz)
  • NoScript 2.9.0.4 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Stylish 2.0.6 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Troubleshooter 1.1a.1-signed (troubleshooter@mozilla.org)
  • uBlock Origin 1.6.1 (uBlock0@raymondhill.net)
  • Blue Moon Linux 3.0 (bluemoonlinux@addons.palemoon.org) (Inactive)
  • Pale Moon Commander 1.7.3 (commander@palemoon.org) (Inactive)
  • Pushbullet 29.1-signed (jid1-BYcQOfYfmBMd9A@jetpack) (Inactive)
  • Shumway 0.11.620 (shumway-dev@research.mozilla.org) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: X.Org -- Gallium 0.4 on AMD SUMO (DRM 2.42.0, LLVM 3.7.1)
  • adapterDeviceID: Gallium 0.4 on AMD SUMO (DRM 2.42.0, LLVM 3.7.1)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: X.Org
  • driverDate:
  • driverVersion: 3.0 Mesa 11.1.2
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: X.Org -- Gallium 0.4 on AMD SUMO (DRM 2.42.0, LLVM 3.7.1)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 307200
  • browser.fixup.alternate.enabled: False
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20160212190230
  • browser.startup.homepage_override.mstone: 2.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.1.0
  • layers.acceleration.disabled: True
  • media.webm.enabled: False
  • mousewheel.with_shift.action: 1
  • network.cookie.cookieBehavior: 3
  • network.cookie.prefsMigrated: True
  • network.http.speculative-parallel-limit: 0
  • places.database.lastMaintenance: 1455853380
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.importedState: True
  • plugin.soname.list: libXt.so:libXext.so
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1455853380

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17574 solutions 158974 answers

You can modify mousewheel.with prefs on the about:config page to disable actions for specific modifiers.

0 means "Do nothing"
1 means "Scroll contents"
2 means "Go back or forward in the history"
3 means "Zoom in or out the contents"
mousewheel.default.action
mousewheel.with_alt.action
mousewheel.with_control.action
mousewheel.with_meta.action
mousewheel.with_shift.action

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can modify mousewheel.with prefs on the <b>about:config</b> page to disable actions for specific modifiers. *https://wiki.mozilla.org/Gecko:Mouse_Wheel_Scrolling 0 means "Do nothing" 1 means "Scroll contents" 2 means "Go back or forward in the history" 3 means "Zoom in or out the contents" mousewheel.default.action mousewheel.with_alt.action mousewheel.with_control.action mousewheel.with_meta.action mousewheel.with_shift.action ---- You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config

Chosen Solution

Thank you. Unfortunately, changing those settings didn't help, but I believe I found the solution. In the about:config page there's an option named middlemouse.contentLoadURL. If you set that to false, it seems to stop the middle mouse click from going back to the previous visited website.

Thank you. Unfortunately, changing those settings didn't help, but I believe I found the solution. In the '''about:config''' page there's an option named '''middlemouse.contentLoadURL'''. If you set that to false, it seems to stop the middle mouse click from going back to the previous visited website.