Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mail goes to wrong folder

  • 13 replies
  • 2 have this problem
  • 1152 views
  • Last reply by modemjunkie

more options

I have my main Local folders set to bring mail from my provider via Pop 3. I have the default inbox and a couple of dozen folders. Most mail should remain in the inbox but lots of it sorts by filters into the other folder.

The other day I started noticing that new mail was showing up in a folder named Medical. Normally only mail from my doctors or drugstores should go there.

Then today I noticed that the Medical had over 7,000 emails. In order to sort things out I renamed the folder to "+inbox" and then searched for the medical emails and moved them to a new Medical folder.

The next thing I noticed was that all new mail was going to +inbox and my default inbox was empty. When I move mail to the default inbox and run filters on it, it moves them back to +inbox.

How can I fix this?

Leonard

Chosen solution

It would be interesting to see your filters for that account They are stored in a file, msgFilterRules.dat, within your mail folder. open in a texteditor, mark and copy into your answer. Do this with Thunderbird NOT running.

You find your profile with the help of troubleshooting information (under help), Show folder -button. Then you have to navigate to Imapmail or mail and to your account.

A part of my filter looks like version="9" logging="no" name="Youtube" enabled="yes" type="17" action="Move to folder" actionValue="mailbox://nobody@Local%20Folders/5-YouTube" condition="AND (from,contains,@youtube.com)" name="support" ........

Read this answer in context 👍 1

All Replies (13)

more options

I can't answer why your messages are moving by themselves, but I would like to comment that folder names in Thunderbird translate to file names in your file system. Therefore all the characters that have special meaning in file names, such as \, / and * should be avoided. (As a matter of good practice I'd also avoid ~, +, ^, %, ?, !, |, $, quotation marks and all brackets and braces.) Also, Thunderbird's filters have a blind spot for some other characters in email addresses; they can't see, in particular, the + symbol. I don't know if this restriction applies also to file/folder names.

Do your filter logs give any hint as to what they are up to?

more options

Thanks, Zenos, I am afraid I inadvertently deleted my filter logs.

I have had a number of folders with "+" as a prefix for years. It allows me to move them above the regular alphabetical listing. I have never had any problem before.

Something strange is going on. Tonight, all of a I found dozens of duplicate emails in many of my folders. I am beginning to think something happened to my profile but I wouldn't know how to fix that without risking losing hundreds of thousands of emails.

more options

just in case...create a backup of your Profile folder name in it's current state. Do not compact anything just yet.

Rename your folders - Remove all of those '+' signs. If you want to rename an Inbox, then name it eg: Inbox Old

Create a second backup - (and delete the first one) Delete all the duplicate emails from all effected folders. Empty the 'Deleted' folder - right click on folder and select 'Empty deleted' Empty the Junk folder - right click on folder and select 'Empty Junk' Now, compact all your folders : 'File' > 'Compact folders'

If everything is ok - no missing emails - create a third and final backup (delete the second) - store this on an external drive for safe keeping.

Now you will probably want to reorganise folders into more suitable position. You can easily reorganise folder position using this addon:

How to Install Add-on Extension:

  • Open the add-ons manager ( New Fx Menu then appmenuAddons )
  • Drag your downloaded XPI file to the add-on manager tab and drop it.

or

  • CogWheel and select 'Install Add-on From File'.
  • Locate the *.xpi file you downloaded and click on 'Open'.
  • You may need to restart Thunderbird when prompted.

For more detailed instructions and information about installing add-ons please see Installing an Add-on in Thunderbird

more options

Well, I am backing up my profile. The only place not on my drive I could put it was Dropbox as it is over 40 gig. Windows tells me it will be several hours before it is finished.

Len

more options

Toad-hall, I have backed up the profile (all 45 gig) to drop box. renamed all of the + folders to AA whatever. Deleted trash and junk, and duplicate files (9000 of them) compacted, and checked my filters.

The filters automatically point to the renamed locations, new mail now goes to AAInbox instead of the default Inbox. Interestingly the filters also run on AAInbox instead of Inbox. If I click something in the junk folder as "not junk" it puts it in the original default inbox.

So I still go back to the original question, How can I get new mail to go to the original default inbox? Thanks.

more options

Chosen Solution

It would be interesting to see your filters for that account They are stored in a file, msgFilterRules.dat, within your mail folder. open in a texteditor, mark and copy into your answer. Do this with Thunderbird NOT running.

You find your profile with the help of troubleshooting information (under help), Show folder -button. Then you have to navigate to Imapmail or mail and to your account.

A part of my filter looks like version="9" logging="no" name="Youtube" enabled="yes" type="17" action="Move to folder" actionValue="mailbox://nobody@Local%20Folders/5-YouTube" condition="AND (from,contains,@youtube.com)" name="support" ........

Modified by Gnospen

more options

Note: I had to truncate the filter list to fit the maximum.

more options

Quick question.

The filters all seem to be working correctly now. The only issue is why incoming mail goes to AAInbox instead of the default Inbox.

I wonder if I could solve that by deleting the inbox from the mail profile?

more options

I'm not sure what fixed it. I think I found a looping filter when I went though the filter.dat. In any event, I think things are working correctly again. Famous last words. Thanks for the input.

more options

Wow what a filter. I use an add-on "FiltaQuilla that gives me more ways to filter so Instead of adding every single address I use:

From, is in my address-book,  Family-Addresses

I then just add or change in that addressbook.

PLEASE DELETE YOUR ANSWER, ITS TO MANY EMAIL_ADDRESSES MADE PUBLIC.

Modified by Gnospen

more options

I have deleted the filterrules.dat posting as it contained many many email addresses other than your own. Not really something that should be publicly published.

I started to edit the posting, but it was just taking more time than I was prepared to give it, given the problem is solved.

more options

Matt said

. I started to edit the posting, but it was just taking more time than I was prepared to give it, given the problem is solved.

Thank you for your thoughtfulness and help, Matt.

Len

more options

Thanks again to all who thought about my problem and offered suggestions.