X
Tap here to go to the mobile version of the site.

Support Forum

Insecure Connection to websites that were fine

Posted

I don't know if was an update or something it just seems to have happened all of a sudden. My security program is Bullguard if that means anything

I don't know if was an update or something it just seems to have happened all of a sudden. My security program is Bullguard if that means anything
Attached screenshots

Modified by VideoJones

Chosen solution

I couldn't find the instructions for making Firefox "trust" the fake certificates BullGuard is generating. Often security products with this feature of intercepting and filtering your secure browser sessions will set up Firefox automatically at system startup, but if that isn't happening, you might contact their support for the steps. With other products, you import the vendor's signing certificate into Firefox as an Authority and that takes care of it. Alternately, in some products, you can exclude secure sites from filtering that eliminates the issue.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17570 solutions 158915 answers

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • click "Advanced" to expand the error message
  • click "Add Exception" to open "Add Security Exception"
  • alternatively you can open "Add Security Exception" by pasting this URL in the location/address bar:
    chrome://pippki/content/exceptionDialog.xul
    paste the URL of the website (https://xxx.xxx) in it's location field
  • let Firefox retrieve the certificate -> "Get Certificate"
  • click the "View" button and inspect the certificate
    check who is the issuer of the certificate

You can see details like intermediate certificates that are used in the Detail tab.

Who is the issuer of the certificate?

See also:

  • [/questions/1104771] I get the message 'unsecure etc' when I try to load yahoo and google. Other web pages load ok.
You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates. *click "Advanced" to expand the error message *click "Add Exception" to open "Add Security Exception" *alternatively you can open "Add Security Exception" by pasting this URL in the location/address bar:<br>chrome://pippki/content/exceptionDialog.xul<br>paste the URL of the website (https://xxx.xxx) in it's location field *let Firefox retrieve the certificate -> "Get Certificate" *click the "View" button and inspect the certificate<br>check who is the issuer of the certificate You can see details like intermediate certificates that are used in the Detail tab. Who is the issuer of the certificate? See also: *[[/questions/1104771]] I get the message 'unsecure etc' when I try to load yahoo and google. Other web pages load ok.

Modified by cor-el

Helpful Reply

When I click advanced I don't get an add exception button. It also happens on google and youtube.

When I click advanced I don't get an add exception button. It also happens on google and youtube.

Modified by VideoJones

cor-el
  • Top 10 Contributor
  • Moderator
17570 solutions 158915 answers

If you can't inspect the certificate via Advanced (Add Exception) then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website with the https:// protocol prefix (https://xxx.xxx).

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then please attach a screenshot that shows the Certificate Viewer.

If you can't inspect the certificate via Advanced (Add Exception) then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website with the https:// protocol prefix (https://xxx.xxx). *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then please attach a screenshot that shows the Certificate Viewer.
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Chosen Solution

I couldn't find the instructions for making Firefox "trust" the fake certificates BullGuard is generating. Often security products with this feature of intercepting and filtering your secure browser sessions will set up Firefox automatically at system startup, but if that isn't happening, you might contact their support for the steps. With other products, you import the vendor's signing certificate into Firefox as an Authority and that takes care of it. Alternately, in some products, you can exclude secure sites from filtering that eliminates the issue.

I couldn't find the instructions for making Firefox "trust" the fake certificates BullGuard is generating. Often security products with this feature of intercepting and filtering your secure browser sessions will set up Firefox automatically at system startup, but if that isn't happening, you might contact their support for the steps. With other products, you import the vendor's signing certificate into Firefox as an Authority and that takes care of it. Alternately, in some products, you can exclude secure sites from filtering that eliminates the issue.

Question owner

I just contacted BullGuard support and it was an issue with the latest update of Firefox and Bullguard. They've given me a workaround until they work out the problem. Thanks for the help

I just contacted BullGuard support and it was an issue with the latest update of Firefox and Bullguard. They've given me a workaround until they work out the problem. Thanks for the help
cor-el
  • Top 10 Contributor
  • Moderator
17570 solutions 158915 answers

Can you tell us the workaround?

It helps others with the same problems who find this thread.

Can you tell us the workaround? It helps others with the same problems who find this thread.

Question owner

It was just to reset firefox via this page https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems

It was just to reset firefox via this page https://support.mozilla.org/en-US/kb/reset-preferences-fix-problems