Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Emails received in Thunderbird from a known good sender have URL's that are never hyperlinks.

  • 8 replies
  • 1 has this problem
  • 171 views
  • Last reply by Eric S.

more options

I have tried the add on "Text Link" 5.0.2015060501, no changes in URL text to force them to hyperlinks when I open them. I can paste the text to my address bar and the link opens the URL web page, so no issues with URL links. I tested (forwarding) the email to myself and opening it again, the URL text converted in the forwarded email to a hyperlink after passing it back to myself again. (very odd problem) I would think Thunderbird would be reviewing the body of an email when I open them and when Thunderbird detects a URL text it would automatically make it a hyperlink. Like URL text with Http://...... or Https://.......( would become a hyperlink)

Not all the emails I get have this problem.

I hope someone might know what I can do, to fix this issue so I don't have to keep copy and pasting URL text to an address bars.

Thanks for your support.

Eric

Modified by Eric S.

Chosen solution

If Toolbar Buttons is installed and enabled, right-click the Mail Toolbar, Customize... (or View/Toolbars/Customize...) and drag the HTML Mode button onto the Mail Toolbar. Clicking the button will cycle through the options for View/Message Body As.

If you don't see the attached picture, it may be because you installed the add-on in Firefox instead of TB.

Read this answer in context 👍 0

All Replies (8)

more options

The problem is probably caused by the sender's email program formatting URLs in some proprietary way that defeats TB's parsing, or the message was created in a word processor and pasted into the message.

Does it make any difference if you choose an option under View/Message Body As that is different from Original HTML?

more options

Hello Sfhowes,

Yes I was able to select View Message body URL's with the (Plain Text) option, this changed the URL's in the emails into a Hyperlinks, and I can click on them now and open the Web pages directly from the email bodies without copy and paste options.

Update: The bad side of this is other emails that are Original HTML emails show content as text now, is there a way I can get thunderbird to view HTML emails and Text emails to view their entire content with HTML and hyperlinks enabled?

2nd Update: I asked the sender how they are creating the emails with the URL links they are sending to me. They are coping and pasting the address bar URL into the body of a newly created email then sending it to me. They are using AOL over the web based email system.

Thanks for the help!

Eric

Modified by Eric S.

more options

I don't know if it's possible to make TB display hyperlinks correctly for every message, irrespective of the senders' email program. But I did a test with AOL webmail: links that are pasted into a message are not clickable, as you know, but if the link is embedded in text (by highlighting a string of text and then clicking the Link icon and pasting the URL in the Link to: box) then the link is clickable in TB if the view format is HTML.

You could also install a button to quickly toggle the View option between text and HTML by installing the Toolbar Buttons add-on for 'HTML Mode' (select 'Offer for download instead of installing'). After the add-on is installed, right-click the Mail Toolbar, Customize... and drag the HTML Mode button to the toolbar.

more options

It seems rather likely that AOL might be using so-called "URL encoding" where, for instance, space is encoded as %20. It may be rendered as a space in a program that understands this convention, but at the bits-and-bytes level Thunderbird doesn't see the space. And so on for any other characters treated this way.

If this is the case, I'm rather disappointed that the add-on isn't fixing them for you.

I'd take a look at the message source (ctrl+u) to check this idea.

more options

I like the idea of having the 2 buttons to toggle between the "plain text" and the "Original HTML" on the mail tool bar.

I installed the add-on called Toolbar buttons 1.1.1-signed, I think this the right one. But, I can seem to figure out how to get it to work to drag and drop the 2 buttons I need. I guess I need step by step instructions to figure out how to drag and drop the two buttons.

When I right click and select customize on the mail tool bar, a screen opens up where I can drag some items like the VIEW MENU to the top mail bar, but I cant seem to see the actual 2 buttons I need to drag over (plain text) and (Original HTML).

Modified by Eric S.

more options

What I found in the email source is copied below, shows plain text with character set =utf-8. When I select Plain text in the view message body this is when the hyperlink shows up. Anything that has Http: or https:. It then becomes a hyperlink. I don't see where %20 compression is being applied. Not sure if compressed or encoded based on the info I copied below. This might help us all learn, why AOL hyperlinks are not active in emails sent from aol over the web.....


out of a source…….on email sent via AOL, WEB BASED.

Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit

Modified by Eric S.

more options

Chosen Solution

If Toolbar Buttons is installed and enabled, right-click the Mail Toolbar, Customize... (or View/Toolbars/Customize...) and drag the HTML Mode button onto the Mail Toolbar. Clicking the button will cycle through the options for View/Message Body As.

If you don't see the attached picture, it may be because you installed the add-on in Firefox instead of TB.

Modified by sfhowes

more options

Thanks to all who helped me solve this problem. I was not aware that the HTML button would cycle every time I selected it. I was trying to put the Plain Text button and the Original HTML button on the tool bar, but I understand now how to use the HTML Mode Button.

Regards to all.

Eric