X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

How to disable DirectWrite?

Posted

Hi. I have a problem with fonts in Firefox - fonts are blurred due to "DirectWrite" and I don't know how to disable "DirectWrite" exсept turn off "hardware acceleration when available". But if I disable hardware acceleration, high quality video's on YouTube beginning to break. I had the same problem in Chrome. I just disable DirectWrite in experimental features (chrome://flags).

Hi. I have a problem with fonts in Firefox - fonts are blurred due to "DirectWrite" and I don't know how to disable "DirectWrite" exсept turn off "hardware acceleration when available". But if I disable hardware acceleration, high quality video's on YouTube beginning to break. I had the same problem in Chrome. I just disable DirectWrite in experimental features (chrome://flags).

Chosen solution

I solved the problem: in about:config - gfx.font_rendering.cleartype_params.rendering_mode set 2 (Use GDI Classic rendering mode).

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 5.1.41212.0

Application

  • Firefox 43.0.4
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0.4/WINNT/en-US/

Extensions

  • Adguard AdBlocker 2.0.20 (adguardadblocker@adguard.com)
  • Ghostery 5.4.10 (firefox@ghostery.com)
  • HTTPS-Everywhere 5.1.0 (https-everywhere@eff.org)
  • OmniSidebar 1.6.9 (osb@quicksaver)
  • S3.Google Translator 5.16 (s3google@translator)
  • Bitdefender Wallet 3.0 (bdwteffv20@bitdefender.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 670MX
  • adapterDescription2:
  • adapterDeviceID: 0x11a1
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 3072
  • adapterRAM2:
  • adapterSubsysID: 21ab1043
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.18123
  • driverDate: 12-16-2015
  • driverDate2:
  • driverVersion: 10.18.13.6143
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670MX Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
ideato 893 solutions 6250 answers

Hello, try to toggle to false the gfx.font_rendering.graphite.enabled (always in about:config).

any luck ?

thank you

Hello, try to toggle to false the '''gfx.font_rendering.graphite.enabled''' (always in [http://kb.mozillazine.org/About:config about:config]). any luck ? thank you

Question owner

It didn't help me.

It didn't help me.

Chosen Solution

I solved the problem: in about:config - gfx.font_rendering.cleartype_params.rendering_mode set 2 (Use GDI Classic rendering mode).

I solved the problem: in about:config - gfx.font_rendering.cleartype_params.rendering_mode set 2 (Use GDI Classic rendering mode).