X
Tap here to go to the mobile version of the site.

Support Forum

This Connection is Untrusted

Posted

I get this error message on just about every site even Mozilla sites

My date and time are correct. I am not using Microsoft Family settings

I get this error message on just about every site even Mozilla sites My date and time are correct. I am not using Microsoft Family settings

Chosen solution

Thanks for the response.

The issue occurs with just about all web sites. I am using AVG free btw.

I have no problems with Chrome so I have switched to using that

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4307 solutions 60481 answers

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate.

http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html

https://support.mozilla.org/en-US/kb/server-not-found-connection-problem

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate. http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.
cor-el
  • Top 10 Contributor
  • Moderator
17682 solutions 159964 answers

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Chosen Solution

Thanks for the response.

The issue occurs with just about all web sites. I am using AVG free btw.

I have no problems with Chrome so I have switched to using that

Thanks for the response. The issue occurs with just about all web sites. I am using AVG free btw. I have no problems with Chrome so I have switched to using that
cor-el
  • Top 10 Contributor
  • Moderator
17682 solutions 159964 answers

Did you check the issuer of the certificate?

I don't know if this works for your AVG version:

Open AVG.
click "Options" -> "Advanced Settings" -> "Web Browsing Protection" -> "Online Shield" -> "Expert Settings"
uncheck "Scan encrypted (TLS and SSL) network traffic" option
Did you check the issuer of the certificate? I don't know if this works for your AVG version: Open AVG. click "Options" -> "Advanced Settings" -> "Web Browsing Protection" -> "Online Shield" -> "Expert Settings" uncheck "Scan encrypted (TLS and SSL) network traffic" option