Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox prevented me from installing add on extensions

  • 23 replies
  • 11 have this problem
  • Last reply by johnny_ash

more options

I have been trying desperately to install facebook purity add on/ extension, and on chrome, had no problem, works great, but firefox keeps giving me the dreaded pop up that says " Firefox prevented this site from asking you to install add on" I went into the permissions and listed this website as an exception, there is no box that pops up and says/asks me to 'allow ' it, i went to about:config, and the signature thingy is already set to false, as per prior articles questions, and so none of these possible fixes work, how the heck do I get firefox to allow me to choose for my self and my own reasons, the add on and not stop me??? please tell me what steps to use, i have toldyou what i already tried, now i just need some help as this happens all the time. OMG when I hit the button at bottom of page to automatically add troubleshooting information, the same pop up came on and wouldn't allow it, here on ffmozilla!!!

Chosen solution

You normally see the "Save Link As" item in the right-click context menu of the Add button. There is also a versions section further down with a link to the xpi file.

Read this answer in context 👍 1

All Replies (20)

more options

Please refer this and get to know why Firefox is preventing you to install the add-on Click Here

Modified by Jyotsna Gupta

more options

I am attaching the sequence of displays on the "doorhanger" for installing F.B. Purity from Where do you see a difference?

more options

Hmm, you weren't able to authorize this site to collect troubleshooting information? I wonder whether your permissions database is corrupted. You could try renaming it to force Firefox to regenerate it. This will remove site-specific permissions such as which sites are allowed/blocked from displaying popups or setting cookies, and also which sites can install software and which can access troubleshooting information.

Here's how you would try that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename permissions.sqlite to something like permissions-old.sqlite (renaming instead of deleting allows you to reverse this change if you decide you want to do that).

Start Firefox back up again. Can you install extensions?

more options

Thanks for responding. ON the door hanger I see the problem, I don't even get the ALLOW part, it just says Firefox prevented you from installing....I am going to try to do the firefox permissions cleanup you are suggesting ( if I can follow it correctly) because something must be wrong. However, on a side note, I did go out of firefox came back in safe mode and was able to install ( and it allowed me because it gave the ALLOW section ) but in regular mode, NO dice. I will see if I can do the 'fix' you suggest and then post again.

more options

Do you mean it worked in Firefox's Safe Mode -- which disables extensions, UI modifications in userChrome.css, and various other things -- or is worked in Windows Safe Mode -- which disables some external programs from starting automatically?

more options

Ok I tried following step by step, found the folder, but there was nothing ( is a step missing) to make Firefox do a cleanup, and here is the weird thing, I found three different permissions.sqlite, one of them had a number 2 with it, but it seems like these are duplicates? should I delete them and if so, which ones? But not sure how to get Firefox to reset them or clean them up ?

more options

Yes in Firefox safe mode it worked, it showed the allow button.

more options

Maybe one of your extensions is incompatible with Firefox 42 in some subtle way. Well, I mean subtle other than this problem.

more options

what should I do about the permissions squlite ( multiples) and how to fix this problem and make it ALLOW me to install. ? Do you have the steps I can use?

more options

The most likely culprits based on your Safe Mode test are:

(1) Extension or full theme (2) userChrome.css customization file (optional, only exists if you or someone with access to your computer created it)

Do you want to post a list of your extensions? The easiest way to extract a list with the title, version number and ID (useful for web searches) is to copy it from the support information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions heading, use the mouse to select from there through the table that follows and copy, and then paste into a reply. It will look a little messy, but don't worry, we're used to it.

more options

Adblock Plus 2.6.13 true {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Adblock Plus Pop-up Addon true Avast Online Security true Classic Theme Restorer 1.4.2 true ClassicThemeRestorer@ArisT2Noia4dev F.B. Purity - Cleans Up Facebook 13.4.2 true New Tab Homepage 0.5.0 true {66E978CD-981F-47DF-AC42-E3CF417C1467} Open Link in New Tab 0.1.2014070301.1-signed true Personas Plus true personas@christopher.beard Social Fixer 12.0 true The Addon Bar (restored) 3.2.1-signed true the-addon-bar@GeekInTraining-GiT Toolbar Buttons 1.1.1-signed true {03B08592-E5B4-45ff-A0BE-C1D975458688} Troubleshooter 1.1a.1-signed true Updated Ad Blocker for Firefox 11+ true {4DC70064-89E2-4a55-8FC6-E8CDEAE3618C} WOT 20151113 true {a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7} Yahoo! Toolbar true {635abd67-4fe9-1b23-4f01-e679fa7484c1} Zoom toolbar 1.1.1-signed true {FBFB7597-9E32-46b4-A500-8B6B0412777F} Avast SafePrice false Download videos and MP3s from YouTube false {B64D9B05-48E1-4CEB-BF58-E0643994E900} Element Hiding Helper for Adblock Plus 1.3.5 false mediaplayerconnectivity false {84b24861-62f6-364b-eba5-2e5e2061d7e6} Multirow Bookmarks Toolbar false {FBF6D7FB-F305-4445-BB3D-FEF66579A033} NoScript false {73a6fe31-595d-460b-a920-fcc0f8843232} NoUn Buttons false {99f30549-35d4-11d9-8a2a-396c6e707e82} Open Bookmarks in New Tab 0.1.2012122901.1-signed false Restart Button false SettingSanity 1.0 false {12A60D0F-0077-4F41-81B2-1286DDD278BB} Strict Pop-up Blocker 0.2.1-signed false jid1-P34HaABBBpOerQ@jetpack Tab Mix Plus false {dc572301-7619-498c-a57d-39143191b318} Vertical Toolbar 1.0.10 false Yahoo Mail Hide Ad Panel 2.48 false {c37bac34-849a-4d28-be41-549b2c76c64e}

more options

Hmm, nothing leaps out at me as an obvious problem. A few notes:

(1) Try disabling Avast Online Security in case that is responsible (2) Try updating Classic Theme Restorer (there was an update on Nov. 17th) (3) You can remove "Updated Ad Blocker for Firefox 11+" as it now is much older than Adblock Plus.

All of these actions can be taken from the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right side, above the list, look for the gear/cog button, click that and then Check for Updates. (If CTR won't auto-update, you could install again from here:

After that you can disable the Avast extension and remove the other one.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

more options

I did all that you listed step by step, then to test, attempted to get an add on and once more, ( even with avast disabled) and the updated ad blocker removed and the classic theme restorer updated... still not getting that ALLOWED popup, just the same thing about not being able to download. So it did not change/improve, I am stumped. Ironically, I can see the allowed when I go on a Mac with Firefox. I am currently using my good old Windows 7 as I have for years, and nothing had changed. I guess deleted the squilite permissions wouldn't work or help ? ( I have 3 files and all named same).... any idea?

more options

I don't think it's the permissions.sqlite file if Safe Mode restored the Allow button. Anyway, once Firefox is fully shut down, usually there would only be one main file (the two temporary/working files should be removed).

Do you use a custom theme? Instead of appearing on the Extensions section of the Add-ons page, it would be under Appearance.

more options

Under appearance, I do have the default theme working, but even after disabling, so no theme, it didn't work, I tried to download the ad-ons manager and once again it just showed the same with no ALLOW button.

more options

What is the value of the xpinstall.* prefs?

Can you attach a screenshot of about:config with the xpinstall.*?

  • Use a compressed image type like PNG or JPG to save the screenshot
  • Make sure that you do not exceed the maximum size of 1 MB

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and (re)install or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then create a new profile.

more options

I have a screen shot attached. I don't think that taking out my firefox and other convoluted time consuming things are really what is necessary; all other things work fine, its basically that Firefox, despite my turning off all security, adding in every website that i want to use for addons ( mozilla's very own) allowing for exceptions, none of these things work at all, now I know I am not as technically gifted as you all, but I have learned through experience, when I am told to basically rip it all out and start over, it does NOT end well for me....hours later I would be trying to find and fix a billion other problems, wheras the first problem may or may not i would ask that short of the very time consuming and long redress, that a file might be at work here that is causing, because I know from turning off all the add ons and so forth, none of that has maybe something else? by the way, I have seen in my search that I am not the only one who faces the 'allow' button being gone and so apparently people are trying different things, but this is not isolated.

more options

That is OK. xpinstall.whitelist prefs control to restore some default permissions (xpinstall.whitelist.add is about the Add-ons website).

Can you install extensions locally by saving the .xpi file to your computer (desktop) and drag the file in a Firefox tab or via "File > Open File"?

more options

cor-el said

That is OK. xpinstall.whitelist prefs control to restore some default permissions (xpinstall.whitelist.add is about the Add-ons website). Can you install extensions locally by saving the .xpi file to your computer (desktop) and drag the file in a Firefox tab or via "File > Open File"?

No, I open add ons and try to add one, it takes me to the add on and then my only option is to add....not download ( even when I right click it) no option to drag it anywhere I have attached a screen shot. Now you see what I see, and there is nothing I can do except hit the green bar and then be told not going to get to add it on, and so I can't drag anything anywhere. the xpinstallwhitelist you mention, is that something we can delete, modify or change? to alter this problem?

more options

Chosen Solution

You normally see the "Save Link As" item in the right-click context menu of the Add button. There is also a versions section further down with a link to the xpi file.

  1. 1
  2. 2