X
Tap here to go to the mobile version of the site.

Support Forum

When I search in the address bar, Firefox takes me to google.com.tr. How do i fix this? I'm in the UK.

Posted

My default search engine is only Google, and my homepage is www.google.co.uk. My router's IP is UK, and so is my Google profile. I don't quite understand why Firefox wants to show me results from Turkey.

My default search engine is only Google, and my homepage is www.google.co.uk. My router's IP is UK, and so is my Google profile. I don't quite understand why Firefox wants to show me results from Turkey.

Additional System Details

Installed Plug-ins

  • 20-20 Technologies - 20-20 3D Viewer for IKEA v5.0.94.1
  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.7
  • 5.1.40728.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

FredMcD
  • Top 10 Contributor
4340 solutions 61029 answers

When Firefox is searching the web, it uses the default search engine. What is yours?

When Firefox is searching the web, it uses the default search engine. What is yours?

Question owner

FredMcD said

When Firefox is searching the web, it uses the default search engine. What is yours?

schnarf78 said

My default search engine is only Google, and my homepage is www.google.co.uk. My router's IP is UK, and so is my Google profile. I don't quite understand why Firefox wants to show me results from Turkey.
''FredMcD [[#answer-807820|said]]'' <blockquote> When Firefox is searching the web, it uses the default search engine. What is yours? </blockquote> ''schnarf78 [[#question-1094830|said]]'' <blockquote> My default search engine is only Google, and my homepage is www.google.co.uk. My router's IP is UK, and so is my Google profile. I don't quite understand why Firefox wants to show me results from Turkey. </blockquote>
cor-el
  • Top 10 Contributor
  • Moderator
17773 solutions 160751 answers

Is your issue fixed since you marked an answer as the solution?

You can check the selected search engine in "Options/Preferences > Search"

You can find Google search engines, including a 'No country redirect' version, on the Mycroft Project website.

Is your issue fixed since you marked an answer as the solution? You can check the selected search engine in "Options/Preferences > Search" *https://support.mozilla.org/kb/Search+bar You can find Google search engines, including a 'No country redirect' version, on the Mycroft Project website. * http://mycroftproject.com/google-search-plugins.html
FredMcD
  • Top 10 Contributor
4340 solutions 61029 answers

I wanted you to check and make sure.

Some installers and ad-ware can change your settings without telling you.

I wanted you to check and make sure. Some installers and ad-ware can change your settings without telling you.

Question owner

FredMcD said

I wanted you to check and make sure. Some installers and ad-ware can change your settings without telling you.

Thanks. I had already checked that Google was the default, and even unselected all others.

''FredMcD [[#answer-807866|said]]'' <blockquote> I wanted you to check and make sure. Some installers and ad-ware can change your settings without telling you. </blockquote> Thanks. I had already checked that Google was the default, and even unselected all others.

Question owner

cor-el said

Is your issue fixed since you marked an answer as the solution? You can check the selected search engine in "Options/Preferences > Search" You can find Google search engines, including a 'No country redirect' version, on the Mycroft Project website.

Hi cor-el,

The settings for the search bar are for Google, and it works fine there, but when I search in the address bar (which is the topic of this post), it takes me to google.com.tr.

''cor-el [[#answer-807845|said]]'' <blockquote> Is your issue fixed since you marked an answer as the solution? You can check the selected search engine in "Options/Preferences > Search" *https://support.mozilla.org/kb/Search+bar You can find Google search engines, including a 'No country redirect' version, on the Mycroft Project website. * http://mycroftproject.com/google-search-plugins.html </blockquote> Hi cor-el, The settings for the search bar are for Google, and it works fine there, but when I search in the address bar (which is the topic of this post), it takes me to google.com.tr.
FredMcD
  • Top 10 Contributor
4340 solutions 61029 answers

Helpful Reply

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Google Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


What does this webpage say about your location? http://whatismyipaddress.com/

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' In the Add-ons Manager, on the left, select '''Extensions.''' Remove Google '''Anything.''' Now do the same in the computers Programs Folder. '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the "Applications" folder. '''Linux:''' Check your user manual. ------------- What does this webpage say about your location? '''http://whatismyipaddress.com/'''
cor-el
  • Top 10 Contributor
  • Moderator
17773 solutions 160751 answers

What page opens if you type https://www.google.com in the location/address bar?

Try to clear the Google cookies.

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
What page opens if you type https://www.google.com in the location/address bar? Try to clear the Google cookies. Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache": *Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now" "Remove Cookies" from sites causing problems: *Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
jscher2000
  • Top 10 Contributor
8886 solutions 72693 answers

Hmm, the search bar and address bar use the same search plugin -- unless an extension is overriding it.


As an aside, unless something changed in Firefox 42, the Google search plugin in your UK English version of Firefox is pointed to www.google.com, and Google does a geographic redirection from there based on what it thinks it knows about your connection.

To bypass that and save a step, or if you often select U.K. pages on google.co.uk, it's easiest to install a custom search plugin for Google UK. There are several choices on this page:

http://mycroftproject.com/google-search-plugins.html

Hmm, the search bar and address bar use the same search plugin -- unless an extension is overriding it. ---- As an aside, unless something changed in Firefox 42, the Google search plugin in your UK English version of Firefox is pointed to www.google''.''com, and Google does a geographic redirection from there based on what it thinks it knows about your connection. To bypass that and save a step, or if you often select U.K. pages on google.co.uk, it's easiest to install a custom search plugin for Google UK. There are several choices on this page: http://mycroftproject.com/google-search-plugins.html
Liamthe1st 0 solutions 1 answers

This Daventry United Kingdom why is Google and Firefox showing United States? At 63 I am getting really annoyed!

This Daventry United Kingdom why is Google and Firefox showing United States? At 63 I am getting really annoyed!
jscher2000
  • Top 10 Contributor
8886 solutions 72693 answers

Hi Liamthe1st, it's time to move from annoyance to a solution! Let me repeat/update an earlier comment:

Unless something changed in Firefox 44, the Google search plugin in your UK English version of Firefox is pointed to www.google.com, and Google does a geographic redirection from there based on what it thinks it knows about your connection.

To bypass that and save a step, or if you often select U.K. pages on google.co.uk, it's easiest to install a custom search plugin for Google UK. There are several choices on this page:

http://mycroftproject.com/google-search-plugins.html

Hi Liamthe1st, it's time to move from annoyance to a solution! Let me repeat/update an earlier comment: Unless something changed in Firefox 44, the Google search plugin in your UK English version of Firefox is pointed to www.google''.''com, and Google does a geographic redirection from there based on what it thinks it knows about your connection. To bypass that and save a step, or if you often select U.K. pages on google.co.uk, it's easiest to install a custom search plugin for Google UK. There are several choices on this page: http://mycroftproject.com/google-search-plugins.html