X
Tap here to go to the mobile version of the site.

Support Forum

Can't Search in Firefox with Windows 10

h_g
Posted

I followed the instructions in "This Connection is Untrusted" error message appears - What to do and deleted cert8.db. I restarted Firefox but the problem persisted

I followed the instructions in "This Connection is Untrusted" error message appears - What to do and deleted cert8.db. I restarted Firefox but the problem persisted

Chosen solution

I'm quote the reply you posted in someone else's thread:

Chrome shows the same certificate that I imported into Firefox from the list of "Authorities". Edge doesn't show the certificate but states that the same authority "GeoTrust Global CA" which issued the Chrome and Firefox certificates identifies the site as www.google.com. As I stated, Chrome and Edge have no problem. I'm beginning to believe it's simply a Firefox bug.

Edge and Chrome should match. As far as I know, they both share the Windows certificate store, and in fact, I believe Chrome still uses the Windows certificate viewer to show the certificate, unless it changed recently or works differently on Windows 10 than on Windows 7. All browsers accessing the same site should get the same certificate hierarchy if there is no hanky panky going on.


Sometimes if Firefox is behaving strangely for no apparent reason it is caused by corrupted program files. For that we suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 43.0.3 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder as follows:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox search normally??

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36 Edge/12.10240

More Information

Question owner

Further after deleting cert8.db, I restarted and imported "Google Internet Authority G2" Software Security Device to the Certificate Manager and that didn't help, either.

Further after deleting cert8.db, I restarted and imported "Google Internet Authority G2" Software Security Device to the Certificate Manager and that didn't help, either.
rahuldecoded 6 solutions 77 answers

Helpful Reply

You probably saw these articles when you were posting, but just in case this is a security software issue: Firefox can't load websites but other browsers can.

You probably saw these articles when you were posting, but just in case this is a security software issue: [https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can Firefox can't load websites but other browsers can.]
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Is this problem only with Google, or other HTTPS connections as well? When you get this for pretty much all secure sites, the problem usually is one of the following:

(1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem.

(2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, and Kaspersky; AVG has a Search Shield feature which can cause this error on search sites.

(3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: http://windows.microsoft.com/en-us/wi.../turn-off-microsoft-family-settings)

(4) Malware on your system intercepting secure connections.

So... which is it?

If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us.


To gather further information, you could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting:

Load my test page at: https://jeffersonscher.com/res/jstest.php

You likely will get an error page. Expand the "I understand the risks" section and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

Is this problem only with Google, or other HTTPS connections as well? When you get this for pretty much all secure sites, the problem usually is one of the following: (1) Error in your system's date, time, or time zone, which throws off certificate validity checks. Sometimes allowing computers to use an internet-based time source can introduce this problem. (2) Firefox not being set up to work with your security software that intercepts and filters secure connections. Products with this feature include Avast, BitDefender, ESET, and Kaspersky; AVG has a Search Shield feature which can cause this error on search sites. (3) On Windows 10, Firefox not being set up to work with the parental control software Microsoft Family Safety. (To test by turning it off, see: [http://windows.microsoft.com/en-us/windows-10/turn-off-microsoft-family-settings]) (4) Malware on your system intercepting secure connections. So... which is it? If you have any of those specific security products, that would be the first thing to check. We might be able to assist with specific next steps based on what you have if you tell us. ---- To gather further information, you could inspect a sample certificate to see whether that points to the culprit. If you want to try that now, here's how I suggest starting: Load my test page at: https://jeffersonscher.com/res/jstest.php You likely will get an error page. Expand the "I understand the risks" section and look for an Add Exception button. ''Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.'' Click Add Exception, and the certificate exception dialog should open. Click the View button. If View is not enabled, try the Get Certificate button first. This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

Question owner

The problem only occurs in Search. I haven't tried them all but it happens with Google and Yahoo.

There's no problem with other https:// url's. The only malware program I have running is Defender and there are no family exclusions.

I don't seem to be able to upload a screen image of your webpage but there seems to be no problem with it - no error. I printed it as a pdf but it hangs up when I try to add it here.

The problem only occurs in Search. I haven't tried them all but it happens with Google and Yahoo. There's no problem with other https:// url's. The only malware program I have running is Defender and there are no family exclusions. I don't seem to be able to upload a screen image of your webpage but there seems to be no problem with it - no error. I printed it as a pdf but it hangs up when I try to add it here.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Helpful Reply

That's odd, why search sites? Hmm...

To see whether there is some kind of global interception, you may want to take a look at the Google and Yahoo certificates using Edge or Chrome. If you click the padlock icon in the address bar, there should be a Certificate information/details link (either immediately or a subsequent panel). Do you notice anything unusual for the issuer of those certificates?

I have attached some screens for reference, from Windows 7, but probably Windows 10 is similar.

That's odd, why search sites? Hmm... To see whether there is some kind of global interception, you may want to take a look at the Google and Yahoo certificates using Edge or Chrome. If you click the padlock icon in the address bar, there should be a Certificate information/details link (either immediately or a subsequent panel). Do you notice anything unusual for the issuer of those certificates? I have attached some screens for reference, from Windows 7, but probably Windows 10 is similar.

Question owner

None of 1, 2, or 3 apply. I have Defender turned on. Also, RegCurePro doesn't report any malware.

and the test page opens as it should.  It doesn't provide information about certificates.

Pressing the icon in front of the URL entry (https://www.google.com/search?q=hello&ie=utf-8&oe=utf-8&gws_rd=ssl) and following the leads provided, yields the following:

Page Info - www.foxnews.com Verified by: Not Specified

None of 1, 2, or 3 apply. I have Defender turned on. Also, RegCurePro doesn't report any malware. and the test page opens as it should. It doesn't provide information about certificates. Pressing the icon in front of the URL entry (https://www.google.com/search?q=hello&ie=utf-8&oe=utf-8&gws_rd=ssl) and following the leads provided, yields the following: Page Info - www.foxnews.com Verified by: Not Specified

Question owner

I notice that my post says 2:45 pm. That must be PST because my computer reports 5:45 pm EST.

I notice that my post says 2:45 pm. That must be PST because my computer reports 5:45 pm EST.
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

You can change your time zone on this page:

https://support.mozilla.org/users/edit

Can you inspect the Google and/or Yahoo certificate using another browser to see whether they show an unusual issuer? I posted what I was seeing as of mid-November earlier in this thread: https://support.mozilla.org/questions/1094777#answer-807808

You can change your time zone on this page: https://support.mozilla.org/users/edit Can you inspect the Google and/or Yahoo certificate '''using another browser''' to see whether they show an unusual issuer? I posted what I was seeing as of mid-November earlier in this thread: https://support.mozilla.org/questions/1094777#answer-807808
jscher2000
  • Top 10 Contributor
8785 solutions 71851 answers

Chosen Solution

I'm quote the reply you posted in someone else's thread:

Chrome shows the same certificate that I imported into Firefox from the list of "Authorities". Edge doesn't show the certificate but states that the same authority "GeoTrust Global CA" which issued the Chrome and Firefox certificates identifies the site as www.google.com. As I stated, Chrome and Edge have no problem. I'm beginning to believe it's simply a Firefox bug.

Edge and Chrome should match. As far as I know, they both share the Windows certificate store, and in fact, I believe Chrome still uses the Windows certificate viewer to show the certificate, unless it changed recently or works differently on Windows 10 than on Windows 7. All browsers accessing the same site should get the same certificate hierarchy if there is no hanky panky going on.


Sometimes if Firefox is behaving strangely for no apparent reason it is caused by corrupted program files. For that we suggest:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 43.0.3 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) Rename the program folder as follows:

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Does a cleanly reinstalled Firefox search normally??

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
I'm quote the reply you posted in someone else's thread: <blockquote>Chrome shows the same certificate that I imported into Firefox from the list of "Authorities". Edge doesn't show the certificate but states that the same authority "GeoTrust Global CA" which issued the Chrome and Firefox certificates identifies the site as www.google.com. As I stated, Chrome and Edge have no problem. I'm beginning to believe it's simply a Firefox bug. </blockquote> Edge and Chrome should match. As far as I know, they both share the Windows certificate store, and in fact, I believe Chrome still uses the Windows certificate viewer to show the certificate, unless it changed recently or works differently on Windows 10 than on Windows 7. All browsers accessing the same site should get the same certificate hierarchy if there is no hanky panky going on. ---- Sometimes if Firefox is behaving strangely for no apparent reason it is caused by corrupted program files. For that we suggest: '''Clean Reinstall''' We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (A) Download a fresh installer for Firefox 43.0.3 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (B) Exit out of Firefox (if applicable). (C) Rename the program folder as follows: ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox (D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings. Does a cleanly reinstalled Firefox search normally?? Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins

Question owner

That did the trick. I now have an Old Firefox, Old Firefox 2 and a Mozilla Firefox Folder but only a single Old Firefox Data folder in the Desktop.

Thanks for all your help!

That did the trick. I now have an Old Firefox, Old Firefox 2 and a Mozilla Firefox Folder but only a single Old Firefox Data folder in the Desktop. Thanks for all your help!

Question owner

Well it worked on 1/1 to 1/3 but on 1/4 the problem suddenly returned. The only change has been the installation of a new router but how that could affect the problem I can't imagine.

Well it worked on 1/1 to 1/3 but on 1/4 the problem suddenly returned. The only change has been the installation of a new router but how that could affect the problem I can't imagine.

Question owner

It looks like Version 43.0.4 has fixed the problem.

It looks like Version 43.0.4 has fixed the problem.