X
Tap here to go to the mobile version of the site.

Support Forum

Firefox just started blocking nearly all websites, including the mozilla support website, as untrusted.

Posted

Firefox just started blocking nearly all websites, including the Firefox website, as untrusted. It won't let me add any websites to the trusted locations. I went to the Mozilla support website through Explorer and tried the fix (delete the cert8.db file and restart Firefox)but it did not work. I tried disabling ESET and restarting Firefox but that didn't work. I refreshed Firefox but that didn't work. All of my favorites work fine from Explorer. Right now Firefox is useless for me.

Firefox just started blocking nearly all websites, including the Firefox website, as untrusted. It won't let me add any websites to the trusted locations. I went to the Mozilla support website through Explorer and tried the fix (delete the cert8.db file and restart Firefox)but it did not work. I tried disabling ESET and restarting Firefox but that didn't work. I refreshed Firefox but that didn't work. All of my favorites work fine from Explorer. Right now Firefox is useless for me.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; rv:11.0) like Gecko

More Information

Shahriar Turjoe 15 solutions 70 answers

Two common reasons for this are:

(1) Problem with the system clock: date, time, or time zone differs substantially from the rest of the internet

(2) Firefox not set up to work with your security software that filters your web traffic

In order to filter secure traffic, your security software needs to present "fake" certificates to Firefox so it can be the "man in the middle" and see everything sent to and from the site. Firefox distrusts the fake certificates until instructed otherwise.

Do you use any software with that kind of feature? On Windows, products with that feature include avast! 2015, Bitdefender, ESET, and Kaspersky.

A less common problem is malware performing a "man in the middle" attack.

Two common reasons for this are: (1) Problem with the system clock: date, time, or time zone differs substantially from the rest of the internet (2) Firefox not set up to work with your security software that filters your web traffic In order to filter secure traffic, your security software needs to present "fake" certificates to Firefox so it can be the "man in the middle" and see everything sent to and from the site. Firefox distrusts the fake certificates until instructed otherwise. Do you use any software with that kind of feature? On Windows, products with that feature include avast! 2015, Bitdefender, ESET, and Kaspersky. A less common problem is malware performing a "man in the middle" attack.

Question owner

I found that by disabling SSL Protocol checking in ESET that Firefox started working again. But I have had ESET for as long as I've had Firefox. Why would the problem being now? I don't like that I have to disable a security check in order to get the browser to work. I never had this problem with any other browser.

I found that by disabling SSL Protocol checking in ESET that Firefox started working again. But I have had ESET for as long as I've had Firefox. Why would the problem being now? I don't like that I have to disable a security check in order to get the browser to work. I never had this problem with any other browser.