X
Tap here to go to the mobile version of the site.

Support Forum

video playback firefox ubuntu

Posted

Video playback is not working on firefox from firefox 42 to 43.09b3 ubuntu 15.10. Updated gstreamer 0.10 and 1.0 all packages and videos on facebook and older videos on youtube still not playing. Installed VLC plugin and yet no video. Used to play on ubuntu 15.04 without flash. Any help?

Video playback is not working on firefox from firefox 42 to 43.09b3 ubuntu 15.10. Updated gstreamer 0.10 and 1.0 all packages and videos on facebook and older videos on youtube still not playing. Installed VLC plugin and yet no video. Used to play on ubuntu 15.04 without flash. Any help?

Chosen solution

Finally, solution: Restart Firefox in safe mode and perform a refresh. Videos now playing.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Version 2.2.1 Terry Pratchett (Weatherwax), copyright 1996-2012 VideoLAN and Authorshttp://www.videolan.org/vlc/

Application

  • Firefox 43.0b3
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0/Linux/en-US/

Extensions

  • Adblock Plus 2.6.11 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • DownThemAll! 2.0.18.1-signed ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Flashblock 1.5.18.1-signed ({3d7eb24f-2740-49df-8937-200b1cc08f8a})
  • Ubuntu Modifications 3.2 (ubufox@ubuntu.com)
  • Video DownloadHelper 5.4.2 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) 915G x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Intel(R) 915G x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 1.4 Mesa 11.0.2
  • info: {u'CairoUseXRender': 1, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • supportsHardwareH264: No;
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4227 solutions 59008 answers

Helpful Reply

Your profile does not show a player. What are you using?

Flash Player (Linux) Version 11.2.202.548 https://www.adobe.com/products/flashplayer/distribution3.html


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration See also:

edit: removed sections not applicable for Flash on Linux.

Your profile does not show a player. What are you using? Flash Player (Linux) '''Version 11.2.202.548 https://www.adobe.com/products/flashplayer/distribution3.html''' -------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting''' edit: removed sections not applicable for Flash on Linux.

Modified by James

cor-el
  • Top 10 Contributor
  • Moderator
17419 solutions 157385 answers

Do you have GStreamer installed on your computer and is this enabled?

  • media.gstreamer.enabled = true

You can consider to install the Flash plugin and disable GStreamer to see if that makes the website use a Flash based player.

  • media.gstreamer.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Do you have GStreamer installed on your computer and is this enabled? *media.gstreamer.enabled = true You can consider to install the Flash plugin and disable GStreamer to see if that makes the website use a Flash based player. *media.gstreamer.enabled = false You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
James
  • Moderator
1594 solutions 11232 answers

Note that if Firefox is running when you do package updates with gstreamer and other stuff. Do quit Firefox and start it again and then try the videos.

Note that if Firefox is running when you do package updates with gstreamer and other stuff. Do quit Firefox and start it again and then try the videos.

Question owner

Purged gstreamer installed it again and restarted the computer no playback yet. Don't want to install flash with the numerous issues it has.

Checked the about:config page and media.gstreamer.enabled is set to true.

What I don't get is under 15.04 videos played well without flash until I decided to upgrade to 15.10. Maybe there is a package not installed.

Will continue searching if solution found will post it here.

Purged gstreamer installed it again and restarted the computer no playback yet. Don't want to install flash with the numerous issues it has. Checked the about:config page and media.gstreamer.enabled is set to true. What I don't get is under 15.04 videos played well without flash until I decided to upgrade to 15.10. Maybe there is a package not installed. Will continue searching if solution found will post it here.

Chosen Solution

Finally, solution: Restart Firefox in safe mode and perform a refresh. Videos now playing.

Finally, solution: Restart Firefox in safe mode and perform a refresh. Videos now playing.
FredMcD
  • Top 10 Contributor
4227 solutions 59008 answers

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know.
James
  • Moderator
1594 solutions 11232 answers

Helpful Reply

brogoti said

Finally, solution: Restart Firefox in safe mode and perform a refresh. Videos now playing.

You did not say if you restarted Firefox if it was running when you did the gstreamer and other packages installs as I suggested.

I suggested this as I reinstalled a Linux distro a few days ago and after installing a few packages to get html5 videos working, the videos not work until I restarted Firefox.

So the refresh may have not solved it but the process of restarting Firefox did.


Ok I see you restarted computer even.

Never had to do anything like create a new Profile or refresh which is essentially making a new Profile. Just a Firefox quit and startup again is all that has ever been needed. I have installed Linux at least oh ten times in past five months so I needed to install appropriate codecs and such each time. granted half of the installs were due to install not working quite right due to issues like fstab mount or sound problems and recent was because new version did not work fully and went back to last.

''brogoti [[#answer-806738|said]]'' <blockquote> Finally, solution: Restart Firefox in safe mode and perform a refresh. Videos now playing. </blockquote> You did not say if you restarted Firefox if it was running when you did the gstreamer and other packages installs as I suggested. I suggested this as I reinstalled a Linux distro a few days ago and after installing a few packages to get html5 videos working, the videos not work until I restarted Firefox. So the refresh may have not solved it but the process of restarting Firefox did. Ok I see you restarted computer even. Never had to do anything like create a new Profile or refresh which is essentially making a new Profile. Just a Firefox quit and startup again is all that has ever been needed. I have installed Linux at least oh ten times in past five months so I needed to install appropriate codecs and such each time. granted half of the installs were due to install not working quite right due to issues like fstab mount or sound problems and recent was because new version did not work fully and went back to last.

Modified by James