X
Tap here to go to the mobile version of the site.

Support Forum

How to turn off bold/italics/underline in HTML mail displayed as plaintext?

Posted

Hi!

I use Thunderbird at a workplace where HTML mail is fairly regular thing, but I prefer to hide all the HTML formatting and display it as plain text, which can be easily done by selecting View > Message Body As > Plain Text, but it seems to convert original HTML formatting to this simple plain text formatting, meaning surrounding it in * for bold, _ for underline, and / for italics, which I find annoying, because often it makes the message harder to read, e.g. inserts lots of these formatting consecutively: "*Reason for Software Replacement****Decision:*", sometimes inside words, and generally does more harm than good. It also breaks URLs, because they are displayed like this: "_https://google.com_", and Thunderbird treats trailing underline as part of URL, so the links are incorrect.

Can this whole formatting be dropped when displaying HTML as Plain Text?

Hi! I use Thunderbird at a workplace where HTML mail is fairly regular thing, but I prefer to hide all the HTML formatting and display it as plain text, which can be easily done by selecting View > Message Body As > Plain Text, but it seems to convert original HTML formatting to this simple plain text formatting, meaning surrounding it in * for bold, _ for underline, and / for italics, which I find annoying, because often it makes the message harder to read, e.g. inserts lots of these formatting consecutively: "*Reason for Software Replacement****Decision:*", sometimes inside words, and generally does more harm than good. It also breaks URLs, because they are displayed like this: "_https://google.com_", and Thunderbird treats trailing underline as part of URL, so the links are incorrect. Can this whole formatting be dropped when displaying HTML as Plain Text?

Chosen solution

As I was writing the question, I found my answer in Thunderbird config registry, but I decided to post it anyway, as I did not find It asked elsewhere. The solution is to go to Preferences > Advanced > Config Editor and set the "converter.html2txt.structs" option to false.

Read this answer in context 0

Chosen Solution

As I was writing the question, I found my answer in Thunderbird config registry, but I decided to post it anyway, as I did not find It asked elsewhere. The solution is to go to Preferences > Advanced > Config Editor and set the "converter.html2txt.structs" option to false.

As I was writing the question, I found my answer in Thunderbird config registry, but I decided to post it anyway, as I did not find It asked elsewhere. The solution is to go to '''Preferences > Advanced > Config Editor''' and set the "'''converter.html2txt.structs'''" option to false.