X
Tap here to go to the mobile version of the site.

Support Forum

How can I stop Firefox toolbar popping up when mouse is at top of screen in full-screen mode (without kiosk mode, please)?

Posted

I don't want the toolbar always there (so turning autohide off doesn't solve the issue). I'd prefer to right-click or use a keystroke to get the toolbar back. The toolbar popping up any time the mouse is near the top of the screen is too distracting. It should be an option users can turn on or off or map to something besides mouse hovering. The only solution I've seen mentioned is to go full kiosk with something like R-kiosk, but that's really too extreme a solution for such a simple problem. Is there a setting already hidden in about-config to fix this or is this a feature request? Thank you.

I don't want the toolbar always there (so turning autohide off doesn't solve the issue). I'd prefer to right-click or use a keystroke to get the toolbar back. The toolbar popping up any time the mouse is near the top of the screen is too distracting. It should be an option users can turn on or off or map to something besides mouse hovering. The only solution I've seen mentioned is to go full kiosk with something like R-kiosk, but that's really too extreme a solution for such a simple problem. Is there a setting already hidden in about-config to fix this or is this a feature request? Thank you.

Chosen solution

There is no built-in way to disable this feature to display the toolbars when you hover the mouse to the top.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#fullscr-toggler { display:none!important; }

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPWLPG
  • Shockwave Flash 19.0 r0
  • Unity Player 5.2.0f3

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157337 answers

Chosen Solution

There is no built-in way to disable this feature to display the toolbars when you hover the mouse to the top.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#fullscr-toggler { display:none!important; }

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file
There is no built-in way to disable this feature to display the toolbars when you hover the mouse to the top. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #fullscr-toggler { display:none!important; } </nowiki></pre> ---- The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive) *Paste the code in the userChrome.css file in the editor window *Make sure that the userChrome.css file starts with the default @namespace line *Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.<br>Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file

Question owner

Beautiful! Thank you!

Beautiful! Thank you!