X
Tap here to go to the mobile version of the site.

Support Forum

Removing the "Press Esc To Exit Full Screen Mode"

Posted

I use FlashPlayer to watch videos on YouTube. To get rid of the notification "Press Esc To Exit Full Screen Mode," I went to about:config and changed the value of "full-screen-api.approval-required" to false. It worked until I restarted Firefox and now it doesn't.

As a matter of fact, every time I restart Firefox, it does a lot of things against my Preferences, too. It signs me out of YouTube and every other site even though I have the box checked to NOT do that.

Any real answers or am I deleting Firefox permanently and going back to Safari?

I use FlashPlayer to watch videos on YouTube. To get rid of the notification "Press Esc To Exit Full Screen Mode," I went to about:config and changed the value of "full-screen-api.approval-required" to false. It worked until I restarted Firefox and now it doesn't. As a matter of fact, every time I restart Firefox, it does a lot of things against my Preferences, too. It signs me out of YouTube and every other site even though I have the box checked to NOT do that. Any real answers or am I deleting Firefox permanently and going back to Safari?
Attached screenshots

Additional System Details

Installed Plug-ins

  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 19.0 r0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:42.0) Gecko/20100101 Firefox/42.0

More Information

jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

First, regarding full screen: In Firefox 43 (currently in beta testing), there will be a new preference you could modify:

full-screen-api.warning.timeout => 3000

Setting that to 0 (zero milliseconds) will disable the message.

However, beta code is subject to change, and who wants to wait 6 weeks, so in a later reply I'll give you a workaround.

Second, regarding getting logged out, that is caused by clearing Cookies. Uncheck that box and try it for a few days and that should solve the problem.

First, regarding full screen: In Firefox 43 (currently in beta testing), there will be a new preference you could modify: full-screen-api.warning.timeout => 3000 Setting that to 0 (zero milliseconds) will disable the message. However, beta code is subject to change, and who wants to wait 6 weeks, so in a later reply I'll give you a workaround. Second, regarding getting logged out, that is caused by clearing Cookies. Uncheck that box and try it for a few days and that should solve the problem.
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

You can use custom style rules to modify the appearance of the full screen warning. For example:

Shrink the box and move it to the upper left corner

Placement may vary depending on your screen resolution:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);   #full-screen-warning-container {     transform: scale(0.4, 0.4) !important;     width: 300px;     height: 50px;   }

Hide the message completely

Since it always says the same thing (on Windows, press Esc, not sure on Mac):

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);   #full-screen-warning-container {     display:none !important;   }

You can apply custom style rules to Firefox's interface using either the Stylish extension or a userChrome.css file. Are you familiar with either of those?

You can use custom style rules to modify the appearance of the full screen warning. For example: '''''Shrink the box and move it to the upper left corner''''' Placement may vary depending on your screen resolution: <code>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); &nbsp;&nbsp;#full-screen-warning-container { &nbsp;&nbsp;&nbsp;&nbsp;transform: scale(0.4, 0.4) !important; &nbsp;&nbsp;&nbsp;&nbsp;width: 300px; &nbsp;&nbsp;&nbsp;&nbsp;height: 50px; &nbsp;&nbsp;}</code> '''''Hide the message completely''''' Since it always says the same thing (on Windows, press Esc, not sure on Mac): <code>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); &nbsp;&nbsp;#full-screen-warning-container { &nbsp;&nbsp;&nbsp;&nbsp;display:none !important; &nbsp;&nbsp;}</code> You can apply custom style rules to Firefox's interface using either the Stylish extension or a userChrome.css file. Are you familiar with either of those?

Question owner

jscher2000 said

You can use custom style rules to modify the appearance of the full screen warning. For example: Shrink the box and move it to the upper left corner Placement may vary depending on your screen resolution: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);   #full-screen-warning-container {     transform: scale(0.4, 0.4) !important;     width: 300px;     height: 50px;   } Hide the message completely Since it always says the same thing (on Windows, press Esc, not sure on Mac): @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);   #full-screen-warning-container {     display:none !important;   } You can apply custom style rules to Firefox's interface using either the Stylish extension or a userChrome.css file. Are you familiar with either of those?

Thank you for replying, jscher200. I'm just confused why the setting that I changed worked but only for awhile. I'm not very technologically inclined so I don't expect to understand it!

I have FireFox 42, so I'll have to wait to try your work around in about:config. As for unchecking Cookies, why is that? I've not had to do that in the past. There's a separate box for Active Log-ins that I have unchecked. Shouldn't that be enough?

Computers are getting far more complicated than they ever were in the past. I used to be able to figure this stuff out for myself, but everything keeps changing. Seems like things are getting "fixed" that were never broken.  :::sigh:::

''jscher2000 [[#answer-802631|said]]'' <blockquote> You can use custom style rules to modify the appearance of the full screen warning. For example: '''''Shrink the box and move it to the upper left corner''''' Placement may vary depending on your screen resolution: <code>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); &nbsp;&nbsp;#full-screen-warning-container { &nbsp;&nbsp;&nbsp;&nbsp;transform: scale(0.4, 0.4) !important; &nbsp;&nbsp;&nbsp;&nbsp;width: 300px; &nbsp;&nbsp;&nbsp;&nbsp;height: 50px; &nbsp;&nbsp;}</code> '''''Hide the message completely''''' Since it always says the same thing (on Windows, press Esc, not sure on Mac): <code>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); &nbsp;&nbsp;#full-screen-warning-container { &nbsp;&nbsp;&nbsp;&nbsp;display:none !important; &nbsp;&nbsp;}</code> You can apply custom style rules to Firefox's interface using either the Stylish extension or a userChrome.css file. Are you familiar with either of those? </blockquote> Thank you for replying, jscher200. I'm just confused why the setting that I changed worked but only for awhile. I'm not very technologically inclined so I don't expect to understand it! I have FireFox 42, so I'll have to wait to try your work around in about:config. As for unchecking Cookies, why is that? I've not had to do that in the past. There's a separate box for Active Log-ins that I have unchecked. Shouldn't that be enough? Computers are getting far more complicated than they ever were in the past. I used to be able to figure this stuff out for myself, but everything keeps changing. Seems like things are getting "fixed" that were never broken. :::sigh:::
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Turning off approval-required doesn't help because the message about pressing Esc is just for your information, it doesn't require your approval like the old message did.

An "Active Login" is different than a cookie. Websites ask Firefox to set cookies for the site, and to send the cookies to the site when you request pages from the site in the future. That way, the site knows your browser has logged in and gives you access without having to login again. An Active Login is for sites that use a very different method of recognizing you (usually a popup box that appears before you can access the page).

If you could previously clear cookies and still get into a site, it may be that you had saved your login in Firefox's Password Manager, and so even though the site sent a login page Firefox took care of it. Or the cookies weren't really getting deleted.

Turning off approval-required doesn't help because the message about pressing Esc is just for your information, it doesn't require your approval like the old message did. An "Active Login" is different than a cookie. Websites ask Firefox to set cookies for the site, and to send the cookies to the site when you request pages from the site in the future. That way, the site knows your browser has logged in and gives you access without having to login again. An Active Login is for sites that use a very different method of recognizing you (usually a popup box that appears before you can access the page). If you could previously clear cookies and still get into a site, it may be that you had saved your login in Firefox's Password Manager, and so even though the site sent a login page Firefox took care of it. Or the cookies weren't really getting deleted.

Question owner

jscher2000 said

You can use custom style rules to modify the appearance of the full screen warning. For example: Shrink the box and move it to the upper left corner Placement may vary depending on your screen resolution: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);   #full-screen-warning-container {     transform: scale(0.4, 0.4) !important;     width: 300px;     height: 50px;   } Hide the message completely Since it always says the same thing (on Windows, press Esc, not sure on Mac): @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);   #full-screen-warning-container {     display:none !important;   } You can apply custom style rules to Firefox's interface using either the Stylish extension or a userChrome.css file. Are you familiar with either of those?

Jenkies! This is a bit out of my league without step-by-step instructions, I'm afraid. I found the Stylish extension for Firefox and downloaded it. I don't know what to do from there. I read their instructions but everything seems to be about skins and themes. I don't see anywhere to copy and paste the:

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

 #full-screen-warning-container {
   display:none !important;
 }

Where do I go to paste this information?

''jscher2000 [[#answer-802631|said]]'' <blockquote> You can use custom style rules to modify the appearance of the full screen warning. For example: '''''Shrink the box and move it to the upper left corner''''' Placement may vary depending on your screen resolution: <code>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); &nbsp;&nbsp;#full-screen-warning-container { &nbsp;&nbsp;&nbsp;&nbsp;transform: scale(0.4, 0.4) !important; &nbsp;&nbsp;&nbsp;&nbsp;width: 300px; &nbsp;&nbsp;&nbsp;&nbsp;height: 50px; &nbsp;&nbsp;}</code> '''''Hide the message completely''''' Since it always says the same thing (on Windows, press Esc, not sure on Mac): <code>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); &nbsp;&nbsp;#full-screen-warning-container { &nbsp;&nbsp;&nbsp;&nbsp;display:none !important; &nbsp;&nbsp;}</code> You can apply custom style rules to Firefox's interface using either the Stylish extension or a userChrome.css file. Are you familiar with either of those? </blockquote> Jenkies! This is a bit out of my league without step-by-step instructions, I'm afraid. I found the Stylish extension for Firefox and downloaded it. I don't know what to do from there. I read their instructions but everything seems to be about skins and themes. I don't see anywhere to copy and paste the: @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); #full-screen-warning-container { display:none !important; } Where do I go to paste this information?

Question owner

jscher2000 said

Turning off approval-required doesn't help because the message about pressing Esc is just for your information, it doesn't require your approval like the old message did. An "Active Login" is different than a cookie. Websites ask Firefox to set cookies for the site, and to send the cookies to the site when you request pages from the site in the future. That way, the site knows your browser has logged in and gives you access without having to login again. An Active Login is for sites that use a very different method of recognizing you (usually a popup box that appears before you can access the page). If you could previously clear cookies and still get into a site, it may be that you had saved your login in Firefox's Password Manager, and so even though the site sent a login page Firefox took care of it. Or the cookies weren't really getting deleted.

I understand a bit better. (Although why they have to keep changing things that seem to be working is beyond me!) I'll try unchecking the cookie box and see how that works.

''jscher2000 [[#answer-802686|said]]'' <blockquote> Turning off approval-required doesn't help because the message about pressing Esc is just for your information, it doesn't require your approval like the old message did. An "Active Login" is different than a cookie. Websites ask Firefox to set cookies for the site, and to send the cookies to the site when you request pages from the site in the future. That way, the site knows your browser has logged in and gives you access without having to login again. An Active Login is for sites that use a very different method of recognizing you (usually a popup box that appears before you can access the page). If you could previously clear cookies and still get into a site, it may be that you had saved your login in Firefox's Password Manager, and so even though the site sent a login page Firefox took care of it. Or the cookies weren't really getting deleted. </blockquote> I understand a bit better. (Although why they have to keep changing things that seem to be working is beyond me!) I'll try unchecking the cookie box and see how that works.
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

For Stylish:

(1) Click the Stylish "s" button on the toolbar and choose Write new style, then Blank style (screen shot attached)

A new tab should open with a couple different editing areas and a few buttons. (If you want to float this in its own window, you can right-click the tab and choose Move to New Window.)

(2) Click in the larger editing area and paste the new style rule. Then click the Preview button. (screen shot attached)

Assuming there are no red error messages at the bottom of the tab, this rule is now in temporary effect and if you full screen a YouTube video, you should not see any warning message.

(3) Assuming the rule works, type a name such as Full Screen No Warning and click Save. Then you're done.

For Stylish: (1) Click the Stylish "s" button on the toolbar and choose Write new style, then Blank style (screen shot attached) A new tab should open with a couple different editing areas and a few buttons. (If you want to float this in its own window, you can right-click the tab and choose Move to New Window.) (2) Click in the larger editing area and paste the new style rule. Then click the Preview button. (screen shot attached) Assuming there are no red error messages at the bottom of the tab, this rule is now in temporary effect and if you full screen a YouTube video, you should not see any warning message. (3) Assuming the rule works, type a name such as Full Screen No Warning and click Save. Then you're done.

Question owner

jscher2000 said

For Stylish: (1) Click the Stylish "s" button on the toolbar and choose Write new style, then Blank style (screen shot attached) A new tab should open with a couple different editing areas and a few buttons. (If you want to float this in its own window, you can right-click the tab and choose Move to New Window.) (2) Click in the larger editing area and paste the new style rule. Then click the Preview button. (screen shot attached) Assuming there are no red error messages at the bottom of the tab, this rule is now in temporary effect and if you full screen a YouTube video, you should not see any warning message. (3) Assuming the rule works, type a name such as Full Screen No Warning and click Save. Then you're done.

Thanks again for all of your help, patience and instructions. I'm following along and understanding what you're saying.

I followed your instructions to the T. Every step. No error messages. I even restarted Firefox, but I'm still getting the Escape box. What did I miss?

''jscher2000 [[#answer-802697|said]]'' <blockquote> For Stylish: (1) Click the Stylish "s" button on the toolbar and choose Write new style, then Blank style (screen shot attached) A new tab should open with a couple different editing areas and a few buttons. (If you want to float this in its own window, you can right-click the tab and choose Move to New Window.) (2) Click in the larger editing area and paste the new style rule. Then click the Preview button. (screen shot attached) Assuming there are no red error messages at the bottom of the tab, this rule is now in temporary effect and if you full screen a YouTube video, you should not see any warning message. (3) Assuming the rule works, type a name such as Full Screen No Warning and click Save. Then you're done. </blockquote> Thanks again for all of your help, patience and instructions. I'm following along and understanding what you're saying. I followed your instructions to the T. Every step. No error messages. I even restarted Firefox, but I'm still getting the Escape box. What did I miss?
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Hmm, what does your rule look like? You can access it from the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click User Styles. Then on the right side an Edit button should appear for your style. Could you grab a screenshot of that style?

Hmm, what does your rule look like? You can access it from the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click User Styles. Then on the right side an Edit button should appear for your style. Could you grab a screenshot of that style?
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Helpful Reply

Since lots of people are interested in this, and it's a hassle going through the rule creation process, I went ahead and posted the rule. With Stylish already running, you can easily install it from here:

https://userstyles.org/styles/120517/hide-warning-on-html5-full-screen

Edit: Actually someone else already posted it months ago: https://userstyles.org/styles/116242/hide-firefox-fullscreen-warning

Since lots of people are interested in this, and it's a hassle going through the rule creation process, I went ahead and posted the rule. With Stylish already running, you can easily install it from here: https://userstyles.org/styles/120517/hide-warning-on-html5-full-screen ''Edit: Actually someone else already posted it months ago:'' https://userstyles.org/styles/116242/hide-firefox-fullscreen-warning

Modified by jscher2000

Question owner

I'm not using HTML5 on YouTube. I'm using FlashPlayer. I like it better since it has the "Watch Later" button on the toolbar.

Does the work around you shared work with FlashPlayer or just HTML5?

I'm not using HTML5 on YouTube. I'm using FlashPlayer. I like it better since it has the "Watch Later" button on the toolbar. Does the work around you shared work with FlashPlayer or just HTML5?
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

What I posted was only tested with HTML5 videos. I have no idea whether it works with Flash.

What I posted was only tested with HTML5 videos. I have no idea whether it works with Flash.

Question owner

Well, there you go then. I'm sure someone will find this extremely helpful since most seem to not prefer Flash Player.

Well, there you go then. I'm sure someone will find this extremely helpful since most seem to ''not'' prefer Flash Player.
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

I'm not saying it won't work with Flash, it's just that I haven't tested it. Someone should test it.

It won't work with Flash.

<s>I'm not saying it won't work with Flash, it's just that I haven't tested it. Someone should test it.</s> ''It won't work with Flash.''

Modified by jscher2000

jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Okay, I tested it. The Flash message is a different message that isn't in the same warning container.

Do you have the version that fades after a few seconds or does it persist?

If it persists:

In a prior thread, a user resolved this by completely uninstalling Flash and re-installing the latest version of the plugin.

If that doesn't fix it, you might have blocked sites from storing data on your Flash.

Okay, I tested it. The Flash message is a different message that isn't in the same warning container. Do you have the version that fades after a few seconds or does it persist? '''''If it persists:''''' In a prior thread, a user resolved this by completely uninstalling Flash and re-installing the latest version of the plugin. * Uninstaller: https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html * Latest version: https://www.adobe.com/products/flashplayer/distribution3.html (use the one for "plugin-based browsers", either EXE or MSI works) If that doesn't fix it, you might have blocked sites from storing data on your Flash. * Hulu identifies that in its support article: [http://www.hulu.com/help/articles/22497633 "Press Escape to Exit Full Screen Mode" stays on screen] * Update your setting here: http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html (Macromedia is a company acquired by Adobe, so this site is legit) * Demo video from 2011: https://www.youtube.com/watch?v=oVWbqxeyZjI
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158587 answers

Helpful Reply

Note that you can also use the code in userChrome.css.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#full-screen-warning-container{display:none!important}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

You can use this button to go to the current Firefox profile folder:

  • Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist
  • Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive)
  • Paste the code in the userChrome.css file in the editor window
  • Make sure that the userChrome.css file starts with the default @namespace line
  • Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.
    Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file
Note that you can also use the code in userChrome.css. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css ---- <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #full-screen-warning-container{display:none!important} </nowiki></pre> ---- The customization files userChrome.css (user interface) and userContent.css (websites) are located in the <b>chrome</b> folder in the Firefox profile folder. *http://kb.mozillazine.org/Editing_configuration You can use this button to go to the current Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox *Create the chrome folder (lowercase) in the <xxxxxxxx>.default profile folder if this folder doesn't exist *Use a plain text editor like Notepad to create a (new) userChrome.css file in the chrome folder (file name is case sensitive) *Paste the code in the userChrome.css file in the editor window *Make sure that the userChrome.css file starts with the default @namespace line *Make sure that you select "All files" and not "Text files" when you save the file via "Save file as" in the text editor as userChrome.css.<br>Otherwise Windows may add a hidden .txt file extension and you end up with a not working userChrome.css.txt file