Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I disable the "This Connection is untrusted" warning which pops up almost everytime I try to reach a webpage via Firefox? I am using Windows 10 64-bit.

  • 15 replies
  • 45 have this problem
  • 23154 views
  • Last reply by wtsmith

more options

I just upgraded to Windows 10 64-bit. The version of Firefox which is now running on this OS routinely displays a blocking window which tells me that "This connection is untrusted" when I attempt to connect with a third party website. A screen capture copy of the window is attached. How do I disable this warning? I cannot continue to use Firefox if I cannot find the "off" switch, which so far has eluded me.

Chosen solution

Yes, that is the feature, and it is turned on.

How it works is that ESET intercepts all of your browser connections to filter the content. If it is an HTTP connection, it's transparent. For an HTTPS connection, ESET has to present a "fake" certificate for the site to Firefox so it can be the "man in the middle" and decrypt and read the response (otherwise, it's gibberish, of course).

ESET is supposed to insert its signing certificate into both the Windows certificate store (used by IE and Chrome) AND Firefox's separate certificate store so the browser accepts the fake certificates. But it doesn't always work. In that case, you can import the certificate manually into Firefox. Hopefully that was covered in the manual, but, if not, it is roughly along these lines:

(1) Locate or save a copy of the ESET signing certificate (this is a DER-format file which usually has a .cer extension). Is your second screen shot what comes up when you click View Certificate? Try this:

  • Click the Details tab, then the button to "Copy to File". This starts the Export Wizard.
  • In the Wizard, choose the DER format and save to a convenient location (e.g., your Documents folder).

(2) Import the file into Firefox as follows:

  • In Firefox, open the Certificate Manager using:
    "3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button
  • Click the Authorities mini-tab and then the "Import" button, and find the DER file. Note: I suggest allowing the certificate for websites only.

I have attached some sample screen shots for reference.

Read this answer in context 👍 3

All Replies (15)

more options

hi, there will be a reason why this error is shown on all pages (most likely ill configured security software or malware) & we should address the root cause! first please make sure that the date, time & timezone are set correctly on your system. if this doesn't solve the issue (or it is already set properly), a possible solution depends on different factors:

  • what is the error code shown under technical details on the error page?

in case the error code equals sec_error_unknown_issuer, please attempt to add an exception on the bottom of the error page in order to inspect the certificate like it is shown on the screenshot attached:

  • which issuer information does the certificate contain?

please report back with those two pieces of information. thank you!

more options

If you have difficulty finding a site with the "Add Exception" button, you could try my test page at: https://jeffersonscher.com/res/jstest.php

After the error page loads, expand the "I understand the risks" section and look for an Add Exception button.

Note: You don't need to complete the process of adding an exception -- I suggest not adding one until we know this isn't a malware issue -- but you can use the dialog to view the information that makes Firefox suspicious.

Click Add Exception, and the certificate exception dialog should open.

Click the View button. If View is not enabled, try the Get Certificate button first.

This should pop up the Certificate Viewer. Look at the "Issued by" section, and on the Details tab, the Certificate Hierarchy. What do you see there? I have attached a screen shot for comparison.

more options

Thanks very much, Phillipp. Attached are screenshots of the Untrusted Connection window for malwarebytes.org, as well as the technical details window and the certificate issuer information shown by Firefox for this site. In this case, the first error window gave me the choice of adding this site as an exception. This does not always happen, so I picked a site which is generally understood to be “safe” to visit. Many sites are simpley rejected and no exception is offered. Let me know what you make of this information.

Additional Info: My Windows 10 64-bit system was installed by a PC Place, a professional installation and trouble-shooting business here in Albuquerque which I have used for many years. Installation was completed last Saturday. The hardware is brand new – An Asus Z170 Deluxe Mobo running a 6th generation Intel Core i5 6600 Quad Core CPU with two sticks of DDR4 Kingston memory (16 GB total), with an EVGA GTX 960 graphics card and the OS installed on a brand new Sandisk Extreme Pro SSD. All the hardware was tested, including the memory, before the OS was installed and Firefox downloaded. The Mobo drivers were updated, as were the drivers for the graphics card.

The date, time and timezone are correct, and the only AV installed on the OS is Eset NOD 32 AV (only the AV program) and Malwarebytes Anti-Malware.

I have been running Firefox on Windows 7 Home Premium (32-bit) for several years without any similar issue ever appearing. Additionally, no such issue appears on either Chrome or Edge, which are also installed on my OS.

Thanks for your help.

more options

thank you - unfortunately there was no attachment submitted, can you try again?

more options

I don't see any indication that the three jpegs I attached to my reply made it through this system. I am attaching them again (hopefully). If you don't get the images, tell me how to get them to upload.

more options

could you just transcribe what's getting displayed in the "issued by" section for us?

more options

My mistake was in using Firefox as the browser to reach this forum's url. Bad, bad mistake! I entered the forum via Edge instead, and everything is very, very different. I can even see the attachments you made to your first message! Amazing what difference one browser can make!

OK, all three jpegs are attached to this reply and I see them, so I know they are here. If you need more info, let me know.

--wts

more options

Thanks, jscher2000. See my reply to philipp. When Windows 10 was in beta test mode, apparently this issue popped up quite often, from threads I’ve googled so far. I am surprised it hasn’t been disposed of by now. I’ve read user threads more than year old in which a host of remedies was suggested based on suspected hardware and software conflicts, but the simple fact that this appears to be a Firefox issue and not one common to Chrome or Edge would indicate an incompatibility between Windows 10 64-bit and Firefox focussed on site certificates. Am I missing something?

By the way, unchecking “Query OCSP responder servers to confirm the current validity of certificates” under the Firefox Advanced Options tab has no effect on this problem.

more options

The issuer is ESET, so this issue is caused by Firefox not being fully set up to work with the Encrypted Scan/SSL Scan feature.

I looked up the user manuals earlier this year, so I don't know whether you have a newer version that has its own manual, but you could try this reply for the links I found earlier: https://support.mozilla.org/questions/1083067#answer-779844

more options

Forgive me if this requires a new thread, but for your additional info, the Firefox version now running on Windows 10 64-bit also will not render video on YouTube. And yes, I have the shockwave flash player installed in Firefox. No such problem on Chrome or Edge.

more options

Hi wtsmith, does the YouTube problem continue after solving the secure connection problem? We need to make sure it isn't blocked by that issue.

YouTube generally serves Firefox users an HTML5-based player, and Firefox needs the Windows Media Foundation to decode H.264.

First, let's see whether this is a YouTube-only issue: can you play the H.264 video on this test page: http://www.quirksmode.org/html5/tests/video.html

If it doesn't work on any site, do you maybe have an N or KN version of Windows that doesn't have the Media Feature Pack bundled in? Please see: https://www.microsoft.com/en-us/download/details.aspx?id=48231

more options

This is reply to your message regarding Eset. I found the section of the Eset manual you referred to and checked the setting in Eset as it is running on my machine. The notification mentioned was enabled in Eset. See the screen shots attached. So, I would say this is not the source of the problem, at least on its face.

more options

This is a reply to your last message about YouTube. I have no trouble playing the video (bunny under the tree). I am using Edge as my browser and that is how I accessed the video. YouTube plays normally on Edge.

more options

Chosen Solution

Yes, that is the feature, and it is turned on.

How it works is that ESET intercepts all of your browser connections to filter the content. If it is an HTTP connection, it's transparent. For an HTTPS connection, ESET has to present a "fake" certificate for the site to Firefox so it can be the "man in the middle" and decrypt and read the response (otherwise, it's gibberish, of course).

ESET is supposed to insert its signing certificate into both the Windows certificate store (used by IE and Chrome) AND Firefox's separate certificate store so the browser accepts the fake certificates. But it doesn't always work. In that case, you can import the certificate manually into Firefox. Hopefully that was covered in the manual, but, if not, it is roughly along these lines:

(1) Locate or save a copy of the ESET signing certificate (this is a DER-format file which usually has a .cer extension). Is your second screen shot what comes up when you click View Certificate? Try this:

  • Click the Details tab, then the button to "Copy to File". This starts the Export Wizard.
  • In the Wizard, choose the DER format and save to a convenient location (e.g., your Documents folder).

(2) Import the file into Firefox as follows:

  • In Firefox, open the Certificate Manager using:
    "3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button
  • Click the Authorities mini-tab and then the "Import" button, and find the DER file. Note: I suggest allowing the certificate for websites only.

I have attached some sample screen shots for reference.

more options

Wow!!! I have never had to dig this deep into an app malfunction, but your last message solved my issue very neatly! Attached is a screenshot showing Eset's signing certificate safely ensconced within the binary bowels of Firefox. I am no longer receiving the dreaded "Untrusted Connection" window and the bonus -- this also seems to have resolved the YouTube player issue. I can return to the pastures of video plenty in YouTube on my favorite browser!!!

Please stick another feather in your Master Problem Solver Cap and accept my sincere thanks!