Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Opning a new tab gives a blank screen instead of my home page (which it showed last week). How can I fix this?

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by Scribe

more options

There no longer seems to be an option to set the default page for a new tab. I would like it to default to my home page as it used to. I have gone on the user forum & followed advice to install a "Newtaburl" but this didn't work.

Chosen solution

Hi, from Firefox 41, you need to use an add-on like New Tab Override (browser.newtab.url replacement), to make changes to the New Tab page.

Once installed, open the Add-ons Manager (Ctrl+Shift+A) > Extensions, then look for New Tab Override and click on Options to set your preference.

Note, if you only want the New Tab to be the same as your Home page, you can use the add-on New Tab Homepage instead.

You may then need to restart Firefox for any changes to take effect.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Hi, from Firefox 41, you need to use an add-on like New Tab Override (browser.newtab.url replacement), to make changes to the New Tab page.

Once installed, open the Add-ons Manager (Ctrl+Shift+A) > Extensions, then look for New Tab Override and click on Options to set your preference.

Note, if you only want the New Tab to be the same as your Home page, you can use the add-on New Tab Homepage instead.

You may then need to restart Firefox for any changes to take effect.

If your question is resolved by this or another answer, please take a minute to let us know. Thank you.