Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does my "localhost" bookmark change to a Google Search?

  • 11 replies
  • 1 has this problem
  • 446 views
  • Last reply by DICKGUERTIN

more options

When I "Bookmark This Page" while viewing a localhost/~username/target.html file, the actual bookmark is initially correct, but then changes to some long Google search I did a week ago. But when I bookmark 127.0.0.1/~username/target.html, it gets bookmarked correctly and stays correct. This started happening in FF V41. I've taken screen shots to show the change from what I asked for, and what I got. Notice the time of these screen shots, and the time of the entry in Notes. The first shot is when I already have "Show All Bookmarks" open, and bookmarked the page. I then closed the Library window, and did "Show All Bookmarks" again, the entry had changed. This makes no sense to me.

Attached screenshots

Chosen solution

Well, that uRL was so long, I didn't know what it was for sure. It took me to my Google Sites page about the assistive devices problem on Yosemite.

I've circumvented THIS problem by editing my bookmarks and changing all occurrences of "//localhost" to "//127.0.0.1". That works all the time. Maybe that bad-URL was being taken from History, so I deleted my History of URLs, and now "localhost" also works properly.

Thanks for listening. I'll mark this as "Solved", although it is still a mystery.

Read this answer in context 👍 0

All Replies (11)

more options

I wonder... when you use the bookmark, does it in fact redirect to the Google login page? I wonder whether Firefox has used that past redirect information to update your bookmark, which really is not what I would expect to happen.

more options

jscher, Here's the sequence of events, which answers your question.

1) I enter a URL for a localhost file under my account, and view the page. 2) I "Bookmark This Page" in any folder. 3) I "Show All Bookmarks" and see the properly stored bookmark. 4) I close the Library window, and return to my prior page. 5) I now drop-down the Bookmarks, and click on the saved bookmark. 6) I'm taken to a Google page satisfying a search, NOT my original page. 7) I "Show All Bookmarks" again, and view my bookmark, and it has been changed into that strange Google search URL.

I can delete the bookmark, and start over, and get the same result.

Modified by DICKGUERTIN

more options

Before you ask, let me add this information. I can bookmark ANY localhost file I've got for which I don't already have a bookmark, and this same failure occurs with that bookmark. Once that altered bookmark is removed, I "Show All Bookmarks" and use "Export Bookmarks to HTML..." to save a text version of the entire Bookmark collection, and then use "grep" to search that text for any hint of the Google Search URL, and can't find it.

more options

I can't explain it.

However, please note that your second screen shot does not show a search URL. It shows a Google account login for an address that is on sites.google.com, which may be an administrative interface for your website. I don't know the connection between your localhost site and that Google Sites address, if any.

more options

Chosen Solution

Well, that uRL was so long, I didn't know what it was for sure. It took me to my Google Sites page about the assistive devices problem on Yosemite.

I've circumvented THIS problem by editing my bookmarks and changing all occurrences of "//localhost" to "//127.0.0.1". That works all the time. Maybe that bad-URL was being taken from History, so I deleted my History of URLs, and now "localhost" also works properly.

Thanks for listening. I'll mark this as "Solved", although it is still a mystery.

more options

If this happens again then you can check for problems with the places.sqlite database file (bookmarks, history) in the Firefox profile folder.

more options

That "Places Maintenance" suggestion is interesting, so I installed it, but can't figure out how to use it. The "about" for this Extension says to use the Options button of the Add-on Manager, but I can't find such a button.

more options

dickguertin said

The "about" for this Extension says to use the Options button of the Add-on Manager, but I can't find such a button.

It would be just below extension's name on the Add-ons page. Either:

  • Cmd+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then find Places Maintenance on the right side and it should have an Options button near the Disable and Remove buttons.

more options

Sorry, I still don't see it. Please look at my attached screen shot.

more options

Oh, sorry, I guess on Mac it is Preferences and not Options. This is the problem with trying to do multi-platform support when you've only ever used Windows!

more options

Well, in that case, I hold the product developer responsible for saying "Options/Preferences" to cover all bases.