X
Tap here to go to the mobile version of the site.

Support Forum

How do we disable the annoying tab function

Posted

I understand that most people are chasing and stuck with the limitations of using I-Pads (Idiot-Pads) with only two thumbs - LOL! However we use multiple displays (sometimes 2, 4 or 6 simultaneous displays depending on a client's needs) and it is desirable to NOT have the TAB function activated. There is nothing more annoying than to have a tab open every time a download is done or an app wants (immediate!) attention. It was (tab interruption) nice to (tab interruption) have (tab interruption) been able (tab interruption) to have (tab interruption) a new (tab interruption) window open and (tab interruption) to stop all (tab interruption) tabs from opening. Annoying isn't it? The "Tabs Feature" is more annoying than having spam popping up!!! We expect your product to be better than "Explorer" not the same or worst! We generally use Apple (for artistic graphics), Microsoft (for "Windows exclusive" business programs) and Linux (for Internet security) systems on various machines so we get to compare what everybody has created. We never use Linux "Unity" because it is worse than the Apple and Windows Desktops! We are not "Idiot-Pad/Phone" (oops - I-Pad/Phone) users! We are systematically migrating our clients away from Apple and Windows as Linux software improves in functionality and compatibility and provides CHOICES! Thank you

I understand that most people are chasing and stuck with the limitations of using I-Pads (Idiot-Pads) with only two thumbs - LOL! However we use multiple displays (sometimes 2, 4 or 6 simultaneous displays depending on a client's needs) and it is desirable to NOT have the TAB function activated. There is nothing more annoying than to have a tab open every time a download is done or an app wants (immediate!) attention. It was (tab interruption) nice to (tab interruption) have (tab interruption) been able (tab interruption) to have (tab interruption) a new (tab interruption) window open and (tab interruption) to stop all (tab interruption) tabs from opening. Annoying isn't it? The "Tabs Feature" is more annoying than having spam popping up!!! We expect your product to be better than "Explorer" not the same or worst! We generally use Apple (for artistic graphics), Microsoft (for "Windows exclusive" business programs) and Linux (for Internet security) systems on various machines so we get to compare what everybody has created. We never use Linux "Unity" because it is worse than the Apple and Windows Desktops! We are not "Idiot-Pad/Phone" (oops - I-Pad/Phone) users! We are systematically migrating our clients away from Apple and Windows as Linux software improves in functionality and compatibility and provides CHOICES! Thank you

Chosen solution

There are other things that need attention.

Your System Details List shows multiple Flash plugins.

  • Shockwave Flash 11.2 r202
  • Shockwave Flash 13.1 r2

The latter is probably a PepperFlash version that is installed via a wrapper.

You can find the installation path of all plugins on the about:plugins page.


Does Firefox switch to another tab or window unexpectedly?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • DivX Web Player version 1.4.0.233
  • Next Generation Java Plug-in 11.60.2 for Mozilla browsers
  • The Videos 3.10.1 plugin handles video and audio streams.
  • Shockwave Flash 13.1 r2
  • Shockwave Flash 11.2 r202
  • will start external gxine media player for embedded media streams
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

I don't understand your question since it's full of half-rant / half-incoherent ramblings about iPads, but if you care to rephrase it in a way that actually makes sense and isn't trying to be "clever" then we can try to help.

I don't understand your question since it's full of half-rant / half-incoherent ramblings about iPads, but if you care to rephrase it in a way that actually makes sense and isn't trying to be "clever" then we can try to help.

Helpful Reply

To rephrase the question. It is EXTREMELY ANNOYING to have "Tabs" popping up when we don't want any tabs AT ALL. It is understood that this alleged feature is put in to accommodate the mass migration to the various "Pads" and "Smart Phones" but the rest of us would like to get some meaningful work done to pay for all this!

HOW CAN THE TABS BE COMPLETELY SHUT OFF!!!

To rephrase the question. It is EXTREMELY ANNOYING to have "Tabs" popping up when we don't want any tabs AT ALL. It is understood that this alleged feature is put in to accommodate the mass migration to the various "Pads" and "Smart Phones" but the rest of us would like to get some meaningful work done to pay for all this! HOW CAN THE TABS BE COMPLETELY SHUT OFF!!!
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

First off, tabs have been around for many years, and have absolutely nothing to do with touch-screen mobile devices. https://en.wikipedia.org/wiki/Tab_%28GUI%29

If you would like links to not open in a new tab, simply uncheck "Open new windows in a new tab instead" in the Firefox options. There is however, no way to completely disable tabs, just as there is no way to completely disable opening a new window.

First off, tabs have been around for many years, and have absolutely nothing to do with touch-screen mobile devices. https://en.wikipedia.org/wiki/Tab_%28GUI%29 If you would like links to not open in a new tab, simply uncheck "Open new windows in a new tab instead" in the Firefox options. There is however, no way to completely disable tabs, just as there is no way to completely disable opening a new window.

Question owner

Thank you for your prompt reply. Previous versions of Firefox did in fact allow us to un-check the "Open in new tab" function. This version (v39.0) however seems to ignore that setting (all the tab setting boxes are unchecked)! We are tiring of hearing all of the complaints coming from our clients, as much as we like promoting Firefox, my boss is demanding a workaround! Thank you!

Thank you for your prompt reply. Previous versions of Firefox did in fact allow us to un-check the "Open in new tab" function. This version (v39.0) however seems to ignore that setting (all the tab setting boxes are unchecked)! We are tiring of hearing all of the complaints coming from our clients, as much as we like promoting Firefox, my boss is demanding a workaround! Thank you!
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

That setting works for me, please try testing with Firefox 40 in safe mode to rule out any addons. If it still happens,please clearly explain what exactly is happening.

That setting works for me, please try testing with Firefox 40 in safe mode to rule out any addons. If it still happens,please clearly explain what exactly is happening.

Question owner

Thank you again. We have updated ver 39.0 to ver 40.0.3 and now have a new set of problems on top of the original ones. Now when we try to respond to your email link all we get is a blank/locked page. This reply was only possible when we entered Safe mode after trying numerous variations to respond to your email which had worked before. While calmer now due to your helpful support we did have to cancel appointments with clients who are desperate to have this problem (and now the new one) resolved. Thank you

Thank you again. We have updated ver 39.0 to ver 40.0.3 and now have a new set of problems on top of the original ones. Now when we try to respond to your email link all we get is a blank/locked page. This reply was only possible when we entered Safe mode after trying numerous variations to respond to your email which had worked before. While calmer now due to your helpful support we did have to cancel appointments with clients who are desperate to have this problem (and now the new one) resolved. Thank you
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

If this works in safe mode, it sounds like one of the modifications or extensions you have is causing all the trouble. Try disabling your extensions or using a Firefox refresh to further troubleshoot.

If this works in safe mode, it sounds like one of the modifications or extensions you have is causing all the trouble. Try disabling your extensions or using a Firefox refresh to further troubleshoot.
fruitklah 0 solutions 18 answers

Tyler Downer said

First off, tabs have been around for many years, and have absolutely nothing to do with touch-screen mobile devices. https://en.wikipedia.org/wiki/Tab_%28GUI%29 If you would like links to not open in a new tab, simply uncheck "Open new windows in a new tab instead" in the Firefox options. There is however, no way to completely disable tabs, just as there is no way to completely disable opening a new window.

This, also was helpful. Also one can just right click and open a link in a new window...

''Tyler Downer [[#answer-781288|said]]'' <blockquote> First off, tabs have been around for many years, and have absolutely nothing to do with touch-screen mobile devices. https://en.wikipedia.org/wiki/Tab_%28GUI%29 If you would like links to not open in a new tab, simply uncheck "Open new windows in a new tab instead" in the Firefox options. There is however, no way to completely disable tabs, just as there is no way to completely disable opening a new window. </blockquote> This, also was helpful. Also one can just right click and open a link in a new window...
cor-el
  • Top 10 Contributor
  • Moderator
17473 solutions 157940 answers

Chosen Solution

There are other things that need attention.

Your System Details List shows multiple Flash plugins.

  • Shockwave Flash 11.2 r202
  • Shockwave Flash 13.1 r2

The latter is probably a PepperFlash version that is installed via a wrapper.

You can find the installation path of all plugins on the about:plugins page.


Does Firefox switch to another tab or window unexpectedly?

There are other things that need attention. Your System Details List shows multiple Flash plugins. * Shockwave Flash 11.2 r202 * Shockwave Flash 13.1 r2 The latter is probably a PepperFlash version that is installed via a wrapper. You can find the installation path of all plugins on the <b>about:plugins</b> page. *http://kb.mozillazine.org/Issues_related_to_plugins#Identifying_installed_plugins ---- Does Firefox switch to another tab or window unexpectedly?

Helpful Reply

Thank you for all your help. We solved the problem by ourselves. First, many of us have been working with computers since the 1960's and when one says that a computer program "can't" or won't do something it usually means that someone either does not know or does not want to do that thing usually what one would expect from Microsoft or Apple programmers! That is why we prefer the various Linux Distros. Fortunately it is the practice of our company to make Image copies of client systems using Live CD's like Acronis or Clonezilla. Windows 10 seems to be trying to block that ability! After following the previous instructions to "Upgrade Firefox" our test computer died completely (rebooting repeatedly). We then installed a fresh, new copy of Ubuntu 14.04.3 and a fresh new copy of Firefox. Pointing out the duplicity of Shockwave plugins provided us with an important clue and reminder that simply "installing updates" can lead to a lot of additional problems in and of itself. We teach our clients to never "backup to the Cloud" and ALWAYS store data on separate LOCAL hard drives or LOCAL LAN Drives! The hard part is keeping backup lists of all software added to any given system and to keep track of plugins, and other add ons to Firefox in a simple and easily restorable fashion. Thank you again we hope this helps others as well.

Thank you for all your help. We solved the problem by ourselves. First, many of us have been working with computers since the 1960's and when one says that a computer program "can't" or won't do something it usually means that someone either does not know or does not want to do that thing usually what one would expect from Microsoft or Apple programmers! That is why we prefer the various Linux Distros. Fortunately it is the practice of our company to make Image copies of client systems using Live CD's like Acronis or Clonezilla. Windows 10 seems to be trying to block that ability! After following the previous instructions to "Upgrade Firefox" our test computer died completely (rebooting repeatedly). We then installed a fresh, new copy of Ubuntu 14.04.3 and a fresh new copy of Firefox. Pointing out the duplicity of Shockwave plugins provided us with an important clue and reminder that simply "installing updates" can lead to a lot of additional problems in and of itself. We teach our clients to never "backup to the Cloud" and ALWAYS store data on separate LOCAL hard drives or LOCAL LAN Drives! The hard part is keeping backup lists of all software added to any given system and to keep track of plugins, and other add ons to Firefox in a simple and easily restorable fashion. Thank you again we hope this helps others as well.