X
Tap here to go to the mobile version of the site.

Support Forum

Why won't Firefox open pages (including Google.com) but Chrome works fine (opens all pages)?

Posted

Firefox had always been my preferred and default browser. For the last month or so, it won't open any pages (except two or three that I'm guessing are cached in the history) but Google Chrome opens everything just fine (so internet connection doesn't appear to be the issue). I am trying to run Firefox 40.0.3 on a Dell with Windows 7 Home Premium (64-bit OS) from my home (cable internet with no proxy). I have Avast Free Antivirus, Malwarebytes Anti-malware and Spybot Free version installed. (I know someone will tell me not to have each of those on my machine and though the person who responds to this will undoubtedly know more than me, I have run this machine [and others] with those 3 programs for years with no problem). I do have some stupid McAfee product that I can't seem to totally get rid of that appears to be set up (from/by the manufacturer) to manage certain operations - including the firewall. The McAfee "LiveSafe - Internet Security" wants me to "buy a subscription no to stay protected."

I have tried everything written on any problem even remotely related to my problem and nothing works (reinstalled FF and other programs, deleted cert8.db files, and on and on). I honestly wonder why I even care enough to keep spending valuable time trying to find a solution - Firefox has just been such a good product for such a long time, I hate to let it totally go. Please help!!

Firefox had always been my preferred and default browser. For the last month or so, it won't open any pages (except two or three that I'm guessing are cached in the history) but Google Chrome opens everything just fine (so internet connection doesn't appear to be the issue). I am trying to run Firefox 40.0.3 on a Dell with Windows 7 Home Premium (64-bit OS) from my home (cable internet with no proxy). I have Avast Free Antivirus, Malwarebytes Anti-malware and Spybot Free version installed. (I know someone will tell me not to have each of those on my machine and though the person who responds to this will undoubtedly know more than me, I have run this machine [and others] with those 3 programs for years with no problem). I do have some stupid McAfee product that I can't seem to totally get rid of that appears to be set up (from/by the manufacturer) to manage certain operations - including the firewall. The McAfee "LiveSafe - Internet Security" wants me to "buy a subscription no to stay protected." I have tried everything written on any problem even remotely related to my problem and nothing works (reinstalled FF and other programs, deleted cert8.db files, and on and on). I honestly wonder why I even care enough to keep spending valuable time trying to find a solution - Firefox has just been such a good product for such a long time, I hate to let it totally go. Please help!!

Chosen solution

What security software (Anti-Virus, firewall) do you have?

There is security software like Avast and Kaspersky that intercept secure connections and send their own certificate.

If you have Avast then try to disable HTTPS scanning in Avast Web Shield.


If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/45.0.2454.85 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
3735 solutions 51350 answers

What is your computer system and Firefox?

Do you get any error messages?

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network. Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use No Proxy. If there is a problem, then try System Proxy.


Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}


http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html

https://support.mozilla.org/en-US/kb/server-not-found-connection-problem

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites

This Connection is Untrusted is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

What is your computer system and Firefox? Do you get any error messages? Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''Network.''' Look for '''Configure How Firefox Connects''' and press the '''Settings''' button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first use '''No Proxy.''' If there is a problem, then try '''System Proxy.''' ------------ Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again; * Make sure your Internet security software is up-to-date (i.e. you are running the latest version). * Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see '''[https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet Configure firewalls so that Firefox can access the Internet.]''' {web link} ---------------------------- http://www.ehow.com/how_11385212_troubleshoot-reset-connection-firefox.html https://support.mozilla.org/en-US/kb/server-not-found-connection-problem https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message '''http://kb.mozillazine.org/Error_loading_websites''' '''This Connection is Untrusted''' is sometimes caused because the computer system clock is wrong. Check the time / date / time zone settings.

Question owner

I am trying to run Firefox 40.0.3 on a Dell with Windows 7 Home Premium (64-bit OS) from my home (cable internet with no proxy).

The message is always "this connection is untrusted" . . . . with the "technical details" saying:

www.google.com [any website url] uses an invalid security certificate.

The certificate is not trusted because the issuer certificate is unknown.

The server might not be sending the appropriate intermediate certificates.

An additional root certificate may need to be imported.

(Error code: sec_error_unknown_issuer)


Thanks for the links, I have been to everyone of those pages and none of the suggestions make the change needed for a page to load.

I am trying to run Firefox 40.0.3 on a Dell with Windows 7 Home Premium (64-bit OS) from my home (cable internet with no proxy). The message is always "this connection is untrusted" . . . . with the "technical details" saying: www.google.com [any website url] uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer) Thanks for the links, I have been to everyone of those pages and none of the suggestions make the change needed for a page to load.
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149981 answers

Chosen Solution

What security software (Anti-Virus, firewall) do you have?

There is security software like Avast and Kaspersky that intercept secure connections and send their own certificate.

If you have Avast then try to disable HTTPS scanning in Avast Web Shield.


If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

What security software (Anti-Virus, firewall) do you have? There is security software like Avast and Kaspersky that intercept secure connections and send their own certificate. If you have Avast then try to disable HTTPS scanning in Avast Web Shield. *http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/ *https://forum.avast.com/index.php?topic=176073.0 ---- If you can't inspect the certificate via "I Understand the Risks" then try this: Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate: *chrome://pippki/content/exceptionDialog.xul In the location field of this window type or paste the URL of the website. *retrieve the certificate via the "Get certificate" button *click the "View..." button to inspect the certificate in the Certificate Viewer You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

Modified by cor-el

Question owner

Thank you, this was new information (finally!!). I used Google.com for the url of the website and the certificate said it was issued by ContentWatch (which is the company that operates NetNanny software - which I use to filter web content when my boys are on the computer). I disabled that program temporarily and Firefox immediately loaded search results and any page I tried to open. I'm confident that ContentWatch is the issue. Now I'll just have to figure out what is happening with that program but I am so glad to know the source of the problem. Thank you so much!! I don't see a way to give you positive feedback but please, please let me know if I can somehow/somewhere. You have my gratitude!!

Thank you, this was new information (finally!!). I used Google.com for the url of the website and the certificate said it was issued by ContentWatch (which is the company that operates NetNanny software - which I use to filter web content when my boys are on the computer). I disabled that program temporarily and Firefox immediately loaded search results and any page I tried to open. I'm confident that ContentWatch is the issue. Now I'll just have to figure out what is happening with that program but I am so glad to know the source of the problem. Thank you so much!! I don't see a way to give you positive feedback but please, please let me know if I can somehow/somewhere. You have my gratitude!!
5mohsen5 0 solutions 2 answers

I have same problem :((

When I enter the chrome://pippki/content/exceptionDialog.xul in addressbar , in certificate viwer show this message :

issued by : Kaspersky Anti-Virus Personal Root Certificate AO Kaspersky Lab <Not Part Of Certificate>

I have same problem :(( When I enter the chrome://pippki/content/exceptionDialog.xul in addressbar , in certificate viwer show this message : issued by : Kaspersky Anti-Virus Personal Root Certificate AO Kaspersky Lab <Not Part Of Certificate>

Modified by 5mohsen5

cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149981 answers

Hi 5mohsen5

If the certificate is issued by your Kaspersky security software then you have two options:

Hi 5mohsen5 If the certificate is issued by your Kaspersky security software then you have two options: *disable scanning secure connections in Kaspersky *install the Kaspersky root certificate.<br />When prompted set the trust bit to use the certificate to "Trust this CA to identify websites"<br>http://support.kaspersky.com/us/9093#block1<br>http://support.kaspersky.com/us/9927#block1