X
Tap here to go to the mobile version of the site.

Support Forum

Can I kill HTML5 video process?

Posted

My PC becomes unresponsive after several days without a reboot. I open several tabs and use Facebook, watch YouTube videos, and read worthless Yahoo news. Ever since HTML5 videos have replaced Flash, my WinXP PC has required more frequent reboots of Firefox and of the PC, itself. I used to be able to open Task Manger and kill "plug-in container" and everything would be fine. Is there such an option for HTML5 videos? Note: I have No Script installed. Even with No Script, the HTML5 videos auto-load and slow down my machine, as they add up and don't let go of memory.

Thanks for volunteering and helping the community. We appreciate it.

My PC becomes unresponsive after several days without a reboot. I open several tabs and use Facebook, watch YouTube videos, and read worthless Yahoo news. Ever since HTML5 videos have replaced Flash, my WinXP PC has required more frequent reboots of Firefox and of the PC, itself. I used to be able to open Task Manger and kill "plug-in container" and everything would be fine. Is there such an option for HTML5 videos? Note: I have No Script installed. Even with No Script, the HTML5 videos auto-load and slow down my machine, as they add up and don't let go of memory. Thanks for volunteering and helping the community. We appreciate it.

Additional System Details

Installed Plug-ins

  • Adobe Acrobat Plug-In Version 6.00 for Netscape
  • GEPlugin
  • Google Update
  • MetaStream 3 Plugin r4
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 15.0 r0
  • VLC media player Web Plugin 2.0.6
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • Firefox 41.0b5
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:41.0) Gecko/20100101 Firefox/41.0
  • Support URL: https://support.mozilla.org/1/firefox/41.0/WINNT/en-US/

Extensions

  • NoScript 2.6.9.36 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: RADEON X300 SE 128MB HyperMemory
  • adapterDescription2:
  • adapterDeviceID: 0x5b60
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 06021002
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'9.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 8-3-2005
  • driverDate2:
  • driverVersion: 8.162.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4220 solutions 58899 answers

If you can go without video for a few days,

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac:<Command>) <Shift> A)

On the left side of the page, select Plugins. Locate HTML5, and disable it.

Then give your system a good run.

If you can go without video for a few days, Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac:<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins.''' Locate HTML5, and disable it. Then give your system a good run.
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

You can try to click the "Minimize memory usage" button on the about:memory page.

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to click the "Minimize memory usage" button on the about:memory page. You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
jscher2000
  • Top 10 Contributor
8632 solutions 70597 answers

The Question Details > More System Details next to your post shows an out-of-date version of Flash. If you prefer to use Flash for videos, you can update it here:

https://www.adobe.com/products/flashplayer/distribution3.html

In the first table, look for the row for "plugin-based browsers" and you can use either the EXE or the MSI installer.

To ensure that the old version is removed, please close any tabs that are using Flash, or exit out of Firefox, during the update.

Next, if YouTube is the main culprit, you may need to force Flash on YouTube using one of these extensions (either one, you don't need both):

The Question Details > More System Details next to your post shows an out-of-date version of Flash. If you prefer to use Flash for videos, you can update it here: https://www.adobe.com/products/flashplayer/distribution3.html In the first table, look for the row for "plugin-based browsers" and you can use either the EXE or the MSI installer. To ensure that the old version is removed, please close any tabs that are using Flash, or exit out of Firefox, during the update. Next, if YouTube is the main culprit, you may need to force Flash on YouTube using one of these extensions (either one, you don't need both): * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/ * https://addons.mozilla.org/firefox/addon/youtube-flash-player/
jscher2000
  • Top 10 Contributor
8632 solutions 70597 answers

By the way, does the preference to stop HTML5 videos from autoplaying work for you?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media and pause while the list is filtered

(3) Double-click the media.autoplay.enabled preference to switch it from true to false.

I don't know whether that takes effect immediately on the next page reload, or whether you need to exit Firefox and start it up again.

By the way, does the preference to stop HTML5 videos from autoplaying work for you? (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media''' and pause while the list is filtered (3) Double-click the '''media.autoplay.enabled''' preference to switch it from true to false. I don't know whether that takes effect immediately on the next page reload, or whether you need to exit Firefox and start it up again.