Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access addons.cdn.mozilla.net

  • 8 replies
  • 15 have this problem
  • 117 views
  • Last reply by eiddon

more options

When I try to download addons they have errors, and some pages don't allow access due to certificate problems. On the network tool it shows addons.cdn.mozilla.net has a bad certificate and won't accept anything from it.

When I try to download addons they have errors, and some pages don't allow access due to certificate problems. On the network tool it shows addons.cdn.mozilla.net has a bad certificate and won't accept anything from it.

Chosen solution

please try to disable https scanning within avast:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok.

http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

Read this answer in context 👍 5

All Replies (8)

more options

hi, what error message/error code are you receiving when you try to access https://addons.cdn.mozilla.net/static/img/app-icons/med/firefox.png directly?

more options

Secure Connection Failed

An error occurred during a connection to addons.cdn.mozilla.net. Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

I'm using Windows 10, but after I did a refresh I couldn't download any addons and a lot of pages stopped working. In the Network tool it flagged the addons.cdn.mozilla.net.

more options

which anti-virus software are you using?

more options

Avast. As far as I can tell, Firefox is whitelisted.

more options

Chosen Solution

please try to disable https scanning within avast:

  1. Open the Avast dashboard on the affected system.
  2. Select Settings from the left sidebar menu.
  3. Switch to Active Protection.
  4. Click on Customize next to Web Shield.
  5. Uncheck the "Enable HTTPS Scanning" option and click ok.

http://www.ghacks.net/2014/10/31/avasts-https-scanning-interferes-with-firefox-and-other-programs/

more options

Well it works. Should I leave it off?

more options

yes, please - i'm not sure what kind of weirdness avast is performing there...

more options

Hahaha, ok then. Thank you!