Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed + Web pages loading as plain

  • 8 replies
  • 1 has this problem
  • 34 views
  • Last reply by cor-el

more options

So about 90% of the websites I try to access or when using google as search engine via Mozilla start up page I get a message that Secure Connection Failed. ( Bing works to some extend )

I have tried reinstalling Firefox 4 times, deleting all possible files that may be linked to it. Tried even installing older version of Firefox. I tried to start in safe mode and refreshing Firefox ( resetting )

I tried to change proxy server settings and hardware settings that are suggested in help pages.

Nothing works.

When I do get into a webpage it looks like the plain blue text and white background no images load etc.

NOTE: other web browsers works but would really love to have Mozilla working still!

All Replies (8)

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open this chrome URI by pasting or typing this URI in the location/address bar to open the "Add Security Exception" window and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field type/paste the URL of the website

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate.

more options

When I use that link in Chrome I get message that page not is not available.

more options

You need to paste the link in the Firefox location/address bar to open the Add Security Exception page in a tab.

Firefox uses the "chrome://" protocol to access its own internal files and also access files from extensions (no connection with Google Chrome).

more options

Oh ok! My bad!

Ok, so I have tried this and this is the result.

Tells me that no information available. ( posted a picture to show )

Tried with a few websites.

more options

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that has effect.

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

No viruses or malware were found however Mozilla works slightly better now. Every website does not give secure connection failed, mainly parts of websites now.

more options

My problem is that since I updated to the latest version of Firefox and the latest version of Kaspersky, every time I try to search for a website, I get this screen. It won't let me "add exception". It won't let me do anything. Help.

more options

If you can't inspect the certificate via "I Understand the Risks" then try this:

Open the "Add Security Exception" window by pasting this chrome URL in the Firefox location/address bar and check the certificate:

  • chrome://pippki/content/exceptionDialog.xul

In the location field of this window type or paste the URL of the website.

  • retrieve the certificate via the "Get certificate" button
  • click the "View..." button to inspect the certificate in the Certificate Viewer

You can inspect details like the issuer and the certificate chain in the Details tab of the Certificate Viewer. Check who is the issuer of the certificate. If necessary then you can attach a screenshot that shows the certificate viewer.

If the certificate is issued by your Kaspersky security software then you have two options:

  • disable scanning secure connections in Kaspersky
  • install the Kaspersky root certificate.

When prompted set the trust bit to use the certificate to "Trust this CA to identify websites"
http://support.kaspersky.com/us/9093#block1
http://support.kaspersky.com/us/9927#block1