X
Tap here to go to the mobile version of the site.

Support Forum

Needing to disable smooth scrolling and hardware acceleration for users on a Remote Desktop Session.

Posted

Hello, I need to disable smooth scrolling and hardware acceleration for any user that logs into a RDS server. I have messed the mozilla.cfg and created a autoconfig.js file. I guess I am missing something along the way.

This is currently my autoconfig.js pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 1); pref("app.update.channel", "release");

Mozilla.cfg // Smooth Scrolling Disabled lockpref("general.smoothScroll.disabled", true); // disables hardware acceleration lockPref("layers.acceleration.disabled", true); lockPref("gfx.direct2d.disabled", true);


Anything I am missing? When I restart both options are still checked in the options.

Thanks!!

Hello, I need to disable smooth scrolling and hardware acceleration for any user that logs into a RDS server. I have messed the mozilla.cfg and created a autoconfig.js file. I guess I am missing something along the way. This is currently my autoconfig.js pref("general.config.filename", "mozilla.cfg"); pref("general.config.obscure_value", 1); pref("app.update.channel", "release"); Mozilla.cfg // Smooth Scrolling Disabled lockpref("general.smoothScroll.disabled", true); // disables hardware acceleration lockPref("layers.acceleration.disabled", true); lockPref("gfx.direct2d.disabled", true); Anything I am missing? When I restart both options are still checked in the options. Thanks!!

Chosen solution

hi b1gt3x, as you use a plaintext cfg file, you'll want to put this in your autoconfig.js intead:

pref("general.config.obscure_value", 0);
pref("general.config.filename", "mozilla.cfg");

also, you'll have to make it lockPref with a capital P in all instances - as this is reacting very sensitive to spelling errors.. http://kb.mozillazine.org/Locking_preferences.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.125 Safari/537.36

More Information

philipp
  • Top 10 Contributor
  • Moderator
4881 solutions 21607 answers

Chosen Solution

hi b1gt3x, as you use a plaintext cfg file, you'll want to put this in your autoconfig.js intead:

pref("general.config.obscure_value", 0);
pref("general.config.filename", "mozilla.cfg");

also, you'll have to make it lockPref with a capital P in all instances - as this is reacting very sensitive to spelling errors.. http://kb.mozillazine.org/Locking_preferences.

hi b1gt3x, as you use a plaintext cfg file, you'll want to put this in your autoconfig.js intead: pref("general.config.obscure_value", '''0'''); pref("general.config.filename", "mozilla.cfg"); also, you'll have to make it lockPref with a capital P in all instances - as this is reacting very sensitive to spelling errors.. http://kb.mozillazine.org/Locking_preferences.

Question owner

Awesome! That got the Hardware acceleration part.

Am I also missing something to disable smooth scrolling? // Smooth Scrolling Disabled lockPref("general.smoothScroll.disabled", True);

// disables hardware acceleration lockPref("layers.acceleration.disabled", true); lockPref("gfx.direct2d.disabled", true);

Awesome! That got the Hardware acceleration part. Am I also missing something to disable smooth scrolling? // Smooth Scrolling Disabled lockPref("general.smoothScroll.disabled", True); // disables hardware acceleration lockPref("layers.acceleration.disabled", true); lockPref("gfx.direct2d.disabled", true);

Question owner

Here is a screen shot of what I need disabled and grayed out. Hardware acceleration is good now. Just need "Use Smooth Scrolling" disabled as well.

Here is a screen shot of what I need disabled and grayed out. Hardware acceleration is good now. Just need "Use Smooth Scrolling" disabled as well.
cor-el
  • Top 10 Contributor
  • Moderator
15847 solutions 143356 answers

Helpful Reply

Try this for smooth scroll:

// always make sure to start mozilla.cfg with an comment line

// Smooth Scrolling Disabled
lockPref("general.smoothScroll", false);

// disables hardware acceleration
lockPref("layers.acceleration.disabled", true);
lockPref("gfx.direct2d.disabled", true);

(edited to restore lost line breaks)

Try this for smooth scroll: <pre><nowiki>// always make sure to start mozilla.cfg with an comment line // Smooth Scrolling Disabled lockPref("general.smoothScroll", false); // disables hardware acceleration lockPref("layers.acceleration.disabled", true); lockPref("gfx.direct2d.disabled", true); </nowiki></pre> ''(edited to restore lost line breaks)''

Modified by cor-el

philipp
  • Top 10 Contributor
  • Moderator
4881 solutions 21607 answers

Helpful Reply

try this:

// Smooth Scrolling Disabled
lockPref("general.smoothScroll", false);
try this: // Smooth Scrolling Disabled lockPref("general.smoothScroll", false);

Question owner

Awesome guys it worked. Much appreciated!

Awesome guys it worked. Much appreciated!