X
Tap here to go to the mobile version of the site.

Support Forum

Disable hardware acceleration to fix graphics glitches and crashes.

Posted

A couple weeks ago, Thunderbird updated itself, and my email life went to hell. The screen kept going black. Often all the icons on the email folders were missing. I often had to minimize and reopen Thunderbird to see anything. I was killing it and restarting it maybe 8 times a day when it hung completely. It crashed itself, and sent error reports, maybe 20 times a day. Absolutely horrible.

I finally found this article, that explains how to disable hardware acceleration:

http://www.askvg.com/how-to-disable-hardware-acceleration-gpu-rendering-in-mozilla-firefox-4-0-to-fix-font-problem/

That worked. Apparently in one of the recent updates, Thunderbird turned hardware acceleration on, when for my system, it needed to be off. (I dimly remember turning it off before.)

A couple weeks ago, Thunderbird updated itself, and my email life went to hell. The screen kept going black. Often all the icons on the email folders were missing. I often had to minimize and reopen Thunderbird to see anything. I was killing it and restarting it maybe 8 times a day when it hung completely. It crashed itself, and sent error reports, maybe 20 times a day. Absolutely horrible. I finally found this article, that explains how to disable hardware acceleration: http://www.askvg.com/how-to-disable-hardware-acceleration-gpu-rendering-in-mozilla-firefox-4-0-to-fix-font-problem/ That worked. Apparently in one of the recent updates, Thunderbird turned hardware acceleration on, when for my system, it needed to be off. (I dimly remember turning it off before.)

Chosen solution

In addition, there is a simple switch off in Options.

'Tools' > 'Options' > 'Advanced' > 'General' tab or 'Menu icon' > 'Options' > 'Options' > 'Advanced' > 'General' tab

To switch off: uncheck 'Use hardware acceleration when available' click on 'OK'.

Read this answer in context 5

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

Toad-Hall
  • Top 10 Contributor
1326 solutions 8690 answers

Chosen Solution

In addition, there is a simple switch off in Options.

'Tools' > 'Options' > 'Advanced' > 'General' tab or 'Menu icon' > 'Options' > 'Options' > 'Advanced' > 'General' tab

To switch off: uncheck 'Use hardware acceleration when available' click on 'OK'.

In addition, there is a simple switch off in Options. 'Tools' > 'Options' > 'Advanced' > 'General' tab or 'Menu icon' > 'Options' > 'Options' > 'Advanced' > 'General' tab To switch off: uncheck 'Use hardware acceleration when available' click on 'OK'.

Question owner

Thank you much, Toad-Hall! Very timely, too. I was just contemplating whether to install the latest Thunderbird update, when the last one gave me grief for a week...

Thank you much, Toad-Hall! Very timely, too. I was just contemplating whether to install the latest Thunderbird update, when the last one gave me grief for a week...

Helpful Reply

P.S. This option is new. I was using Thunderbird 36.0, which did not include the hardware acceleration option on Tools > Options > Advanced > General.

P.S. This option is new. I was using Thunderbird 36.0, which did not include the hardware acceleration option on Tools > Options > Advanced > General.