X
Tap here to go to the mobile version of the site.

Support Forum

disable built in flash blocker

Posted

I hate the new built in flash blocker, too much trouble to allow and disallow for certain sites and NO way to just allow for parts of a site.

Is there a way to disable it entirely? And, hopefully, allow the good old flashblock add-on that worked FLAWLESSLY to work again?

I don't understand why developers make changes that violate the old saying "If it ain't broke, don't fix it.".

I hate the new built in flash blocker, too much trouble to allow and disallow for certain sites and NO way to just allow for parts of a site. Is there a way to disable it entirely? And, hopefully, allow the good old flashblock add-on that worked FLAWLESSLY to work again? I don't understand why developers make changes that violate the old saying "If it ain't broke, don't fix it.".

Chosen solution

You can ask your questions here;

Add-on home page http://flashblock.mozdev.org/

Support site http://flashblock.mozdev.org/contact.html

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • LastPass Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • npsdcwc.dll
  • Unity Player 5.0.3f2

Application

  • Firefox 39.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:39.0) Gecko/20100101 Firefox/39.0
  • Support URL: https://support.mozilla.org/1/firefox/39.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.9.1-signed ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Boomerang for GMail 1.2.4 ({65e41d20-f092-41b7-bb83-c6e8a9ab0f57})
  • Classic Theme Restorer 1.3.5 (ClassicThemeRestorer@ArisT2Noia4dev)
  • Download YouTube Videos as MP4 1.8.3.1-signed ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • DuckDuckGo Plus 0.4.6.1-signed (jid1-ZAdIEUB7XOzOJw@jetpack)
  • Element Hiding Helper for Adblock Plus 1.3.2.1-signed (elemhidehelper@adblockplus.org)
  • Flash and Video Download 1.73 ({bee6eb20-01e0-ebd1-da83-080329fb9a3a})
  • Google Voice 5.2.1-signed (gvoice@elijahclark.com)
  • LastPass 3.2.16a (support@lastpass.com)
  • OperaView 0.7.1-signed ({87f54a61-c9b3-4138-a38a-33c31770bb9e})
  • Print Edit 15.9 (printedit@DW-dev)
  • QuickJava 2.0.6.1-signed ({E6C1199F-E687-42da-8C24-E7770CC3AE66})
  • Switch to Tab no more 0.2.1-signed ({7edcdfc0-3056-11e0-91fa-0800200c9a66})
  • Xmarks 4.3.7.1-signed (foxmarks@kei.com)
  • Copy As Plain Text 1.0.9.1-signed ({1a5dabbd-0e74-41da-b532-a364bb552cab}) (Inactive)
  • Dragon NaturallySpeaking Rich Internet Application Support 1.0.0.9 (jid0-lmZNVK7a82O8cufhdfB9dUDfA2w@jetpack) (Inactive)
  • FoxBleed 0.1.1-signed (jid1-Ni8A2ixlGmYBiw@jetpack) (Inactive)
  • Ghostery 5.4.5.1-signed (firefox@ghostery.com) (Inactive)
  • IE Tab 2 (FF 3.6+) 5.12.12.1.1-signed ({1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) 82945G Express Chipset Family (Microsoft Corporation - WDDM 1.0)
  • adapterDescription2:
  • adapterDeviceID: 0x2772
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igdumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 2a5e103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.17795
  • driverDate: 10-1-2012
  • driverDate2:
  • driverVersion: 8.15.10.2697
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedDriver']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11 WARP

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4250 solutions 59440 answers

There is no built in flash blocker except for the user settings.

Can you give more information?

Flash block {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

There is no built in flash blocker except for the user settings. Can you give more information? '''[https://addons.mozilla.org/en-US/firefox/addon/flashblock/ Flash block]''' {web link} Never be annoyed by a Flash animation again! Blocks Flash so it won't get in your way, but if you want to see it, just click on it

Question owner

OK, built in User Settings regarding Flash being activated (not blocked), never activate (blocked), ask to activate (a pain to change back and forth should I change my mind).

I want to remove/disable/not have this option IN firefox so the old, easier to use and NOT broken flashblock (that you posted a link to and doesn't work since this stupid "user setting" was put into Firefox) add-on will work again.

OK, built in User Settings regarding Flash being activated (not blocked), never activate (blocked), ask to activate (a pain to change back and forth should I change my mind). I want to remove/disable/not have this option IN firefox so the old, easier to use and NOT broken flashblock (that you posted a link to and doesn't work since this stupid "user setting" was put into Firefox) add-on will work again.
Enul 1 solutions 3 answers

Hello rwernst150716! Thank you for your question. There should be also another option "Allow and remember". Please try to use that if you really want to keep using Adobe's flash player. By doing so, Mozilla's announcer never pops out anymore.

PS: I have also done that on a friends computer, that needs flash for some websites that still use it.

Hello rwernst150716! Thank you for your question. There should be also another option "Allow and remember". Please try to use that if you really want to keep using Adobe's flash player. By doing so, Mozilla's announcer never pops out anymore. PS: I have also done that on a friends computer, that needs flash for some websites that still use it.

Modified by Enul

Question owner

Maybe I asked the wrong question. Perhaps I should have asked if there's a way to have the old flashblock add on work in current Firefox, either by disabling(?)/removing/??? the built in user setting for flash, or modifying how Firefox uses the add-on which I preferred vastly to this one.

Maybe I asked the wrong question. Perhaps I should have asked if there's a way to have the old flashblock add on work in current Firefox, either by disabling(?)/removing/??? the built in user setting for flash, or modifying how Firefox uses the add-on which I preferred vastly to this one.
FredMcD
  • Top 10 Contributor
4250 solutions 59440 answers

Helpful Reply

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac:<Command>)<Shift> A)

On the left side of the page, select Plugins.

Look for flash (For some reason, Flash is listed as Shockwave Flash) plugin, and set it to Always.

Note: If you changed the flash settings on any specific sites, you must change these back to default.

Last note. FlashBlock will stop all flash viewers until you start them. But you can select web sites where you don't want the flash blocked.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''<Control>''(Mac:<Command>)''<Shift> A)''' On the left side of the page, select '''Plugins.''' Look for flash (For some reason, Flash is listed as Shockwave Flash) plugin, and set it to '''Always.''' Note: If you changed the flash settings on any specific sites, you must change these back to default. Last note. FlashBlock will stop all flash viewers until you start them. But you can select web sites where you don't want the flash blocked.

Question owner

Thanks all, I give up. I reinstalled the add on flashblock 1.5.18.1 (not updated since 2013) and it doesn't seem to work at all any more. What happened originally is some things (flash pages) wouldn't work at all once Firefox added it's user setting for activating/etc. flash.

Is there a way to close this thread and just leave it as unsolved? I don't want to mark it as solved since the problem still exists. I'll just have to live with it as I have for quite a while now.

Thanks all, I give up. I reinstalled the add on flashblock 1.5.18.1 (not updated since 2013) and it doesn't seem to work at all any more. What happened originally is some things (flash pages) wouldn't work at all once Firefox added it's user setting for activating/etc. flash. Is there a way to close this thread and just leave it as unsolved? I don't want to mark it as solved since the problem still exists. I'll just have to live with it as I have for quite a while now.
FredMcD
  • Top 10 Contributor
4250 solutions 59440 answers

Chosen Solution

You can ask your questions here;

Add-on home page http://flashblock.mozdev.org/

Support site http://flashblock.mozdev.org/contact.html

You can ask your questions here; Add-on home page http://flashblock.mozdev.org/ Support site http://flashblock.mozdev.org/contact.html