Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In the field where one would enter a web address, when I click on the arrow to show recent history nothing happens.

  • 5 replies
  • 1 has this problem
  • 3 views
  • Last reply by cor-el

more options

As in the question, clicking the button between the web address and the reload current page icon, nothing happens. I don't see any settings that would have turned this off. The box to remember downloads and browsing is checked

As in the question, clicking the button between the web address and the reload current page icon, nothing happens. I don't see any settings that would have turned this off. The box to remember downloads and browsing is checked

All Replies (5)

more options

Hi, try clicking on Restore Defaults as shown in this article - Customize Firefox controls, buttons and toolbars.

If that doesn't work Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Hi Scribe

I currently surf in private mode and I get nothing either. Can "private mode" be the simple solution?

Sorry for butting in.........

B.R.

Modified by Bobby R.

more options

In PB mode you do not retain history, so there is nothing to show.

You can check the setting for the location bar in "Options > Privacy".

  • Tools > Options > Privacy > Location Bar: When using the location bar, suggest:
History
Bookmarks
Open tabs
more options

Hi cor-el,

Well, I just noticed it earlier and just thought I put it out there (someone, like me, has to dare to ask the stupid questions too), but then I "unchecked" private mode and still nothing.

Again, sorry for butting in......

   B.R:
more options

You can check for problems with the places.sqlite database file in the Firefox profile folder.

You can also check browser.urlbar prefs on the about:config page to see if they have the default value.

  • browser.urlbar.autocomplete.enabled
  • browser.urlbar.maxRichResults

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.