Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Something strange about firefox.exe AND plugin-container.exe

  • 3 replies
  • 6 have this problem
  • 1 view
  • Last reply by elzach

more options

Since yesterday something very strange is happening with firefox.exe and plugin-container.exe.

Just a minute ago for example, firefox.exe was stuck at 50% of CPU, overheating my computer, the plugin-container.exe was NOT running AND when I exited FF, firefox.exe was still in the task manager taking up its 50% of CPU.

Has anyone ever seen anything similar?

It's not happening every time I start FF, but it's already happened twice today. Right now plugin-container.exe is still NOT running.

Any suggestions are welcome. I do have an outdated Shockwave flash 14.0

All Replies (3)

more options

Hi elzach, not that your firefox is outdated also (current version is 38.0.5), and xp the same :-), i also use xp and from time to time i have the same behavior if i use older versions.

Maybe it is time to update Firefox to the latest version, update plugins also, leave only xp without upgrade :-)


thank you

more options

It's happening more often now. Basically plugin-container.exe is not loading and firefox.exe gets stuck.

I'll see if I can update.

Thanks!

more options

I just updated to FF 38.0.5 and I also updated the Flash plugin to 17.0

It seems to have alleviated the problem. I say "alleviated" because I still see 40-60% of CPU on firefox.exe SOMETIMES (on Yahoo Mail for example).

Can you tell me under what circumstances plugin-container.exe is supposed to be running?? Right now it's not loaded.

The only thing I definitely don't like is that my tiles on new tab were reduced from 8-9 to 4! Gone are my facebook, bank etc tiles. Can I get them back? Why only 4 tiles?!