X
Tap here to go to the mobile version of the site.

Support Forum

firefox 38 unable to decode mp3 files

Posted

I am using Ubuntu 14.04 with Firefox 38 and since I updated to that version of Firefox I am unnable to use SoundCloud and TuneIn Radio websites.

On both websites I get the error: media resource ... could not be decoded

I already checked this post (https://support.mozilla.org/es/questions/999164) where somebody had the same problem on Win 7, Firefox 28, but the answer there is not possible for me as my firefox doesn't have those configurations :(

I also disabled all of my add-ons, but still not working :'(

Any help, is welcome :)

I am using Ubuntu 14.04 with Firefox 38 and since I updated to that version of Firefox I am unnable to use SoundCloud and TuneIn Radio websites. On both websites I get the error: media resource ... could not be decoded I already checked this post (https://support.mozilla.org/es/questions/999164) where somebody had the same problem on Win 7, Firefox 28, but the answer there is not possible for me as my firefox doesn't have those configurations :( I also disabled all of my add-ons, but still not working :'( Any help, is welcome :)

Chosen solution

Hey, I understand that a video with an .mp3 extension gives the error: "could not be decoded", I am happy to help.

Even though linux does not have the about:config entries for the windows media player, there might be an alternative player that can play this file type.

Do you have Flash loading in this page as well? There was another solution for your operating system, try gstreamer. Please note that there is a 32 bit version and 64bit, I believe the former is mentioned here:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • The IcedTea-Web Plugin executes Java applets.
  • Shockwave Flash 11.2 r202

Application

  • Firefox 38.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0/Linux/es-ES/

Extensions

  • Adblock Plus Pop-up Addon 0.9.2.1-signed (adblockpopups@jessehakanen.net) (Inactive)
  • Blur (Formerly DoNotTrackMe) 4.5.1334.1-signed (donottrackplus@abine.com) (Inactive)
  • InstantFox 3.0.0.1-signed (searchy@searchy) (Inactive)
  • National Geographic NewTab 1.4.1-signed ({4d4f5a49-4c4c-4100-0002-4e4557544142}) (Inactive)
  • Pocket 3.0.6.1-signed (isreaditlater@ideashower.com) (Inactive)
  • ProxMate 4.1.2.1-signed (jid1-QpHD8URtZWJC2A@jetpack) (Inactive)
  • Ubuntu Firefox Modifications 3.0 (ubufox@ubuntu.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
  • adapterDeviceID: Mesa DRI Intel(R) Ironlake Mobile
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 2.1 Mesa 10.1.3
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Chosen Solution

Hey, I understand that a video with an .mp3 extension gives the error: "could not be decoded", I am happy to help.

Even though linux does not have the about:config entries for the windows media player, there might be an alternative player that can play this file type.

Do you have Flash loading in this page as well? There was another solution for your operating system, try gstreamer. Please note that there is a 32 bit version and 64bit, I believe the former is mentioned here:

Hey, I understand that a video with an .mp3 extension gives the error: "could not be decoded", I am happy to help. Even though linux does not have the about:config entries for the windows media player, there might be an alternative player that can play this file type. Do you have Flash loading in this page as well? There was another solution for your operating system, try gstreamer. Please note that there is a 32 bit version and 64bit, I believe the former is mentioned here: *[http://www.reddit.com/r/Ubuntu/comments/35gtp8/fix_broken_html5_mp3_and_m4a_firefox_audio_in/]

Helpful Reply

guigs2 said

Hey, I understand that a video with an .mp3 extension gives the error: "could not be decoded", I am happy to help. Even though linux does not have the about:config entries for the windows media player, there might be an alternative player that can play this file type. Do you have Flash loading in this page as well? There was another solution for your operating system, try gstreamer. Please note that there is a 32 bit version and 64bit, I believe the former is mentioned here:

Hey guigs2, Thanks a lot for your answer, it solved my problem. I just installed the gstreamer1.0-plugins-ugly from my Software Center on Ubuntu and firefox inmediately recognize it; no changes necesary on about:config.

Just as a final note, as said on the reedit post, this website helped me recognize which formats were working and which were not, and sadly even after solving my problem, the ".flac" file-format is still unnable to play. So far, this doesn't affect me, but maybe it could be usefull for someone else =D

''guigs2 [[#answer-737539|said]]'' <blockquote> Hey, I understand that a video with an .mp3 extension gives the error: "could not be decoded", I am happy to help. Even though linux does not have the about:config entries for the windows media player, there might be an alternative player that can play this file type. Do you have Flash loading in this page as well? There was another solution for your operating system, try gstreamer. Please note that there is a 32 bit version and 64bit, I believe the former is mentioned here: *[http://www.reddit.com/r/Ubuntu/comments/35gtp8/fix_broken_html5_mp3_and_m4a_firefox_audio_in/] </blockquote> Hey guigs2, Thanks a lot for your answer, it solved my problem. I just installed the gstreamer1.0-plugins-ugly from my Software Center on Ubuntu and firefox inmediately recognize it; no changes necesary on about:config. Just as a final note, as said on the reedit post, this [http://hpr.dogphilosophy.net/test/index.php website] helped me recognize which formats were working and which were not, and sadly even after solving my problem, the ".flac" file-format is still unnable to play. So far, this doesn't affect me, but maybe it could be usefull for someone else =D