X
Tap here to go to the mobile version of the site.

Support Forum

Cannot get Firefox to Save a Password if you didn't Save it When First Entered

Posted

If I visit a new site and create an account, it prompts me to save the password. If I accidentally or otherwise click outside of that box, it goes away and Firefox will no longer ask me if I want to save that password/log-in combo when I revisit the site. I have looked at the password list and the exceptions lists, and nothing shows for the sites in question. Please tell me how I can get Firefox to prompt me again and allow me to save these log ins.

If I visit a new site and create an account, it prompts me to save the password. If I accidentally or otherwise click outside of that box, it goes away and Firefox will no longer ask me if I want to save that password/log-in combo when I revisit the site. I have looked at the password list and the exceptions lists, and nothing shows for the sites in question. Please tell me how I can get Firefox to prompt me again and allow me to save these log ins.

Additional System Details

Installed Plug-ins

  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.6
  • 5.1.30514.0

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Ghostery 5.4.5 (firefox@ghostery.com)
  • Video DownloadHelper 5.2.0 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Blur (Formerly DoNotTrackMe) 4.5.1334 (donottrackplus@abine.com) (Inactive)
  • Flashblock 1.5.18 ({3d7eb24f-2740-49df-8937-200b1cc08f8a}) (Inactive)
  • MaskMe 1.40.366 (idme@abine.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x 8a4
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x10de
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: NVIDIA Corporation -- NVIDIA GeForce 320M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Could you try the Permissions Manager: in a new tab, type or paste about:permissions in the address bar and press Enter/Return.

Firefox will scan through your settings files for permission settings. While it's loading, you can use the search box above the list in the left column to filter down to the login site.

Click the login site in the left column and on the right, if the "Store Passwords" permission is set to Block, change it to Allow.

If you return to the login site in another tab and log out/log in again, does Firefox offer to remember the password?

Could you try the Permissions Manager: in a new tab, type or paste '''about:permissions''' in the address bar and press Enter/Return. Firefox will scan through your settings files for permission settings. While it's loading, you can use the search box above the list in the left column to filter down to the login site. Click the login site in the left column and on the right, if the "Store Passwords" permission is set to Block, change it to Allow. If you return to the login site in another tab and log out/log in again, does Firefox offer to remember the password?

Question owner

I tried your suggestion and it did not work. I also deleted a cookie from the site in an attempt to correct the problem as well.

I tried your suggestion and it did not work. I also deleted a cookie from the site in an attempt to correct the problem as well.
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hmm, Firefox may have stored your preference not to be bothered by the dialog in an obscure location. You can erase Firefox's memory of everything about the site by using the "Forget about this site" feature. It is very thorough, removing history, cookies, site-specific zoom levels, even bookmarks for the site. If you want to try that, there is button on the upper-right corner of the about:permissions page when you have a specific site selected.

Maybe someone else can propose a less drastic next step.

Hmm, Firefox may have stored your preference not to be bothered by the dialog in an obscure location. You can erase Firefox's memory of ''everything'' about the site by using the "Forget about this site" feature. It is very thorough, removing history, cookies, site-specific zoom levels, even bookmarks for the site. If you want to try that, there is button on the upper-right corner of the about:permissions page when you have a specific site selected. Maybe someone else can propose a less drastic next step.

Question owner

Alas, that did not work either. There were three entries for the site, and I had Firefox forget them all. Restarted Firefox, still no prompt to remember. Hard to understand why they made it default to not be asked again when it is so hard to reverse...

Alas, that did not work either. There were three entries for the site, and I had Firefox forget them all. Restarted Firefox, still no prompt to remember. Hard to understand why they made it default to not be asked again when it is so hard to reverse...

Modified by FirefoxQuestions

jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Wow, after that Firefox should have behaved like it was your first visit ever to the site. Could you double-check that the password manager is still enabled in Preferences? See: Password Manager - Remember, delete and edit logins and passwords in Firefox.


Some sites add autocomplete="off" to block browsers from saving logins. By default, Firefox ignores this. Could you check that the hidden setting has not been switched:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste signon and pause while the list is filtered

(3) If the signon.storeWhenAutocompleteOff preference is bolded and "user set" to false, double-click it to restore the default value of true


Other than that, I'm out of ideas.

Wow, after that Firefox should have behaved like it was your first visit ever to the site. Could you double-check that the password manager is still enabled in Preferences? See: [[Password manager - Remember, delete and change saved passwords in Firefox]]. ---- Some sites add autocomplete="off" to block browsers from saving logins. By default, Firefox ignores this. Could you check that the hidden setting has not been switched: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''signon''' and pause while the list is filtered (3) If the '''signon.storeWhenAutocompleteOff''' preference is bolded and "user set" to false, double-click it to restore the default value of true ---- Other than that, I'm out of ideas.

Question owner

Sadly, it is already set to true.... thanks ever so much for your help.

Sadly, it is already set to true.... thanks ever so much for your help.
cor-el
  • Top 10 Contributor
  • Moderator
17472 solutions 157915 answers

Did you check if there is a key icon on the at the left end of location/address bar?

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Did you check if there is a key icon on the at the left end of location/address bar? You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page. Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of the involved files. It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

Modified by cor-el