X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

ssl_error_bad_mac_alert and will not connect to wireless network

Posted

I sure would like to solve this. I was using Safari on my 2008 Mac and then it became outdated on some websites so I switched to Firefox. I am using a wireless connection supplied by the RV park that we are in with a password. I must use Safari to log in then I can use Firefox once that I am connected. (Firefox 38.0.1). Is there some way to disable whatever security line is causing this problem. I also use Firefox on a windows7 laptop from time to time with no problems. So far this is the only problem that I have found since installing Firefox on the Mac.

I sure would like to solve this. I was using Safari on my 2008 Mac and then it became outdated on some websites so I switched to Firefox. I am using a wireless connection supplied by the RV park that we are in with a password. I must use Safari to log in then I can use Firefox once that I am connected. (Firefox 38.0.1). Is there some way to disable whatever security line is causing this problem. I also use Firefox on a windows7 laptop from time to time with no problems. So far this is the only problem that I have found since installing Firefox on the Mac.

Chosen solution

I understand that it also does work on other browsers, but there may or may not be an issue with the network.

If the service has some form of security, the ssl might be the issue. This error came up a bit when they changed the security policy in Firefox in the last two versions. If you are interested in the details, check out the blog here and the new security certificate: https://www.mozilla.org/en-US/about/g.../policy/

There were two work arounds to narrow down which one it was:

  • Note this is not secure: Change the fallback configuration back to 1.0

security.tls.version.fallback-limit = 1 In order to change your Firefox Configuration please do the following steps :

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. search for fallback, doubleclick on the entry and change 3 to 1.



I am not sure how your internet is setup, you could try to change the dns server in your computer settings to 8.8.8.8 which is Google's open dns server. (DNS is like a phonebook for websites)

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Office Live Update v1.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 17.0 r0
  • Web based SlingPlayer for streaming from Slingbox
  • iPhoto6

Application

  • Firefox 38.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:38.0) Gecko/20100101 Firefox/38.0
  • Support URL: https://support.mozilla.org/1/firefox/38.0.1/Darwin/en-US/

Extensions

  • Adblock Plus 2.6.9 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • SSL Version Control 0.4 (jid1-ZM3BerwS6FsQAg@jetpack)
  • Webmail Ad Blocker 4.28 (gmailnoads@mywebber.com)
  • YouTube ALL HTML5 2.1.3 (jid1-qj0w91o64N7Eeg@jetpack)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x2a02
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel GMA X3100 OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Hi Peon, To check the theory where a security setting is an issue, is it possible to share a screenshot of the security information of the webpage from the working Windows 7 machine?

The Encryption information on this menu: Right click on the webpage > Select "Show Page Info" > Click on the Security Tab

If you have a url, we can test and troubleshoot this together, however if it is network dependent please also contact your network administrator.

Hi Peon, To check the theory where a security setting is an issue, is it possible to share a screenshot of the security information of the webpage from the working Windows 7 machine? The Encryption information on this menu: Right click on the webpage > Select "Show Page Info" > Click on the Security Tab If you have a url, we can test and troubleshoot this together, however if it is network dependent please also contact your network administrator.

Helpful Reply

Sorry but I have been gone for a week. Well I also made a mistake in the original question. The Windows7 machine will not log in either with Firefox but will work with Explorer. Interesting that Safari and Explorer will work but Firefox on either of the computers will not. It may in fact be the wireless network in the RV park but they will not admit to it. Everybody that is using a Mac is using Safari and all the Windows machines are using Explorer or Chrome and here I am using what I like. Really there must me something I can change to get it to work.

Sorry but I have been gone for a week. Well I also made a mistake in the original question. The Windows7 machine will not log in either with Firefox but will work with Explorer. Interesting that Safari and Explorer will work but Firefox on either of the computers will not. It may in fact be the wireless network in the RV park but they will not admit to it. Everybody that is using a Mac is using Safari and all the Windows machines are using Explorer or Chrome and here I am using what I like. Really there must me something I can change to get it to work.

Question owner

More info: I did look at the network login and it is not encrypted. I examined it with Firefox when it would not work just to see if I could see anything strange. Firefox did post a caution that it was not encrypted and that someone could see what I was doing. Once that I am on the network with Safari or Explorer and then go back and look at it now the network is encrypted. Don't know whether that will help to solve the problem but I am at wits end.

More info: I did look at the network login and it is not encrypted. I examined it with Firefox when it would not work just to see if I could see anything strange. Firefox did post a caution that it was not encrypted and that someone could see what I was doing. Once that I am on the network with Safari or Explorer and then go back and look at it now the network is encrypted. Don't know whether that will help to solve the problem but I am at wits end.
guigs 1072 solutions 11697 answers

Chosen Solution

I understand that it also does work on other browsers, but there may or may not be an issue with the network.

If the service has some form of security, the ssl might be the issue. This error came up a bit when they changed the security policy in Firefox in the last two versions. If you are interested in the details, check out the blog here and the new security certificate: https://www.mozilla.org/en-US/about/g.../policy/

There were two work arounds to narrow down which one it was:

  • Note this is not secure: Change the fallback configuration back to 1.0

security.tls.version.fallback-limit = 1 In order to change your Firefox Configuration please do the following steps :

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise! to continue to the about:config page.
  3. search for fallback, doubleclick on the entry and change 3 to 1.



I am not sure how your internet is setup, you could try to change the dns server in your computer settings to 8.8.8.8 which is Google's open dns server. (DNS is like a phonebook for websites)

I understand that it also does work on other browsers, but there may or may not be an issue with the network. If the service has some form of security, the ssl might be the issue. This error came up a bit when they changed the security policy in Firefox in the last two versions. If you are interested in the details, check out the blog [https://blog.mozilla.org/security/ here] and the new security certificate: [https://www.mozilla.org/en-US/about/governance/policies/security-group/certs/policy/] There were two work arounds to narrow down which one it was: *[http://mzl.la/1BAQlkP Enable SSL to fix the Firefox cannot connect securely error message] *Note this is not secure: Change the fallback configuration back to 1.0 security.tls.version.fallback-limit = 1 In order to change your Firefox Configuration please do the following steps : # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''' to continue to the about:config page. # search for fallback, doubleclick on the entry and change 3 to 1. I am not sure how your internet is setup, you could try to change the dns server in your computer settings to 8.8.8.8 which is Google's open dns server. (DNS is like a phonebook for websites)