X
Tap here to go to the mobile version of the site.

Support Forum

When I press "fullscreen" in any video player on any website, Firefox makes the switch super slowly and pauses video (but not audio) while switching. Help?

Posted

Whenever I'm watching a video on youtube or any other website, and I press the button in the player to make it fullscreen, the process of going from small-to-big makes my video pause but the audio continues going, and the whole process takes so much time it makes me never want to use Firefox. The same process repeats when exiting fullscreen.

In addition, an annoying dialogue box pops up demanding I allow or deny permission to enter fullscreen. After following the advice on the support site, I tried going to tools > page info > permissions and toggling "enter fullscreen", but that didn't help at all, and nothing was mentioned about the slow and choppy switching problem.  I also tried turning off my add-ons and plug-ins. Didn't work for either getting rid of the permission box or speeding things up.

This problem used to be limited to only some video players, and thank God Youtube was spared. Now, as of the last update I think, YouTube is painfully slow as well. Any help would be much appreciated!!!

Whenever I'm watching a video on youtube or any other website, and I press the button in the player to make it fullscreen, the process of going from small-to-big makes my video pause but the audio continues going, and the whole process takes so much time it makes me never want to use Firefox. The same process repeats when exiting fullscreen. In addition, an annoying dialogue box pops up demanding I allow or deny permission to enter fullscreen. After following the advice on the support site, I tried going to tools > page info > permissions and toggling "enter fullscreen", but that didn't help at all, and nothing was mentioned about the slow and choppy switching problem. I also tried turning off my add-ons and plug-ins. Didn't work for either getting rid of the permission box or speeding things up. This problem used to be limited to only some video players, and thank God Youtube was spared. Now, as of the last update I think, YouTube is painfully slow as well. Any help would be much appreciated!!!

Additional System Details

Installed Plug-ins

  • Provides information about the default web browser
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Version 5.41.0.0
  • Displays Java applet content, or a placeholder if Java is not installed.
  • npmnqmp 071706000001
  • NortonInternetSecurityBF 2.7.1 with BrowserFramework 1.11.0, © 2015 Symantec Corporation. All rights reserved.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:38.0) Gecko/20100101 Firefox/38.0

More Information

{
"application": {
"name": "Firefox",
"version": "38.0.1",
"buildID": "20150513174244",
"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:38.0) Gecko/20100101 Firefox/38.0",
"updateChannel": "release",
"supportURL": "https://support.mozilla.org/1/firefox/38.0.1/Darwin/en-US/",
"numTotalWindows": 2,
"numRemoteWindows": 0,
"remoteAutoStart": false
},
"lockedPreferences": {},
"graphics": {
"numTotalWindows": 2,
"numAcceleratedWindows": 2,
"windowLayerManagerType": "OpenGL",
"windowLayerManagerRemote": true,
"adapterDescription": "",
"adapterVendorID": "0x10de",
"adapterDeviceID": "0x 863",
"adapterRAM": "",
"adapterDrivers": "",
"driverVersion": "",
"driverDate": "",
"webglRenderer": "NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine",
"info": {
"AzureCanvasBackend": "quartz",
"AzureSkiaAccelerated": 0,
"AzureFallbackCanvasBackend": "none",
"AzureContentBackend": "quartz"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.10.8",
"version": "4.10.8"
},
"NSS": {
"minVersion": "3.18.1 Basic ECC",
"version": "3.18.1 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.18.1",
"version": "3.18.1"
},
"NSSSSL": {
"minVersion": "3.18.1 Basic ECC",
"version": "3.18.1 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.18.1 Basic ECC",
"version": "3.18.1 Basic ECC"
}
},
"userJS": {
"exists": false
},
"extensions": [
{
"name": "Norton Identity Toolbar for Firefox",
"version": "1.11.0f7",
"isActive": true,
"id": "nortonconfidential@symantec.com"
},
{
"name": "Thumbnail Zoom Plus",
"version": "3.4",
"isActive": true,
"id": "thumbnailZoom@dadler.github.com"
},
{
"name": "WOT",
"version": "20131118",
"isActive": true,
"id": "{a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7}"
},
{
"name": "YouTube High Definition",
"version": "37.1",
"isActive": true,
"id": "{7b1bf0b6-a1b9-42b0-b75d-252036438bdc}"
},
],
"experiments": [],
"modifiedPreferences": {}
}

FredMcD
  • Top 10 Contributor
4229 solutions 59021 answers

Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?


If you have problems with current Shockwave Flash plugin versions then check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

'''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} While you are in safe mode; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites. Are there any problems? --------------------------------- If you have problems with current Shockwave Flash plugin versions then check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Question owner

Thanks for taking the time to try and help me! I really appreciate it.

I tried everything you suggested, except for disabling protected mode in Flash, since it wasn't clear how to do it (I'm using Mac OS X) and I'm not sure I'd be comfortable using unprotected flash after reading the warnings.

Any other suggestions? Thanks.

Thanks for taking the time to try and help me! I really appreciate it. I tried everything you suggested, except for disabling protected mode in Flash, since it wasn't clear how to do it (I'm using Mac OS X) and I'm not sure I'd be comfortable using unprotected flash after reading the warnings. Any other suggestions? Thanks.
jscher2000
  • Top 10 Contributor
8640 solutions 70690 answers

Is YouTube using the HTML5 player or the Flash player on Mac? You may be able to tell using one of these methods:

This would be helpful in diagnosing whether it's a Flash problem or a native video player problem.

Is YouTube using the HTML5 player or the Flash player on Mac? You may be able to tell using one of these methods: * right-click (Ctrl+click?) the player and check the last item on the context menu * check: https://www.youtube.com/html5 This would be helpful in diagnosing whether it's a Flash problem or a native video player problem.
cor-el
  • Top 10 Contributor
  • Moderator
17422 solutions 157425 answers

I think that this is the way that switching to full screen mode on Mac works and you need to accept this. This is done by the Mac OS and Firefox uses the API that OS X offers and can take more time..


  • bug 739012 - [10.7] DOM/video full-screen transition uses two stages on Lion
I think that this is the way that switching to full screen mode on Mac works and you need to accept this. This is done by the Mac OS and Firefox uses the API that OS X offers and can take more time.. ---- *[https://bugzilla.mozilla.org/show_bug.cgi?id=739012 bug 739012] - [10.7] DOM/video full-screen transition uses two stages on Lion

Question owner

jscher2000: Thanks for the info. It says it's the HTML5 player, so I guess that means its a native video player problem?

cor-el: I think you're right about it. Thanks for the link. I opened it and indeed the thread seems to describe my issue perfectly.

Has anyone using Firefox on Mac OS X 10.9.5 noticed the slow transition to fullscreen and found a fix? It seems to me that if this is the standard practice now with Firefox, many people will choose a different browswer. I love Firefox, but if making a video go full-screen comes at the cost of actually seeing the full video, I'm not sure I understand how this "bug" hasn't been fixed in the last 3 years.

Anyone else have any ideas? Have the same problem on Mac OS X 10.9?

(thanks again to cor-el and jscher2000)

jscher2000: Thanks for the info. It says it's the HTML5 player, so I guess that means its a native video player problem? cor-el: I think you're right about it. Thanks for the link. I opened it and indeed the thread seems to describe my issue perfectly. Has anyone using Firefox on Mac OS X 10.9.5 noticed the slow transition to fullscreen and found a fix? It seems to me that if this is the standard practice now with Firefox, many people will choose a different browswer. I love Firefox, but if making a video go full-screen comes at the cost of actually seeing the full video, I'm not sure I understand how this "bug" hasn't been fixed in the last 3 years. Anyone else have any ideas? Have the same problem on Mac OS X 10.9? (thanks again to cor-el and jscher2000)
jscher2000
  • Top 10 Contributor
8640 solutions 70690 answers

If this is a recent problem, maybe try one of the extensions to force Flash on YouTube. For example:

If this is a recent problem, maybe try one of the extensions to force Flash on YouTube. For example: * https://addons.mozilla.org/firefox/addon/youtube-flash-video-player/