X
Tap here to go to the mobile version of the site.

Support Forum

Firefox slows to a crawl while Syncing bookmarks

Posted

Every time I add, edit, move, or delete a bookmark, Firefox slows to a crawl for a few seconds while Sync does its thing. I know Sync is the issue because I've added the Sync icon to the toolbar and see it light up and spin and Firefox is unusable each time I make a bookmark change. This is most likely because I have a ridiculous number of bookmarks: probably in the 10 - 20,000 range.

Despite these issues, Sync does a good job syncing bookmarks among my computers and makes it easier for me to complete my work so I'd like to keep using it. My bookmarks file acts like a mini-search engine for things I've found useful/interesting; deleting bookmarks or using a very stripped down bookmarks file doesn't really solve my issue here.

I've already Googled this to exhaustion and set services.sync.autoconnect to false in about:config, but that didn't seem to do anything. This solution could work but is very inconvenient: http://superuser.com/a/818726/362951

Is there any way that I can disable Sync from automatically syncing after each bookmark change? I'd love to be able to sync ONLY when I click the "Sync" button on my FF toolbar.

Every time I add, edit, move, or delete a bookmark, Firefox slows to a crawl for a few seconds while Sync does its thing. I know Sync is the issue because I've added the Sync icon to the toolbar and see it light up and spin and Firefox is unusable each time I make a bookmark change. This is most likely because I have a ridiculous number of bookmarks: probably in the 10 - 20,000 range. Despite these issues, Sync does a good job syncing bookmarks among my computers and makes it easier for me to complete my work so I'd like to keep using it. My bookmarks file acts like a mini-search engine for things I've found useful/interesting; deleting bookmarks or using a very stripped down bookmarks file doesn't really solve my issue here. I've already Googled this to exhaustion and set services.sync.autoconnect to false in about:config, but that didn't seem to do anything. This solution could work but is very inconvenient: http://superuser.com/a/818726/362951 Is there any way that I can disable Sync from automatically syncing after each bookmark change? I'd love to be able to sync ONLY when I click the "Sync" button on my FF toolbar.

Chosen solution

Sync chooses when to sync based on a combination of the last sync time and the amount of change that has occured. You can effectively disable sync (except you can still manually sync) by changing these values.

1. Go to "about:config"

2. Enter "services.sync.syncInterval" in the search box. This is the amount of time (in 1/1000's of a second) that sync waits between syncs. If you want sync to never sync after a certain time, change it to something large like "999999999999999999999999".

3. Enter "services.sync.syncThreshold" in the search box. This is the amount of change that must occur between syncs. 300 represents one bookmark, and is also the default, so by default sync will sync every time you add a bookmark. If you want this to only sync after 2 bookmarks, change it to 600, etc. If you want it to never sync, also change it to some extremely large number.

Note: there is still a possibility sync might sync automatically sometime, but it would be extremely rare.

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Provides information about the default web browser
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Shockwave Flash 14.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

user293 39 solutions 279 answers

Chosen Solution

Sync chooses when to sync based on a combination of the last sync time and the amount of change that has occured. You can effectively disable sync (except you can still manually sync) by changing these values.

1. Go to "about:config"

2. Enter "services.sync.syncInterval" in the search box. This is the amount of time (in 1/1000's of a second) that sync waits between syncs. If you want sync to never sync after a certain time, change it to something large like "999999999999999999999999".

3. Enter "services.sync.syncThreshold" in the search box. This is the amount of change that must occur between syncs. 300 represents one bookmark, and is also the default, so by default sync will sync every time you add a bookmark. If you want this to only sync after 2 bookmarks, change it to 600, etc. If you want it to never sync, also change it to some extremely large number.

Note: there is still a possibility sync might sync automatically sometime, but it would be extremely rare.

Sync chooses when to sync based on a combination of the last sync time and the amount of change that has occured. You can effectively disable sync (except you can still manually sync) by changing these values. 1. Go to "about:config" 2. Enter "services.sync.syncInterval" in the search box. This is the amount of time (in 1/1000's of a second) that sync waits between syncs. If you want sync to never sync after a certain time, change it to something large like "999999999999999999999999". 3. Enter "services.sync.syncThreshold" in the search box. This is the amount of change that must occur between syncs. 300 represents one bookmark, and is also the default, so by default sync will sync every time you add a bookmark. If you want this to only sync after 2 bookmarks, change it to 600, etc. If you want it to never sync, also change it to some extremely large number. Note: there is still a possibility sync might sync automatically sometime, but it would be extremely rare.
the-edmeister
  • Moderator
5391 solutions 40022 answers

You may think that Sync is causing Firefox to run at a crawl, but in my experience merely rearranging bookmarks too fast can peg the CPU and stop Firefox from doing anything or "crawl".

Does Mac have a CPU Usage or "Performance Meter" like Windows does? If so, disable Sync (Disconnect) and watch the CPU usage when merely rearranging some bookmarks.

You may think that Sync is causing Firefox to run at a crawl, but in my experience merely rearranging bookmarks too fast can peg the CPU and stop Firefox from doing anything or "crawl". Does Mac have a CPU Usage or "Performance Meter" like Windows does? If so, disable Sync (Disconnect) and watch the CPU usage when merely rearranging some bookmarks.
user293 39 solutions 279 answers

the-edmeister said

Does Mac have a CPU Usage or "Performance Meter" like Windows does? If so, disable Sync (Disconnect) and watch the CPU usage when merely rearranging some bookmarks.

It does. It is located in /Applications/utilities/activity monitor

''the-edmeister [[#answer-715391|said]]'' <blockquote> Does Mac have a CPU Usage or "Performance Meter" like Windows does? If so, disable Sync (Disconnect) and watch the CPU usage when merely rearranging some bookmarks. </blockquote> It does. It is located in /Applications/utilities/activity monitor

Question owner

Thanks, user293! Your solution accomplished exactly what I needed.

I think at some point I had tried setting services.sync.syncInterval to some high number, but didn't realize services.sync.syncInterval was triggering a sync after each bookmark.

Thanks for the suggestion, the-edmeister. In this case though, I started experiencing these slowdowns right after I turned on sync. Previously, slowdowns weren't an issue unless I was moving a LOT of bookmarks at once. Always a good idea to check CPU performance too!

Thanks, user293! Your solution accomplished exactly what I needed. I think at some point I had tried setting services.sync.syncInterval to some high number, but didn't realize services.sync.syncInterval was triggering a sync after each bookmark. Thanks for the suggestion, the-edmeister. In this case though, I started experiencing these slowdowns right after I turned on sync. Previously, slowdowns weren't an issue unless I was moving a LOT of bookmarks at once. Always a good idea to check CPU performance too!