Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure connection failed in version 37.0.1 but works in all other browsers and firefox 36

  • 5 replies
  • 9 have this problem
  • 366 views
  • Last reply by cor-el

more options

https://mail.twcbc.com/ will not load. The is Time Warner's business class web email.

The specific message is: Secure Connection Failed

The connection to mail.twcbc.com was interrupted while the page was loading.

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

This page loads in IE 11 with all recent patches, and in Chrome. Also it will load in Firefox 35 and 36. This issue is specific to 37.0.1

All Replies (5)

more options

The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases. It also uses a weak cipher suite that is not considered safe.

  • Connection Encrypted (TLS_RSA_WITH_AES_128_CBC_SHA, 128 bit keys, TLS 1.0)

You can open the about:config page via the location/address bar and use its search bar to locate this pref:

  • security.tls.insecure_fallback_hosts

You can double-click the line to modify the pref and add the domain to this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). You should only see domains separated by a comma in the value column.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

Modified by cor-el

more options

cor-el said

The website may try to fallback to TLS 1.0 in a way that is no longer allowed in current releases. It also uses a weak cipher suite that is not considered safe.
  • Connection Encrypted (TLS_RSA_WITH_AES_128_CBC_SHA, 128 bit keys, TLS 1.0)
You can open the about:config page via the location/address bar and use its search bar to locate this pref:
  • security.tls.insecure_fallback_hosts
You can double-click the line to modify the pref and add the domain to this pref. If there are already websites (domains) in this list then add a comma and the new domain (no spaces). You should only see domains separated by a comma in the value column.

Sorry, unless I'm putting it in the wrong place

I did try both just the domain, the full URL. same result

more options

You need the full domain: mail.twcbc.com

more options

cor-el said

You need the full domain: mail.twcbc.com

Thank you, that fixes it.

more options

You're welcome