X
Tap here to go to the mobile version of the site.

Support Forum

"This Connection is Untrusted" appears when trying to access ALL sites on MacBook Pro; problem started after running Avast scan of computer

Posted

I ran the Avast full disk scan. Since that time, I've been unable to access any site using Firefox without getting the message, "This Connection is not Trusted." Many are sites I've been too many times before and they are trusted sites. I don't know whether there's a problem with Firefox or might Firefox be picking up some kind of new "infestation." The Avast scan resulted in 5 files being put into a virus chest. Eleven could not be scanned. Thanks for any help that you can provide!

I ran the Avast full disk scan. Since that time, I've been unable to access any site using Firefox without getting the message, "This Connection is not Trusted." Many are sites I've been too many times before and they are trusted sites. I don't know whether there's a problem with Firefox or might Firefox be picking up some kind of new "infestation." The Avast scan resulted in 5 files being put into a virus chest. Eleven could not be scanned. Thanks for any help that you can provide!

Chosen solution

I assume Safari is working normally on those sites?

The latest version of avast! Web Shield includes a feature to filter your web connections for potential threats. In order to filter secure sites, it must present a "fake" certificate for the site to Firefox, so it can be "in the middle" and read your secure communications. If Firefox is not set up to trust the fake certificates, then you will get warnings for every secure site.

You might want to turn this feature off as a test to see whether the problem goes away.

If that works, but you want to use the feature, you'll need to import Avast's certificate into Firefox's "Authorities" tab so Firefox accepts its fake certificates (there might be an automated way AVAST intended for you to do this, or you might need to export from IE and then import into Firefox).

Here is some discussion on avast!'s forum about how this is supposed to work: Issues and questions on HTTPS Scanning - Avast Internet 2015

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/534.59.10 (KHTML, like Gecko) Version/5.1.9 Safari/534.59.10

More Information

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Chosen Solution

I assume Safari is working normally on those sites?

The latest version of avast! Web Shield includes a feature to filter your web connections for potential threats. In order to filter secure sites, it must present a "fake" certificate for the site to Firefox, so it can be "in the middle" and read your secure communications. If Firefox is not set up to trust the fake certificates, then you will get warnings for every secure site.

You might want to turn this feature off as a test to see whether the problem goes away.

If that works, but you want to use the feature, you'll need to import Avast's certificate into Firefox's "Authorities" tab so Firefox accepts its fake certificates (there might be an automated way AVAST intended for you to do this, or you might need to export from IE and then import into Firefox).

Here is some discussion on avast!'s forum about how this is supposed to work: Issues and questions on HTTPS Scanning - Avast Internet 2015

I assume Safari is working normally on those sites? The latest version of avast! Web Shield includes a feature to filter your web connections for potential threats. In order to filter ''secure'' sites, it must present a "fake" certificate for the site to Firefox, so it can be "in the middle" and read your secure communications. If Firefox is not set up to trust the fake certificates, then you will get warnings for every secure site. '''You might want to turn this feature off as a test to see whether the problem goes away.''' If that works, but you want to use the feature, you'll need to import Avast's certificate into Firefox's "Authorities" tab so Firefox accepts its fake certificates (there might be an automated way AVAST intended for you to do this, or you might need to export from IE and then import into Firefox). Here is some discussion on avast!'s forum about how this is supposed to work: [https://forum.avast.com/index.php?topic=159346.0 Issues and questions on HTTPS Scanning - Avast Internet 2015]

Helpful Reply

Thanks so much for your help. I opened Avast, turned off the Web Shield, and the problem disappeared. Now I will try to import the certificate into Firefox.


Sooser said

I ran the Avast full disk scan. Since that time, I've been unable to access any site using Firefox without getting the message, "This Connection is not Trusted." Many are sites I've been too many times before and they are trusted sites. I don't know whether there's a problem with Firefox or might Firefox be picking up some kind of new "infestation." The Avast scan resulted in 5 files being put into a virus chest. Eleven could not be scanned. Thanks for any help that you can provide!
Thanks so much for your help. I opened Avast, turned off the Web Shield, and the problem disappeared. Now I will try to import the certificate into Firefox. ''Sooser [[#question-1055379|said]]'' <blockquote> I ran the Avast full disk scan. Since that time, I've been unable to access any site using Firefox without getting the message, "This Connection is not Trusted." Many are sites I've been too many times before and they are trusted sites. I don't know whether there's a problem with Firefox or might Firefox be picking up some kind of new "infestation." The Avast scan resulted in 5 files being put into a virus chest. Eleven could not be scanned. Thanks for any help that you can provide! </blockquote>