Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 37 crashes when using Peacekeeper browser test

  • 13 replies
  • 3 have this problem
  • 309 views
  • Last reply by AJ Godinho

more options

Hi guys, I updated my browser with Firefox 37 and it crashes on me every time I use the Peacekeeper browser benchmark test. I've had no issues using the website in the past. Every time I update my browser I run the test to compare previous results as well as compare the results with Google Chrome.

It works fine with Chrome, but keeps crashing just 2 minutes in the test on FF37. I've tried running it in Safe Mode as well, but it still crashes. My plug-ins are up to date and I've tried a refresh as well. I did not have any other applications while running the test, just the browser was open with one tab. I'm running Windows 7.

Here is the Peacekeeper website: http://peacekeeper.futuremark.com/

I've sent the crash reporter to Mozilla.

Appreciate your help...thanks in advance!

Edit: included the Peacekeeper website.

Modified by AJ Godinho

Chosen solution

Hi @user293, @jscher2000 and @cor-el, thanks so much for your input and help with this issue I've been having. I tried disabling WebGL and ran Peacekeeper and it worked ok. There was no crash.

How to Disable WebGL: [https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardwar...]

I'm assuming that keeping it disabled should not cause much of an issue for me? When the new Firefox version is out in May, I will enable WebGL and see if this issue has been fixed.

Thanks again for your help guys...it's much appreciated!

Edit: included help link for disabling WebGL

Read this answer in context 👍 0

All Replies (13)

more options

Can you post the crash id's in this thread?

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and then go back to your forum question and paste those IDs into the "Post a Reply" box.

Note: If a recent Report ID does not start with bp- click on it to submit the report.

aboutcrashesFx29
more options

AJ Godinho said

Hi guys, I updated my browser with Firefox 37 and it crashes on me every time I use the Peacekeeper browser benchmark test. I've had no issues using the website in the past. Every time I update my browser I run the test to compare previous results as well as compare the results with Google Chrome. It works fine with Chrome, but keeps crashing just 2 minutes in the test on FF37. I've tried running it in Safe Mode as well, but it still crashes. My plug-ins are up to date and I've tried a refresh as well. I did not have any other applications while running the test, just the browser was open with one tab. I'm running Windows 7. Here is the Peacekeeper website: http://peacekeeper.futuremark.com/ I've sent the crash reporter to Mozilla. Appreciate your help...thanks in advance! Edit: included the Peacekeeper website.

Thanks...as requested, here you go:

bp-68ad5490-5d88-41f3-ab5d-3c6822150403 bp-da223147-068e-44f2-bc07-a0f522150402 bp-942a0beb-10d8-4357-a9df-881c22150402 bp-1e78cc45-5619-4387-944a-f1eba2150402 bp-71f6bac8-cb9c-4a1a-b1d9-a7e602150402

more options

Sorry for the delayed response. This appears to have been fixed in firefox 38, which will be released on may 12. In the meantime, you can download firefox beta to use the browser test.

more options

AJ Godinho said

Here is the Peacekeeper website: http://peacekeeper.futuremark.com/

Proxy Error The proxy server received an invalid response from an upstream server. The proxy server could not handle the request GET /. Reason: DNS lookup failure for: peacekeeper Apache/2.2.22 (Ubuntu) Server at peacekeeper.futuremark.com Port 80

more options

The problem may be outside of Firefox.

The crash reports flagged these programs;

Signature hang

Process Type plugin Shockwave Flash Version:17.0.0.134 ++++++++++++ Signature rx::IndexRangeCache

IPSEng32.dll = Symantec Intrusion Detection

IPSLdr32.dll = Symantec Intrusion Detection


See if there are updates for your graphics drivers https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration


Download the current full Symantec installer programs.

Download and run the Norton Removal Tool to uninstall your Norton product

After run the full installers.

Modified by FredMcD

more options

@user293 and @FredMcD first of all, thanks guys for your time and effort in trying to help me resolve this issue!

Every time I update my Firefox browser to the new rapid release version, I do a video review on my YouTube channel. In the review I also report the results of my browser benchmark test.

Anyway, one odd thing is that one of my YTube subscribers told me that he is using Firefox 37 and had no issues running the Peacekeeper tests. So I thought that it may be an issue with something else, apart from Firefox.

However, what baffles me is that I've never had any issues running Peacekeeper on Firefox. I've been running this tests for more than 2 years. That is, every time Firefox comes out with these updates. Also, I made sure to check that all my plug-ins were up-to-date.

Furthermore, I have had no issues running Peacekeeper on Google Chrome. I've always had Norton 360 from Symantec running as my internet security and anti-virus application.

If it was an issue with either Norton 360 or the graphics driver, would I not have had an issue running Peacekeeper on Google Chrome? Please let me know.

In the meantime, I will try and see if I there is an update for the graphics driver and look into uninstalling/reinstalling Norton 360.

Thanks again!

Edit: corrected typos.

Modified by AJ Godinho

more options

Hi @user293 and @FredMcD, further to my comment above, I checked updates for my graphics driver. It was up-to-date and I also uninstalled and reinstalled Norton 360 from my system. However, the issues still remains and my browser still crashes when running Peacekeeper.

Soon after I posted the above comment and before I checked any of the above (i.e. graphics driver and uninstalling/reinstalling N360), I decided to run Peacekeeper. It ran ok, just once and I tried it again, and it crashed. It crashes in Safe Mode too and even if I disable the Norton Toolbar.

Then I proceed with uninstalling/reinstalling N360 and tried running Peacekeeper again, Firefox crashed each time I ran it. I'm not sure what the issue is. I've never had this issue in the past and have been running Peacekeeper for at least a couple of years. And like I said earlier, it runs fine on Google Chrome.

If it will help...below are 10 of the latest crash report IDs:

bp-14370781-ee6b-42f2-bc07-e19972150414 bp-130b658d-2e35-4a83-9d2f-596952150414 bp-04f9553e-9e5d-424c-a66c-8b4212150413 bp-8b4e6b48-6a78-4475-87ad-4658f2150412 bp-516b81c1-e892-47f8-a6e8-f9fba2150411 bp-73fdf419-6563-400a-8792-ae8202150411 bp-6322ab0d-536e-4227-b1dc-1ec492150411 bp-f23e72dc-dcea-475d-aff8-93aff2150411 bp-d0ce8912-ab5e-4b0f-9353-3991c2150411 bp-375c29b8-eb25-4cca-8d2a-1e9e32150411

Thanks again for your help with this!

more options

This has been fixed in firefox 38 (coming out may 12)(according to https://bugzilla.mozilla.org/show_bug.cgi?id=1152972 ), so I would suggest waiting until then, or downloading a prerelease version of firefox.

Modified by cor-el

more options

It may be hard to work around this if Windows and your graphics card/chipset driver software are already up-to-date. Based on the above bug report, it's too late to fix whatever it is for Firefox 37.x.

For what it's worth, the test completed on my Windows 7 system. (Screen shot attached.)

more options

You can do a check for problems with current Shockwave Flash plugin versions and try this:

See also:

more options

Chosen Solution

Hi @user293, @jscher2000 and @cor-el, thanks so much for your input and help with this issue I've been having. I tried disabling WebGL and ran Peacekeeper and it worked ok. There was no crash.

How to Disable WebGL: [https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardwar...]

I'm assuming that keeping it disabled should not cause much of an issue for me? When the new Firefox version is out in May, I will enable WebGL and see if this issue has been fixed.

Thanks again for your help guys...it's much appreciated!

Edit: included help link for disabling WebGL

Modified by AJ Godinho

more options

Disabling webGL shouldn't cause an issue most of the time, but some websites (mostly 3d games) depend on it and won't work correctly with it disabled.

more options

Thanks @user293 - I'm not into gaming or 3D stuff, so that's good. I'll keep it disabled.