Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Secure Connection Failed?? Error code: sec_error_bad_signature... How do i over ride this?? I need this website to open or i will have to use IE again.

  • 12 replies
  • 49 have this problem
  • Last reply by jscher2000

more options

Secure Connection Failed

An error occurred during a connection to Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.

All Replies (12)

more options

I'm not getting that error at the moment on the main page:

Here is some general advice first:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site (use HTTP, not HTTPS), try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Do you think you might have saved an "exception" for this site before? If so, try deleting it from here:

"3-bar" menu button (or Tools menu) > Options > Advanced > Certificates mini-tab > "View Certificates" button > Servers tab

Any improvement?

more options

I sure wish it worked. I tried all of the above and nothing worked. I even clicked on the link for that site above and it came up Problem Loading.

Secure Connection Failed

An error occurred during a connection to Peer's certificate has an invalid signature. (Error code: sec_error_bad_signature)

   The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
   Please contact the website owners to inform them of this problem.
more options

Is this the only secure site that Firefox has complained about?

I'd like a little more information about the site's certificate.

Does the error page have a last section called "I understand the risks"?

If so, you can use the Add Exception dialog to take a look at the certificate. You don't need to add an exception, I would prefer you didn't yet until we confirm that this isn't a malware issue.

Click Add Exception, then the View button. (If View is not enabled, click Get Certificate first.) What do you see in the "Issued by" section? Is there a complete chain of trust on the Details tab? I have attached what I see for comparison.

After checking that, you can cancel out.

If you do not have the Add Exception button, you can check the certificate in Internet Explorer.

After opening the site, click the padlock in the IE address bar and View Certificate. The information might be on slightly different tabs, but it's the same idea.

What do you find?

more options

I do not have the option to view the "I understand the Risks". I have attached 2 images from the IE browser. it works fine using that one.

more options

You can call up the "Add Exception" dialog manually as follows:

(1) Type or paste the following into the address bar and press Alt+Enter to open it in a new tab:


(2) In the Location space, type or paste the address of the page you can't open

(3) Click the Get Certificate button

(4) Click the View button

Any difference from the information in IE?

more options

Says :

No Information Available Unable to obtain identification status for the given site.

View button is greyed out and will not function.

more options

Try to rename the cert8.db file (cert8.db.old) and delete the cert_override.txt file in the Firefox profile folder to remove intermediate certificates and exceptions that Firefox has stored.

If that has helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previously stored intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

more options

Ok so i renamed the cert8.db file and changed it to (cert8.db.old) and deleted the cert_override.txt file in the Firefox profile folder. tried again and it did not work. I then renamed secmod.db (secmod.db.old) as well and that did not work either so far. It did re block me from other sites i had been using before but the option to Click on making an exception was there so i did and they all work once again. Price Master site will not work still.

more options

If it hasn't worked then you can undo the rename and restore the renamed cert8.db.old file to cert.db to undo this action.

more options

What on earth is blocking Firefox from accessing the certificate?!

To try to bypass possible site preference issues, or other possible settings, could you try this 3-minute test?

Create a new Firefox profile

A new profile will have your system-installed plugins (e.g., Flash) and extensions (e.g., security suite toolbars), but no themes, other extensions, or other customizations. It also should come with completely fresh settings databases and a fresh cache folder.

This does not replace your existing setup; the new folder exists in parallel with your current settings.

Exit Firefox and start up in the Profile Manager using Start > Run:

firefox.exe -P

Don't delete anything here.

Any time you want to switch profiles, exit Firefox and return to this dialog.

Click the Create Profile button, assign a name like April2, and ignore the option to change the folder location. Then start Firefox in the new profile you created.

Any improvement in ability to access PriceMaster?

When returning to the Profile Manager to switch back to your normal profile, you might be tempted to use the Delete Profile button. But... it's a bit too easy to accidentally delete your "real" profile, so I recommend resisting the temptation. If you do want to clean up later, I suggest making a backup of all your profiles first in case something were to go wrong.

more options

I have this same problem when trying to access pages associated with my university. I've tried all of the above, including the most recent suggestion, to no avail.

more options

Hi muno0021, would you mind starting a new question and providing information about your system and what you have tried so far. Also, if your university uses a particular software package such as Blackboard, that may help to mention because volunteers may remember reading about issues/workarounds related to that software in another thread.

For a desktop/laptop version of Firefox:

For Android:

If the suggestions do not look helpful, keep scrolling down to continue entering your question.