X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Wednesday, April 1, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

FF 36.0.4 not showing Burmese characters. Only seeing unicode boxes

Posted

All other Asian/non-Western character sets that I have checked (Arabic, Thai, Urdu, Hindustani, Korean, Japanese, Chinese, etc.) appear to be showing correctly.

All other Asian/non-Western character sets that I have checked (Arabic, Thai, Urdu, Hindustani, Korean, Japanese, Chinese, etc.) appear to be showing correctly.
Attached screenshots

Additional System Details

Installed Plug-ins

  • Coupons, Inc. Coupon Printer 5.0.2.3
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0

Application

  • Firefox 36.0.4
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
  • Support URL: https://support.mozilla.org/1/firefox/36.0.4/WINNT/en-US/

Extensions

  • Disconnect 3.15.3 (2.0@disconnect.me)
  • Facebook Disconnect 2.1.3 (facebook@disconnect.me)
  • Ghostery 5.4.3 (firefox@ghostery.com)
  • Google Disconnect 2.4.2 (google@disconnect.me)
  • Google™ Translator 0.3.3 (jid1-dgnIBwQga0SIBw@jetpack)
  • Magic Actions for YouTube™ 6.8.5.1 (jid0-UVAeBCfd34Kk5usS8A1CBiobvM8@jetpack)
  • MailtoWebmails 1.3 (MailtoWebmails@jetpack)
  • Reddit Enhancement Suite 4.5.4 (jid1-xUfzOsOFlzSOXg@jetpack)
  • SmoothWheel (AMO) 0.45.8.20130519.3 ({5F590AA2-1221-4113-A6F4-A4BB62414FAC})
  • Speed Dial 0.9.6.17 ({64161300-e22b-11db-8314-0800200c9a66})
  • Thumbnail Zoom Plus 3.3 (thumbnailZoom@dadler.github.com)
  • WOT 20131118 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • ZenMate Security & Privacy VPN 4.1.7 (firefox@zenmate.com)
  • µBlock 0.8.6.0 ({2b10c1c8-a11f-4bad-fe9c-1c11e82cac42})
  • Adblock Plus 2.6.8 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Social Fixer 12.0 (socialfixer@mattkruse.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7640G
  • adapterDescription2:
  • adapterDeviceID: 0x9903
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 105b1043
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 11-20-2014
  • driverDate2:
  • driverVersion: 14.501.1003.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7640G Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4390 solutions 61617 answers

Check and make sure that language pack is on your computer.

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Check and make sure that language pack is on your computer. Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.'''
cor-el
  • Top 10 Contributor
  • Moderator
17855 solutions 161578 answers

It is possible that Firefox is using a font that doesn't cover this Unicode range.

You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector.

You may have to select another default font if there is a problem with the currently used font.

style="font-family:Myanmar3, Myanmar2, Myanmar1, Padauk, mm3web, TharLon, 'Masterpiece Uni Sans', Parabaik, Yunghkio, Thanlwin, 'Win Uni Innwa', 'MyMyanmar Unicode', 'Myanmar Text', 'WinUni Innwa', 'Noto Sans Myanmar';"

See also:

It is possible that Firefox is using a font that doesn't cover this Unicode range. You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector. You may have to select another default font if there is a problem with the currently used font. *http://en.wikipedia.org/wiki/Burmese_alphabet (0x1000-0x109F) <pre><nowiki>style="font-family:Myanmar3, Myanmar2, Myanmar1, Padauk, mm3web, TharLon, 'Masterpiece Uni Sans', Parabaik, Yunghkio, Thanlwin, 'Win Uni Innwa', 'MyMyanmar Unicode', 'Myanmar Text', 'WinUni Innwa', 'Noto Sans Myanmar';"</nowiki></pre> See also: *http://en.wikibooks.org/wiki/Unicode/Character_reference/1000-1FFF *http://www.alanwood.net/unicode/myanmar.html

Question owner

Thanks, but no good. It was already selected  :(

I appreciate the help, though!

Thanks, but no good. It was already selected :( I appreciate the help, though!
cor-el
  • Top 10 Contributor
  • Moderator
17855 solutions 161578 answers

You can try different default fonts and temporarily disable website fonts to test the selected default font and see if you can find a font that works.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
You can try different default fonts and temporarily disable website fonts to test the selected default font and see if you can find a font that works. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"