X
Tap here to go to the mobile version of the site.

Support Forum

Firefox for Android only displays the desktop version of gmail instead of the mobile one.

Posted

Android only question.

I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website.

Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated.

Thanks

Pinellas Chuck

Android only question. I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website. Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated. Thanks Pinellas Chuck

Chosen solution

Okay, yes, it's that pesky word Tablet.

What I'm about to describe is hard to type, so hopefully you can open this page on your tablet.

(0) Select and copy the following on your tablet if possible to avoid excess typing:

general.useragent.override.mail.google.com Android; Tablet;#Android; Mobile;

The forum linkifies that first part but it is not meant to be a link.

(1) Open a new tab to about:config (type about:config in the Awesomebar and tap the go arrow or tap Enter).

You may want to bookmark this for easier future access.

(2) In the search box, type agen and pause while Firefox filters the list

(3) Scroll down and look for a preference named general.useragent.site_specific_overrides and confirm that it has its default value of true. If it is set to false, tap the Reset button to switch it back to true.

(4) Scroll back up and tap the large "+" button to the left of the search box to add a new setting

(A) The name of the preference should be general.useragent.override.google.com (for all Google sites) general.useragent.override.mail.google.com (for Gmail only)

If you are typing this, watch out for autocorrect inserting spaces and make sure to delete those.

If pasting, delete the part after that.

(B) On the right side, tap Boolean and in the popup change it to String

(C) The value of the preference should be Android; Tablet;#Android; Mobile; -- in other words, substitute Mobile for Tablet.

If typing, watch out for excess spaces.

If pasting, delete the preference name and extra space before this part.

(D) Then click Create

If you open https://mail.google.com/ it should now use the mobile layout.

Success?

Edit: Clarified the preference name options.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:39.0) Gecko/20100101 Firefox/39.0

More Information

user1192079 0 solutions 19 answers

pinellaschuck22 said

Android only question. I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website. Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated. Thanks Pinellas Chuck

Please reply to this message with the following information:

  • What is the model of your phone?
  • What is the OS version and Build ID found in the Device Information page? Please visit this link if you need help finding the Build ID of your phone.
  • Please provide the exact steps to reproduce the issue you are encountering.
  • Who is your current cell phone carrier?
  • How often do you encounter this issue?

Please be sure to include as much detail as possible, including any websites that may exhibit this issue, and any error messages that you may be receiving, exactly as they appear. This will ensure that we have all the necessary information to investigate this behavior.

''pinellaschuck22 [[#question-1053476|said]]'' <blockquote> Android only question. I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website. Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated. Thanks Pinellas Chuck </blockquote> Please reply to this message with the following information: * What is the model of your phone? * What is the OS version and Build ID found in the Device Information page? Please visit [https://support.mozilla.org/en-US/kb/how-do-i-find-what-version-firefox-os-i-have this link] if you need help finding the Build ID of your phone. * Please provide the exact steps to reproduce the issue you are encountering. * Who is your current cell phone carrier? * How often do you encounter this issue? Please be sure to include as much detail as possible, including any websites that may exhibit this issue, and any error messages that you may be receiving, exactly as they appear. This will ensure that we have all the necessary information to investigate this behavior.

Question owner

pinellaschuck22 said

Android only question. I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website. Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated. Thanks Pinellas Chuck
  • Google Nexus 7 2012 (tablet - not a phone)
  • Android 5.1 / LMY46D
  • Visit gmail website with Android Firefox (see orig msg for details)
  • tablet wi-fi only
  • everytime I visit gmail webiste
''pinellaschuck22 [[#question-1053476|said]]'' <blockquote> Android only question. I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website. Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated. Thanks Pinellas Chuck </blockquote> * Google Nexus 7 2012 (tablet - not a phone) * Android 5.1 / LMY46D * Visit gmail website with Android Firefox (see orig msg for details) * tablet wi-fi only * everytime I visit gmail webiste
jscher2000
  • Top 10 Contributor
8775 solutions 71738 answers

You may want to just double-check on the menu that the box for "Request Desktop Site" is not checked.

If you visit my test page here, how is your Android device identifying itself (first text in red, the user agent string)?

http://dev.jeffersonscher.com/jstest.asp

On a phone, I get:

Mozilla/5.0 (Android; Mobile; rv:36.0) Gecko/36.0 Firefox 36.0

Does yours specifically mention being a tablet, or show any other difference?

You may want to just double-check on the menu that the box for "Request Desktop Site" is not checked. If you visit my test page here, how is your Android device identifying itself (first text in red, the user agent string)? http://dev.jeffersonscher.com/jstest.asp On a phone, I get: Mozilla/5.0 (Android; Mobile; rv:36.0) Gecko/36.0 Firefox 36.0 Does yours specifically mention being a tablet, or show any other difference?

Question owner

Checked "Request Desktop Site" as one of my first steps to diagnose problem with gmail.

Using your test page I see: Mozilla/5.0 (Android;Tablet; rv36.0) Gecko/36.0 Firefox 36.0

As an additional test I note that both cnn.com and theverge.com correctly display the mobile versions of their sites.

Thank you , Chuck

Checked "Request Desktop Site" as one of my first steps to diagnose problem with gmail. Using your test page I see: Mozilla/5.0 (Android;Tablet; rv36.0) Gecko/36.0 Firefox 36.0 As an additional test I note that both ''cnn.com'' and ''theverge.com'' correctly display the mobile versions of their sites. Thank you , Chuck
jscher2000
  • Top 10 Contributor
8775 solutions 71738 answers

Chosen Solution

Okay, yes, it's that pesky word Tablet.

What I'm about to describe is hard to type, so hopefully you can open this page on your tablet.

(0) Select and copy the following on your tablet if possible to avoid excess typing:

general.useragent.override.mail.google.com Android; Tablet;#Android; Mobile;

The forum linkifies that first part but it is not meant to be a link.

(1) Open a new tab to about:config (type about:config in the Awesomebar and tap the go arrow or tap Enter).

You may want to bookmark this for easier future access.

(2) In the search box, type agen and pause while Firefox filters the list

(3) Scroll down and look for a preference named general.useragent.site_specific_overrides and confirm that it has its default value of true. If it is set to false, tap the Reset button to switch it back to true.

(4) Scroll back up and tap the large "+" button to the left of the search box to add a new setting

(A) The name of the preference should be general.useragent.override.google.com (for all Google sites) general.useragent.override.mail.google.com (for Gmail only)

If you are typing this, watch out for autocorrect inserting spaces and make sure to delete those.

If pasting, delete the part after that.

(B) On the right side, tap Boolean and in the popup change it to String

(C) The value of the preference should be Android; Tablet;#Android; Mobile; -- in other words, substitute Mobile for Tablet.

If typing, watch out for excess spaces.

If pasting, delete the preference name and extra space before this part.

(D) Then click Create

If you open https://mail.google.com/ it should now use the mobile layout.

Success?

Edit: Clarified the preference name options.

Okay, yes, it's that pesky word Tablet. What I'm about to describe is hard to type, so hopefully you can open this page on your tablet. (0) Select and copy the following on your tablet if possible to avoid excess typing: general.useragent.override.mail.google.com Android; Tablet;#Android; Mobile; ''The forum linkifies that first part but it is not meant to be a link.'' (1) Open a new tab to '''about:config''' (type about:config in the Awesomebar and tap the go arrow or tap Enter). ''You may want to bookmark this for easier future access.'' (2) In the search box, type '''agen''' and pause while Firefox filters the list (3) Scroll down and look for a preference named '''general.useragent.site_specific_overrides''' and confirm that it has its default value of true. If it is set to false, tap the Reset button to switch it back to true. (4) Scroll back up and tap the large "+" button to the left of the search box to add a new setting (A) The name of the preference should be '''general.useragent.override.google''.''com''' (for all Google sites) '''general.useragent.override.mail.google''.''com''' (for Gmail only) If you are typing this, watch out for autocorrect inserting spaces and make sure to delete those. If pasting, delete the part after that. (B) On the right side, tap Boolean and in the popup change it to String (C) The value of the preference should be '''Android; Tablet;#Android; Mobile;''' -- in other words, substitute Mobile for Tablet. If typing, watch out for excess spaces. If pasting, delete the preference name and extra space before this part. (D) Then click Create If you open https://mail.google.com/ it should now use the mobile layout. Success? ''Edit: Clarified the preference name options.''

Modified by jscher2000

Question owner

pinellaschuck22 said

Android only question. I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website. Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated. Thanks Pinellas Chuck


The answer from jscher2000 worked - just had to due a little typing. Thank you so much for the help.

''pinellaschuck22 [[#question-1053476|said]]'' <blockquote> Android only question. I prefer to access gmail through a browser rather than the gmail app. Testing other browsers on Android (Chrome and Dolphin) I see that they display a mobile specific version of the gmail website. Firefox for Android only displays the desktop version on my Nexus 7 (2012 running Android 5.1) - so harder to read and use. Any help or ideas would be greatly appreciated. Thanks Pinellas Chuck </blockquote> The answer from jscher2000 worked - just had to due a little typing. Thank you so much for the help.