Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Mailto links in websites not working correctly in FF 36.0.1

  • 9 replies
  • 2 have this problem
  • 1807 views
  • Last reply by Piskey

more options

I know this isn't a new problem as I've found lots about it in the Internet but I haven't found anything that will fix it! This problem only started for me when I updated to Firefox36, until then everything was working perfectly, but as I've seen references to the problem going back to 2007 that may be a red herring.

I'm using Windows 7 Professional, 64 bit on an HP ProBook. When I click on a mailto link in a web page I have a Windows Internet Explorer window open saying "Could not perform this operation because the default mail client is not properly installed".

I was clicking the link in Firefox, Firefox is my default browser, The Bat is set as my default program for handling mailto commands and everything was in 100% working order until I updated to v36.

On another computer also running Windows 7 Professional, 64 bit with Firefox 36.0.1 this problem does not occur! Clicking on a mailto in that works just as it should. I've tried uninstalling and reinstalling Firefox, but it made no difference - the problem wouldn't go away.

It's driving me barmy!  ;-)

Chosen solution

Hello once more, and thanks for your further suggestions.

(1) HKEY_CLASSES_ROOT\mailto Your current default mail client details should be here

Hmmm.... nothing there at all! No 'mailto' folder. There is, though, on the other machine.

I added it on this computer.

AND NOW IT WORKS CORRECTLY !!!!! Thank you - I wasn't shouting, I was just being very grateful ;-)

(2) HKEY_CLASSES_ROOT\PROTOCOLS\Handler\mailto that seems to point to HKEY_CLASSES_ROOT\CLSID\{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B} which uses

C:\Windows\System32\mshtml.dll

That all checked out.

(3) HKEY_CLASSES_ROOT\Wow6432Node\PROTOCOLS\Handler\mailto that seems to point to HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B} which uses

C:\Windows\SysWOW64\mshtml.dll

That checked out correctly too

Use the System File Checker tool to repair missing or corrupted system files

I ran that anyway and it reported nothing wrong.

Thank you once more for your help and especially your solution.

Read this answer in context 👍 1

All Replies (9)

more options

Piskey said

I updated to Firefox36

This should have read: " I updated to Firefox 36.0.1"

Sorry.

more options

Could you check to make sure The Bat is still recognized in Firefox as your default mailto handler? It's under Options...

"3-bar" menu button (or Tools menu) > Options > Applications

This list takes a while to load. Then you can type mailto in the search box to filter the list and see whether you can select The Bat on the right side.

More info: Change the program used to open email links

more options

Sometimes the file that stores your application/download preferences becomes corrupted. The standard medicine for that is to remove the file and have Firefox re-generate it from defaults. To try that:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again. You may need to go back into Options to select your mailto preference, or Firefox may preselect the system default, or you may be offered choices the first time you click a mailto link.

more options

Thanks for the suggestions jscher2000 but .....

Firstly The Bat is showing in the Applications list as the default maito program.

I tried your renaming of mimeTypes.rdf file but after a reboot and running Firefox again I still have the same problem. The old mimeTypes.rdf file was 4kb whereas the new one is 2kb.

When the IE error window appears it doesn't want to close down. Try clicking on the close gadget and it produces many copies of an IE error web page saying "Navigation to the web page was canceled" when all was trying to do was close down the error message. Sometimes clicking on the IE icon in the task bar and selecting "Close all windows" will close these down but on other occasions it simply creates more of them! Task manager has the same problem, click on IE and then on End task and all that happens is the number of IE incidences in Task manager increases by one!

Eventually persistence with "Close all windows" will work - or it's a resort to a restart of the computer!

more options

I'm puzzled why IE is getting on the action... Does this same problem happen if you click a mailto link in another program such as Adobe Reader or a Microsoft Office application?

If you go into the Control Panel, under Programs, Default Programs, and go into "Associate a file type or protocol with a program" can you confirm that MAILTO is associated with The Bat there?

more options

Hello again,

Yes, all the default settings are correct, that was my first port of call.

However, it would seem it's not just a Firefox problem. The same thing happens in Internet Explorer, Safari just puts up an error message saying it can't open the specified address because Windows doesn't recognise Internet addresses starting with mailto:

...... BUT ...... if I load Opera or Chrome the mailto links work 100% correctly!

more options

Oh dear, seems it is nothing at all to do with the mimeTypes.rdf file.

I just copied this file across from another computer runningWin 7 Pro, FF 36.0.1 and The Bat that doesn't have this problem, replacing the file on this computer, but the problem is still there. It just opened 54 instances of the IE error page

more options

If you are familiar with RegEdit, I wonder whether you could compare the mailto entries in the registries on the two systems to see whether there is a discrepancy there.

I saw 3 entries of potential interest:

(1) HKEY_CLASSES_ROOT\mailto Your current default mail client details should be here

(2) HKEY_CLASSES_ROOT\PROTOCOLS\Handler\mailto that seems to point to HKEY_CLASSES_ROOT\CLSID\{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B} which uses

C:\Windows\System32\mshtml.dll

(3) HKEY_CLASSES_ROOT\Wow6432Node\PROTOCOLS\Handler\mailto that seems to point to HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B} which uses

C:\Windows\SysWOW64\mshtml.dll

Firefox is a 32-bit application, so the last file probably is most relevant to making mailto requests on a 64-bit system. Perhaps there is a problem with that file or something else required to process the mailto request. You could try the System File Checker if you don't find another solution.

Use the System File Checker tool to repair missing or corrupted system files

more options

Chosen Solution

Hello once more, and thanks for your further suggestions.

(1) HKEY_CLASSES_ROOT\mailto Your current default mail client details should be here

Hmmm.... nothing there at all! No 'mailto' folder. There is, though, on the other machine.

I added it on this computer.

AND NOW IT WORKS CORRECTLY !!!!! Thank you - I wasn't shouting, I was just being very grateful ;-)

(2) HKEY_CLASSES_ROOT\PROTOCOLS\Handler\mailto that seems to point to HKEY_CLASSES_ROOT\CLSID\{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B} which uses

C:\Windows\System32\mshtml.dll

That all checked out.

(3) HKEY_CLASSES_ROOT\Wow6432Node\PROTOCOLS\Handler\mailto that seems to point to HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{3050f3DA-98B5-11CF-BB82-00AA00BDCE0B} which uses

C:\Windows\SysWOW64\mshtml.dll

That checked out correctly too

Use the System File Checker tool to repair missing or corrupted system files

I ran that anyway and it reported nothing wrong.

Thank you once more for your help and especially your solution.