Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop Firefox from loading tabs at startup?

  • 7 replies
  • 2 have this problem
  • 1419 views
  • Last reply by powow

more options

Within the last month I got a new computer, previously I had no issues with Firefox. Now, when I launch Firefox, it loads the 6 tabs I used my first session of using Firefox, which is espcially annoying because it autoplays a YouTube page. I only want my homepage to launch at startup.

Chosen solution

You can use this button to go to the currently used Firefox profile folder:

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

The "AppData" folder in Windows Vista and later Window 7+ versions and the "Application Data" folder in XP/Win2K are hidden folders.

Read this answer in context 👍 1

All Replies (7)

more options

Can you double check your homepage setting in options?

Note Firefox allows setting of multiple pages as homepage, separated by "|" in settings.

more options

You can check if you have a user.js file in the Firefox profile folder that sets the browser.sessionstore.resume_session_once pref to true.

You can use this button to go to the currently used Firefox profile folder:


You can check for problems with the sessionstore.js file in the Firefox profile folder that store session data.

Deleting sessionstore.js will cause App Tabs and Tab Groups and open and closed (undo) tabs to get lost and you will have to recreate them (make a note or bookmark them if possible).

more options

Win 7 38.0.5

Browser.sessionstore.resume = false

FF loads all previous tab sessions at Startup. It's been doing this for months.

Why can't FF just load my homepage setting? There's no crash. I'm just starting my laptop every morning.

Modified by powow

more options

This is not about what you see on the about:config page, but about the presence of a user.js file in the profile folder. browser.sessionstore.resume_session_once is always false when you check this on the about:config page unless you or Firefox has set this pref to true during the current session. The normal purpose of this pref is to restore the tabs when Firefox needs to be restarted, e.g. with an update or installing an extension. The pref is automatically reset to false after it has served its purpose.

You nee the check the Firefox profile folder for the presence of a user.js file.

Windows hides some file extensions by default. Among them are .html and .ini and .js and .txt, so you may only see file name without file extension. You can see the real file type (file extension) in the properties of the file via the right-click context menu in Windows Explorer.

more options

Where's the Profile folder for Win 7?

I need the exact path.

I searched in the area you recommended. It's not there.

more options

Chosen Solution

You can use this button to go to the currently used Firefox profile folder:

  • C:\Users\<user>\AppData\Roaming\Mozilla\Firefox\Profiles\<profile>\

The "AppData" folder in Windows Vista and later Window 7+ versions and the "Application Data" folder in XP/Win2K are hidden folders.

more options

Thanks. It works now.