Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

very slow startup refreshing make no differance

  • 10 replies
  • 14 have this problem
  • 2 views
  • Last reply by mikearthur

more options

Fire fox out of the blue started to take a very very long time to load I have done a reinstall and a refresh niether work what can I do to solve it take 4 times long or more than I.E. 11 also i have run Norton and Norton power scan and seams to be no virus or malware causeing this. I use Windows 8.1 on a Surface-Pro

Chosen solution

rephil said

Fire fox out of the blue started to take a very very long time to load I have done a reinstall and a refresh niether work.................

I also have the same issue. There is definitely a problem with v. 36.0 AND 36.01. I have reinstalled v.35.0 and there is now no problem. Load times are back to 2 secs. MOZILLA PLEASE SORT THIS OUT.

Read this answer in context 👍 3

All Replies (10)

more options

Try enabling hardware acceleration. You can do this by clicking menu>options>advanced and then check the box that says enable hardware acceleration when able. You can also try refreshing Firefox by resetting add ons. I would just write down your favorite add ons and try that, I just did it today and it was very noticeably faster.

Have a great day!!

Jon

more options

did both before posting question neither made any difference

more options

Try enabling an new HTTP cache. To do so, enter about:config into Firefox's address bar and press Enter. Search for the browser.cache.use_new_backend flag and double-click on it. Change its value from 0 to 1 to enable the new cache. ... Close about:config and continue browsing—no need to restart or anything.

-Jon

more options

does not work get The address isn't valid

more options

This about:config works on Firefox on my laptop but on my Surface were I have the problem I get as I say above "The Address is Invalid" and cant get to the config page

more options

See this forum thread in the Norton forum: https://community.norton.com/en/forums/firefox-extreemly-slow-start

more options

I have this on my Surface and Alienware Laptop both also have Norton and the problem is on the Surface

more options

Chosen Solution

rephil said

Fire fox out of the blue started to take a very very long time to load I have done a reinstall and a refresh niether work.................

I also have the same issue. There is definitely a problem with v. 36.0 AND 36.01. I have reinstalled v.35.0 and there is now no problem. Load times are back to 2 secs. MOZILLA PLEASE SORT THIS OUT.

more options

thanks for the info about version 35 reinstalled that version now all is fine

more options

Same problem - reinstalled 35.0 and ok now.

Except it automatically updated to 36.01 again - Changed my update options and re-re-installed 35.0.