Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are YouTube Videos stuttering?

  • 11 replies
  • 16 have this problem
  • 1577 views
  • Last reply by petef

more options

After upgrading to version 36, heavy stuttering occurs. I'm able to watch the exact the video with Version 35 without stutter. My os is android 4.4.4.

Chosen solution

Hi InDane It may be of interest to look at this discussion: https://support.mozilla.org/en-US/questions/1049703 Although the symptoms are slightly different, I'm beginning to wonder if the underlying cause isn't the same? Using the link http://people.mozilla.org/~atrain/mobile/tests/media.html provided by Barry_scott, I too find the only video that will play correctly is the VP9/WEBM video. Regards, Pete

Read this answer in context 👍 1

All Replies (11)

more options

I have the identical problem. Android 4.2.2

more options

Hi InDane:

I just tried Firefox for Android 35.0.1 and Firefox for Android 36 on my Galaxy Note 4 running Android 4.4.4 using the Kia Canada Sorrento 2016 video:

m.youtube.com/?#/watch?v=RvyacdBrezQ

and it played fine without stuttering (but it launched the YouTube Android player)

So some follow up questions (for missing info - it's always helpful to tell us what phone/tablet you have and what you did, what did, and what happened versus what you expected) so we can help you better:

  1. What Android phone or tablet are you using?
  2. Do you have the Flash Video Player installed?
  3. Does your phone or tablet launch the YouTube Android player like the Note 4)
  4. Could you please give us the URL of a YouTube video that stutters?

Cheers! ...Roland

more options

Hi I'm not sure if it's the right thing to do, but as the question owner hasn't come back, this is my experience. Since installing v36, all video I have tried is buffering, by that I mean the video keeps stalling while the sound continues. This is not due to a slow connection, the same videos play fine in another browser. Also, the same videos played fine in v35.0.1. This seems to be happening with all videos I've tried. In answer to your questions: 1. I'm using HUDL tablet with Android 4.2.2 2. Flash is installed (but not needed for these videos) 3. No 4. https://www.youtube.com/embed/ddaXT8C-hjc?vndapp=youtube_mobile&vndclient=mv-google&vndel=watch&vnddnc=1

I have now tried enabling Flash, and the video above plays OK without buffering when using Flash, but buffers when not using Flash.

Cheers petef

PS I have tried with all addons disabled. This had no effect.

Modified by petef

more options

hello, sorry i didnt see that my question was answered in the first place!

its exactly like petef said. In Addition to that. 1. LG p880 with Cyanogenmod 11 4.4.4. 2. No i dont. 3. i dont use GApps, no Google Play Store etc. so no Youtube Player. 4. https://www.youtube.com/embed/MhlL_IWJqag?vndapp=youtube_mobile&vndclient=mv-google&vndel=watch&vnddnc=1

more options

Hi InDane:

Just tried https://www.youtube.com/embed/ddaXT8C-hjc?vndapp=youtube_mobile&vndclient=mv-google&vndel=watch&vnddnc=1 on my Note 4 runing Android 4.4.4 and it played fine in Firefox for Android 36 with or without the flash player installed.

Don't know what's happening her, maybe a Cyanogen11.4.4.4 bug? I suggest trying the Cyanogen support forums and see if you can find anything out there. Please let us know what you find!

Cheers!

...Roland

more options

The pre-installed Browser plays all Videos without stuttering. And ff 35 was working. I dont See why this could be a cm Problem? The sandwich Video stutters in ff and plays well in the Android pre installed Browser.

Best regards Ken

Modified by InDane

more options

Hi again :-) InDane:

Perhaps you are right, it's perhaps not a Cyanogen Mod problem but it's still worth a look in the Cyanogen forums I think because when using a non factory ROM like Cyanogen Mod there's always the possibility that things will break in weird ways especially on older not so popular phones.

Also, I am curious why you and a few others are not using the YouTube app.

As far as I can tell, google can still track you every time you play a youtube video whether you are using a web browser or the you tube app to play it.

Cheers ! (and wish I could come up with a solution for you!)

...Roland

more options

Hey Roland, it is less about the yt app itself, its the play store and the services that I don't want to track me. The play store can install apps on your phone without you knowing.

Is there an option to increase the frame buffer or cache for those videos? Maybe that might fix it? I searched in the config already but nothing that I've found fits.

Best regards Ken

more options

Chosen Solution

Hi InDane It may be of interest to look at this discussion: https://support.mozilla.org/en-US/questions/1049703 Although the symptoms are slightly different, I'm beginning to wonder if the underlying cause isn't the same? Using the link http://people.mozilla.org/~atrain/mobile/tests/media.html provided by Barry_scott, I too find the only video that will play correctly is the VP9/WEBM video. Regards, Pete

more options

Hey petef, toggle 'media.fragmented-mp4.enabled' to 'False' worked for YouTube Videos on my device, thanks for the link!

more options

Unfortunately doesn't work for embedded videos though (at least on my device). Cheers, Pete