X
Tap here to go to the mobile version of the site.

Support Forum

I am using ALSA and Icecat. When I play any html5 audio/video it works, but the next time i click on another audio/video link I lose sound.

Posted

I am using Parabola (a fork of archlinux), Icecat 31.4 and ALSA

Icecat and firefox seem to hold onto the soundcard when I click on a new html5 audio/video link in the same tab. The next video/audio element loses sound. If I wait 10 seconds and click back to the start of the audio/video, the audio returns. I often get cpu spikes for icecat when it happens. I have tried this with both motherboard and usb sound and I get the same problem. I have disabled extensions (addons) in Icecat, deleted profiles, reinstalled the browser and even installed firefox from the AUR and it still occurs. I have disable gstreamer in about:config and restarted and it still occurs.

My .asoundrc is this:

pcm.!default {

   type plug
   slave.pcm "hw:0,0"

}


All my other audio applications work. I have noticed that if I use pulseaudio it fixes it, but it should work without anyway, like it used to. I think something happened after an update, but I'm not sure.

Any help would be appreciated. I know it's not a big problem, but it's really frustrating and I've had it for ages. I even switched browsers to get away from it.

I am using Parabola (a fork of archlinux), Icecat 31.4 and ALSA Icecat and firefox seem to hold onto the soundcard when I click on a new html5 audio/video link in the same tab. The next video/audio element loses sound. If I wait 10 seconds and click back to the start of the audio/video, the audio returns. I often get cpu spikes for icecat when it happens. I have tried this with both motherboard and usb sound and I get the same problem. I have disabled extensions (addons) in Icecat, deleted profiles, reinstalled the browser and even installed firefox from the AUR and it still occurs. I have disable gstreamer in about:config and restarted and it still occurs. My .asoundrc is this: pcm.!default { type plug slave.pcm "hw:0,0" } All my other audio applications work. I have noticed that if I use pulseaudio it fixes it, but it should work without anyway, like it used to. I think something happened after an update, but I'm not sure. Any help would be appreciated. I know it's not a big problem, but it's really frustrating and I've had it for ages. I even switched browsers to get away from it.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

guigs 1072 solutions 11697 answers

In /usr/share/alsa/alsa.conf is the default sound card correct?

reference:http://www.linuxquestions.org/questio.../firefox-and-asoundrc-no-html5-audio-4175521779/

You may also want to try the icecat forums, because they may have changed some of the defaults from the default linux build of Firefox.

In /usr/share/alsa/alsa.conf is the default sound card correct? reference:[http://www.linuxquestions.org/questions/slackware-14/firefox-and-asoundrc-no-html5-audio-4175521779/] You may also want to try the icecat forums, because they may have changed some of the defaults from the default linux build of Firefox.

Question owner

That fixed it.................. partially.

I changed my .asoundrc to :

pcm.!default.type plug; pcm.default.slave.pcm.type hw; pcm.default.slave.pcm.card 0;

and noticed that continuous sound output only happens with certain types of videos. For example if I play two music videos (audio only with a picture in the background) in a row, the second video will play fine, but if then switch to one with moving pictures, the sound will cut out again.

If I start with a moving pictures video and click on another, it works, but if i click on an audio only video after that it will cut out.

Also, there was no improvement with ogg audio files from my first post.

This makes me think it might be something to do with codecs or sample rates.

I can't paste the content of my /usr/share/alsa/alsa.conf in here, it's too big.

That fixed it.................. partially. I changed my .asoundrc to : pcm.!default.type plug; pcm.default.slave.pcm.type hw; pcm.default.slave.pcm.card 0; and noticed that continuous sound output only happens with certain types of videos. For example if I play two music videos (audio only with a picture in the background) in a row, the second video will play fine, but if then switch to one with moving pictures, the sound will cut out again. If I start with a moving pictures video and click on another, it works, but if i click on an audio only video after that it will cut out. Also, there was no improvement with ogg audio files from my first post. This makes me think it might be something to do with codecs or sample rates. I can't paste the content of my /usr/share/alsa/alsa.conf in here, it's too big.

Modified by sigod

the-edmeister
  • Top 25 Contributor
  • Moderator
5420 solutions 40434 answers

Post it here and give us the URL to it. http://pastebin.mozilla.org/

Post it here and give us the URL to it. http://pastebin.mozilla.org/

Question owner

https://pastebin.mozilla.org/8822422
guigs 1072 solutions 11697 answers
  • nerding out*

I am not an expert in this and if we get stuck I have found a mailing list for the alsa project that can be contacted: http://www.alsa-project.org/main/index.php/Mailing-lists

Gstreamer is disabled in Firefox as well as the os?

Since you are seeing issues with ogg files and moving video/audio combination I started to dig into file formats {sox http://sox.sourceforge.net/soxformat.html}

For ogg would the file format affect the "raw"?

defaults.pcm.file_format        "raw"

Updated libraries alsa-lib-1.0.6-8.FC3 alsa-utils-1.0.6-3

No no, here: http://oss.sgi.com/LDP/LDP/linuxcookbook/html/cookbook_27.html#SEC377 Is the OGG cpu intensive for your alsa architecture? http://alsa.opensrc.org/Ogg

Troubleshooting sound on Linux to narrow down the issue: http://www.troubleshooters.com/linux/.../sound_troubleshooting.htm#the_steve_litt_diagnostic_tools


References: http://www.alsa-project.org/main/inde.../Minivosc http://www.troubleshooters.com/linux/.../sound_troubleshooting.htm#the_steve_litt_diagnostic_tools

I am sorry, this is where I can no longer help. Please seek the guidance of the Linux forums or that alsa mailing list.

*nerding out* I am not an expert in this and if we get stuck I have found a mailing list for the alsa project that can be contacted: http://www.alsa-project.org/main/index.php/Mailing-lists Gstreamer is disabled in Firefox as well as the os? Since you are seeing issues with ogg files and moving video/audio combination I started to dig into file formats {sox http://sox.sourceforge.net/soxformat.html} For ogg would the file format affect the "raw"? defaults.pcm.file_format "raw" Updated libraries alsa-lib-1.0.6-8.FC3 alsa-utils-1.0.6-3 No no, here: http://oss.sgi.com/LDP/LDP/linuxcookbook/html/cookbook_27.html#SEC377 Is the OGG cpu intensive for your alsa architecture? [http://alsa.opensrc.org/Ogg] Troubleshooting sound on Linux to narrow down the issue: [http://www.troubleshooters.com/linux/sound/sound_troubleshooting.htm#the_steve_litt_diagnostic_tools] References: [http://www.alsa-project.org/main/index.php/Minivosc] [http://www.troubleshooters.com/linux/sound/sound_troubleshooting.htm#the_steve_litt_diagnostic_tools] I am sorry, this is where I can no longer help. Please seek the guidance of the Linux forums or that alsa mailing list.

Question owner

Gstreamer is enabled in firefox and the os. It was disabled in firefox before and enabling it had no effect.

I don't see why the ogg format would affect the "raw" setting in /usr/share/alsa/alsa.conf. I use another browser called Qupzilla and it plays ogg files continuously, although it won't let me seek through them.

It's not just ogg files that cause cpu spikes, it happens when firefox has trouble playing the sound from any html5 element in the continuous playback scenario I described above. I then have to kill firefox/icecat twice to close the program so I can restart it and get the sound working again.

Gstreamer is enabled in firefox and the os. It was disabled in firefox before and enabling it had no effect. I don't see why the ogg format would affect the "raw" setting in /usr/share/alsa/alsa.conf. I use another browser called Qupzilla and it plays ogg files continuously, although it won't let me seek through them. It's not just ogg files that cause cpu spikes, it happens when firefox has trouble playing the sound from any html5 element in the continuous playback scenario I described above. I then have to kill firefox/icecat twice to close the program so I can restart it and get the sound working again.

Modified by sigod