X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Wednesday, April 1, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

How many times do I have to hit "Allow and Remember" before it remembers?

Posted

One site that I need to use regularly unfortunately still hasn't migrated their functionality off of Java, and every time I use it, I get the "Java blocked" stripe at the top of the window - to the point that I don't always notice anymore when it appears. I keep clicking "Allow and Remember", but this does nothing to prevent it from happening the next time. Is there any way to more forcibly tell Firefox "stop bugging me about this"?

One site that I need to use regularly unfortunately still hasn't migrated their functionality off of Java, and every time I use it, I get the "Java blocked" stripe at the top of the window - to the point that I don't always notice anymore when it appears. I keep clicking "Allow and Remember", but this does nothing to prevent it from happening the next time. Is there any way to more forcibly tell Firefox "stop bugging me about this"?

Chosen solution

To be specific, under Options | Privacy, I have it "Use custom settings for History", and "Clear history when Firefox closes", but to get the Java stuff to stick, I had to go into the Settings subdialog and uncheck "Site Preferences" - on top of putting an exception in Java's own Control Panel (which was the way I had been trying to fix this before).

It would have been nice if all those "Allow and Remember" prompts had bothered to remind me that I had remembering turned off.

Read this answer in context 1
philipp
  • Top 25 Contributor
  • Moderator
5348 solutions 23617 answers

Helpful Reply

hi T.BugReporter, do you happen to run firefox in permanent private browsing mode ("never remember history" in the options > privacy panel) or clear your site preferences when quitting the application? in this case the site-specific permissions won't be kept...

Settings for privacy, browsing history and do-not-track

hi T.BugReporter, do you happen to run firefox in permanent private browsing mode ("never remember history" in the options > privacy panel) or clear your site preferences when quitting the application? in this case the site-specific permissions won't be kept... [[Settings for privacy, browsing history and do-not-track]]

Chosen Solution

To be specific, under Options | Privacy, I have it "Use custom settings for History", and "Clear history when Firefox closes", but to get the Java stuff to stick, I had to go into the Settings subdialog and uncheck "Site Preferences" - on top of putting an exception in Java's own Control Panel (which was the way I had been trying to fix this before).

It would have been nice if all those "Allow and Remember" prompts had bothered to remind me that I had remembering turned off.

To be specific, under Options | Privacy, I have it "Use custom settings for History", and "Clear history when Firefox closes", but to get the Java stuff to stick, I had to go into the Settings subdialog and uncheck "Site Preferences" - on top of putting an exception in Java's own Control Panel (which was the way I had been trying to fix this before). It would have been nice if all those "Allow and Remember" prompts had bothered to remind me that I had remembering turned off.

Modified by T.BugReporter