X
Tap here to go to the mobile version of the site.

Support Forum

Using Firefox, how do I block side pop out ads/links?

Posted

When using Firefox I continue to get these left hand pop-out strips for links to Facebook, Email, Twitter, Reddit, Stumblupon and more. This strip of links covers the text on the page making it impossible to read any article.

How do I get rid of it? I've installed AdBlock, AdPlus, NoScript and still can't get rid of the thing. Here's a picture:

When using Firefox I continue to get these left hand pop-out strips for links to Facebook, Email, Twitter, Reddit, Stumblupon and more. This strip of links covers the text on the page making it impossible to read any article. How do I get rid of it? I've installed AdBlock, AdPlus, NoScript and still can't get rid of the thing. Here's a picture:
Attached screenshots

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.10
  • Coupons Inc., Coupon Printer
  • DivX Web Player version 3.2.4.1250
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:35.0) Gecko/20100101 Firefox/35.0

More Information

Diego Victor 658 solutions 4175 answers

That aren't popups, they are shortcuts to visitor of the website login in their accounts on that social sites.

If you have AdBlock Plus installed, just right click on it and select AdBlock Plus: Block ??? (??? can be image, frame , etc ...)

That aren't popups, they are shortcuts to visitor of the website login in their accounts on that social sites. If you have AdBlock Plus installed, just right click on it and select '''AdBlock Plus: Block ???''' (??? can be image, frame , etc ...)
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157866 answers

Such sliders are usually hidden at the left or right side of the window and only move into full view if you hover them. Zooming pages or use non default font sizes may also have affect on such a slider. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))
Such sliders are usually hidden at the left or right side of the window and only move into full view if you hover them. Zooming pages or use non default font sizes may also have affect on such a slider. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages

Question owner

Resetting the zoom does not solve the problem merely makes the page smaller allowing the text to display. If you can't see that small of print (and I cannot) then zooming the page size is necessary.

The point is - how do I block these types of side pop-out links? They are annoying and unnecessary.

Resetting the zoom does not solve the problem merely makes the page smaller allowing the text to display. If you can't see that small of print (and I cannot) then zooming the page size is necessary. The point is - how do I block these types of side pop-out links? They are annoying and unnecessary.

Question owner

No option in Adblock Plus, see image:

Block Pop Up options is ON but does not block this side pop up.

No option in Adblock Plus, see image: Block Pop Up options is ON but does not block this side pop up.

Modified by Cary

Question owner

Diego Victor said

That aren't popups, they are shortcuts to visitor of the website login in their accounts on that social sites.

How do I remove the 'shortcut'? I don't have accounts on any of the social sites and my viewing pleasure should not be hampered.

I can block this side pop out with Safari but not Firefox. Is Firefox not up to it?

''Diego Victor [[#answer-687448|said]]'' <blockquote> That aren't popups, they are shortcuts to visitor of the website login in their accounts on that social sites. </blockquote> How do I remove the 'shortcut'? I don't have accounts on any of the social sites and my viewing pleasure should not be hampered. I can block this side pop out with Safari but not Firefox. Is Firefox not up to it?
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157866 answers

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

Question owner

Try this: http://www.towleroad.com/2015/02/vigil-staged-outside-san-francisco-cathedral-to-protest-archbishops-anti-gay-purity-test-for-teacher.html#comments
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157866 answers

I only get the overlap if I zoom the page using full page zoom. I some cases "Zoom Text Only" causes issues and full page zoom causes issues, but in this case the opposite happens.

You can hide that bar with this code in userContent.css or Stylish

@-moz-document domain(www.towleroad.com){
 #at4-share { display: none !important; }
}
I only get the overlap if I zoom the page using full page zoom. I some cases "Zoom Text Only" causes issues and full page zoom causes issues, but in this case the opposite happens. You can hide that bar with this code in userContent.css or Stylish <pre><nowiki>@-moz-document domain(www.towleroad.com){ #at4-share { display: none !important; } }</nowiki></pre>

Question owner

cor-el said

I only get the overlap if I zoom the page using full page zoom. I some cases "Zoom Text Only" causes issues and full page zoom causes issues, but in this case the opposite happens. You can hide that bar with this code in userContent.css or Stylish
@-moz-document domain(www.towleroad.com){
 #at4-share { display: none !important; }
}

Yes but I would have to do that with each page I view. I want a resolution to remove that option permanently.

Please understand, my browser(s) appear on a five-foot display (two-30" Cinema displays) and because of poor eyesight (which can't be corrected with glasses or surgery) I must Zoom the page to a readable size. But that is hampered now by this ridiculous left side link pop-out. A pop-out that is there for the convenience of the website to help promote their business through social media.

I DO HAVE the option to ban this side pop-out using Safari - so why can't the Firefox people offer the same option? I dropped Firefox years ago and returned just a few months back hoping the problems with Firefox had been corrected. They haven't yet day after day we keep getting new upgrades disabling our addons until those developers can catch up.

I like Firefox but I now like Safari much better. I can search for anything directly in the url bar and not in a separate search box. I am removing Firefox from my systems.

''cor-el [[#answer-688243|said]]'' <blockquote> I only get the overlap if I zoom the page using full page zoom. I some cases "Zoom Text Only" causes issues and full page zoom causes issues, but in this case the opposite happens. You can hide that bar with this code in userContent.css or Stylish <pre><nowiki>@-moz-document domain(www.towleroad.com){ #at4-share { display: none !important; } }</nowiki></pre> </blockquote> Yes but I would have to do that with each page I view. I want a resolution to remove that option permanently. Please understand, my browser(s) appear on a five-foot display (two-30" Cinema displays) and because of poor eyesight (which can't be corrected with glasses or surgery) I must Zoom the page to a readable size. But that is hampered now by this ridiculous left side link pop-out. A pop-out that is there for the convenience of the website to help promote their business through social media. I DO HAVE the option to ban this side pop-out using Safari - so why can't the Firefox people offer the same option? I dropped Firefox years ago and returned just a few months back hoping the problems with Firefox had been corrected. They haven't yet day after day we keep getting new upgrades disabling our addons until those developers can catch up. I like Firefox but I now like Safari much better. I can search for anything directly in the url bar and not in a separate search box. I am removing Firefox from my systems.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157866 answers

On that page using "View > [X] Zoom Text Only" works. On other pages you get better results with that option disabled. I usually set a larger default font and use only page or text zoom in cases that a larger minimum is causing issues with overlapping text or other issues like text disappearing outside containers..

You can use the NoSquint extension to set font size (text/page zoom) and text color on web pages.

On that page using "View > [X] Zoom Text Only" works. On other pages you get better results with that option disabled. I usually set a larger default font and use only page or text zoom in cases that a larger minimum is causing issues with overlapping text or other issues like text disappearing outside containers.. You can use the NoSquint extension to set font size (text/page zoom) and text color on web pages. *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/