X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop a recurring issue with fonts displaying incorrectly?

Posted

A while ago, I noticed that the fonts on some webpages all of a sudden turned thin and compressed, and many other fonts didn't display correctly. I tried all the usual stuff (restart the computer, clear the cache) and searched around with no solution, so I reset Firefox to its default settings.

This fixed it, but the issue returned later. It goes away every time I refresh Firefox (resetting it to its default settings), but seems to come back a week or so later. Lately, the time it takes for it to come back seems to be getting shorter. I refreshed Firefox last night, but it returned this morning. I refreshed again this morning and it came back this evening.

The problem is most noticeable on Facebook, which I've included some screenshots of. The top is how the fonts normally look, and the bottom is how they look once this problem occurs.

A while ago, I noticed that the fonts on some webpages all of a sudden turned thin and compressed, and many other fonts didn't display correctly. I tried all the usual stuff (restart the computer, clear the cache) and searched around with no solution, so I reset Firefox to its default settings. This fixed it, but the issue returned later. It goes away every time I refresh Firefox (resetting it to its default settings), but seems to come back a week or so later. Lately, the time it takes for it to come back seems to be getting shorter. I refreshed Firefox last night, but it returned this morning. I refreshed again this morning and it came back this evening. The problem is most noticeable on Facebook, which I've included some screenshots of. The top is how the fonts normally look, and the bottom is how they look once this problem occurs.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • GEPlugin
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.31.2 for Mozilla browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 16.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.5.155
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3.153
  • 5.1.30514.0
  • VLC media player Web Plugin 2.1.3
  • Plugin for Wacom tablets.
  • iTunes Detector Plug-in

Application

  • Firefox 35.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.6.7 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adobe Acrobat - Create PDF 2.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon R9 200 Series
  • adapterDescription2: Intel(R) HD Graphics 4600
  • adapterDeviceID: 0x6810
  • adapterDeviceID2: 0x0412
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterRAM: 4095
  • adapterRAM2: Unknown
  • adapterSubsysID: 227d1458
  • adapterSubsysID2: 0000000c
  • adapterVendorID: 0x1002
  • adapterVendorID2: 0x8086
  • clearTypeParameters: Gamma: 2200 Pixel Structure: B ClearType Level: 0 Enhanced Contrast: 50
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 2-23-2014
  • driverDate2: 1-29-2014
  • driverVersion: 13.350.1005.0
  • driverVersion2: 10.18.10.3412
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon R9 200 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
user1089369 5 solutions 48 answers

I am guessing this isnt an issue with Firefox but a program on your computer that is automatically doing this. Have you seen the same issue on other browsers?

I am guessing this isnt an issue with Firefox but a program on your computer that is automatically doing this. Have you seen the same issue on other browsers?
FredMcD
  • Top 10 Contributor
4224 solutions 58948 answers

You have two problems


Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.


https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

You have two problems ---------------------- Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' ----------------------- '''https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save'''
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157316 answers

You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

This can be a problem with the font that is used to display the text.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
You may have zoomed web page(s) by accident. Reset the page zoom on pages that cause problems. *<b>View > Zoom > Reset</b> (Ctrl/Command+0 (zero)) *http://kb.mozillazine.org/Zoom_text_of_web_pages ---- This can be a problem with the font that is used to display the text. You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 You can try different default fonts and temporarily disable website fonts to test the selected default font. *Tools > Options > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"