Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"User certificate has expired" errors - my clock was wrong but it's fixed now, errors still happen

  • 3 replies
  • 5 have this problem
  • 1997 views
  • Last reply by jscher2000

more options

I recently reinstalled windows 8.1 and started from scratch with firefox. My computer clock somehow got a day ahead in the process, so all my browsers were giving me errors. I fixed the date, and all the other browsers are fine, but Firefox still gives me "this connection is untrusted - user certificate has expired" whenever it tries to load a https website (even google.)

I tried clearing everything in Firefox, up to and including completely uninstalling and reinstalling it, and it's still giving me these errors, fresh out of the installer, with the correct time/date on the clock. Help?

Edit to add: Okay... so I set my clock forward a day again, and the errors went away (for firefox, they came back in the other browsers.) And then I set it back again, and the errors were gone, but only on sites I visited while the clock was wrong. I guess doing that is forcing some kind of site-by-site reset or something? I would still love to know what caused this, though, so I don't have to change my computer date every time I visit a new https: site in firefox.

Edit 2: And... I have to go in and do that again for every site every time I close & re-open firefox.

Modified by secatn

Chosen solution

If you haven't already, could you try renaming Firefox's certificate store file, cert8.db, so Firefox starts a new one? Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename cert8.db to something like cert8.old (note: if your Windows does not show the .db extension, you can turn on display of file extensions following the steps in this article: http://windows.microsoft.com/en-us/wi.../show-hide-file-name-extensions)

Start Firefox back up again. Can you visit secure sites more normally?

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

If you haven't already, could you try renaming Firefox's certificate store file, cert8.db, so Firefox starts a new one? Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various settings files.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename cert8.db to something like cert8.old (note: if your Windows does not show the .db extension, you can turn on display of file extensions following the steps in this article: http://windows.microsoft.com/en-us/wi.../show-hide-file-name-extensions)

Start Firefox back up again. Can you visit secure sites more normally?

more options

Yes! I followed your instructions and that seems to have fixed it. Thank you so much.

more options

PLEASE IGNORE - posted in wrong thread, sorry

Modified by jscher2000