X
Tap here to go to the mobile version of the site.

Support Forum

Suddenly, I'm being asked to download webm files before playing them. Do you not have an embedded player anymore?

Posted

As Mac user, I've always shunned Sarfari in favor of Firefox mainly because I don't have to download webm files in order to watch them. All of a sudden, now you do. Is there something I have to reset, or have you turned it into a option like you did with the Add-on bar?

As Mac user, I've always shunned Sarfari in favor of Firefox mainly because I don't have to download webm files in order to watch them. All of a sudden, now you do. Is there something I have to reset, or have you turned it into a option like you did with the Add-on bar?

Chosen solution

jscher2000 said

...(Your) server(s)... do...not appear to be correctly configured to host .webm files...Maybe try: https://www.google.com/search?q=apache+configure+webm

Mystery solved, and Firefox wasn't the culprit -- I didn't take into account that I changed web hosts in the past week. Updated my htaccess files as per an article at your link and it's back to normal. An excellent piece of sleuthing, sir -- I salute you!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.10
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • DivX Web Player version 3.2.3.1164
  • DivX VOD Helper Plug-in
  • Fuze Launch Plugin
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • npmnqmp 071706000001
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Plugin
  • Shockwave Flash 15.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.3
  • 5.1.30317.0
  • WebEx64 General Plugin Container Version 202
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:34.0) Gecko/20100101 Firefox/34.0

More Information

user1068417 21 solutions 226 answers

In Settings > Applications, search for Video and find Web Media Video. Tell it to preview/open in Firefox or a plugin such as VLC or Windows Media Player.

In Settings > Applications, search for Video and find Web Media Video. Tell it to preview/open in Firefox or a plugin such as VLC or Windows Media Player.
jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

There are several ways that sites can set up webm video for viewing, including HTML5 video tags and various plugins.

Here's a test site that uses HTML5 video tags: http://www.webmfiles.org/demo-files/ (scroll down to "WebM Videos within the HTML5 <Video> Tag" where you should see a player). Does that work? If not, could you double check some settings:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste webm and pause while the list is filtered

(3) I think you need both of these to have their default value of "true" (double-click to toggle between false and true if necessary):

  • media.encoder.webm.enabled
  • media.webm.enabled

Note: I'm viewing this on Windows, so there could be some differences on Mac. Please let me know if you don't find those.

There are several ways that sites can set up webm video for viewing, including HTML5 video tags and various plugins. Here's a test site that uses HTML5 video tags: http://www.webmfiles.org/demo-files/ (scroll down to "WebM Videos within the HTML5 &lt;Video&gt; Tag" where you should see a player). Does that work? If not, could you double check some settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webm''' and pause while the list is filtered (3) I think you need both of these to have their default value of "true" (double-click to toggle between false and true if necessary): * media.encoder.webm.enabled * media.webm.enabled Note: I'm viewing this on Windows, so there could be some differences on Mac. Please let me know if you don't find those.
cor-el
  • Top 10 Contributor
  • Moderator
16653 solutions 150528 answers

Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used.

You can check that via the right-click context menu in the Inspector.

Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used. You can check that via the right-click context menu in the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector

Question owner

SuperSluether said

In Settings > Applications, search for Video and find Web Media Video. Tell it to preview/open in Firefox or a plugin such as VLC or Windows Media Player.

For Web Media files, I see a dropdown box with Use Opera as default, Always Ask, Save, and Use Other. I try to select Firefox under Use Other, but when I click on Open, nothing happens. Why is another browser one of the option?

''SuperSluether [[#answer-671439|said]]'' <blockquote> In Settings > Applications, search for Video and find Web Media Video. Tell it to preview/open in Firefox or a plugin such as VLC or Windows Media Player. </blockquote> For Web Media files, I see a dropdown box with Use Opera as default, Always Ask, Save, and Use Other. I try to select Firefox under Use Other, but when I click on Open, nothing happens. Why is another browser one of the option?

Question owner

cor-el said

Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used. You can check that via the right-click context menu in the Inspector.

jscher2000 said

There are several ways that sites can set up webm video for viewing, including HTML5 video tags and various plugins. Here's a test site that uses HTML5 video tags: http://www.webmfiles.org/demo-files/ (scroll down to "WebM Videos within the HTML5 <Video> Tag" where you should see a player). Does that work? If not, could you double check some settings: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste webm and pause while the list is filtered (3) I think you need both of these to have their default value of "true" (double-click to toggle between false and true if necessary):
  • media.encoder.webm.enabled
  • media.webm.enabled
Note: I'm viewing this on Windows, so there could be some differences on Mac. Please let me know if you don't find those.
''cor-el [[#answer-671480|said]]'' <blockquote> Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used. You can check that via the right-click context menu in the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector </blockquote> ''jscher2000 [[#answer-671454|said]]'' <blockquote> There are several ways that sites can set up webm video for viewing, including HTML5 video tags and various plugins. Here's a test site that uses HTML5 video tags: http://www.webmfiles.org/demo-files/ (scroll down to "WebM Videos within the HTML5 &lt;Video&gt; Tag" where you should see a player). Does that work? If not, could you double check some settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webm''' and pause while the list is filtered (3) I think you need both of these to have their default value of "true" (double-click to toggle between false and true if necessary): * media.encoder.webm.enabled * media.webm.enabled Note: I'm viewing this on Windows, so there could be some differences on Mac. Please let me know if you don't find those. </blockquote>

Question owner

rocktivity said

cor-el said
Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used. You can check that via the right-click context menu in the Inspector.

jscher2000 said

There are several ways that sites can set up webm video for viewing, including HTML5 video tags and various plugins. Here's a test site that uses HTML5 video tags: http://www.webmfiles.org/demo-files/ (scroll down to "WebM Videos within the HTML5 <Video> Tag" where you should see a player). Does that work? If not, could you double check some settings: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste webm and pause while the list is filtered (3) I think you need both of these to have their default value of "true" (double-click to toggle between false and true if necessary):
  • media.encoder.webm.enabled
  • media.webm.enabled
Note: I'm viewing this on Windows, so there could be some differences on Mac. Please let me know if you don't find those.

The file on the Webmfiles.org page plays, and my about:config media encoders are both on true. Exactly what should I look for in the inspector?

''rocktivity [[#answer-672423|said]]'' <blockquote> ''cor-el [[#answer-671480|said]]'' <blockquote> Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used. You can check that via the right-click context menu in the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector </blockquote> ''jscher2000 [[#answer-671454|said]]'' <blockquote> There are several ways that sites can set up webm video for viewing, including HTML5 video tags and various plugins. Here's a test site that uses HTML5 video tags: http://www.webmfiles.org/demo-files/ (scroll down to "WebM Videos within the HTML5 &lt;Video&gt; Tag" where you should see a player). Does that work? If not, could you double check some settings: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webm''' and pause while the list is filtered (3) I think you need both of these to have their default value of "true" (double-click to toggle between false and true if necessary): * media.encoder.webm.enabled * media.webm.enabled Note: I'm viewing this on Windows, so there could be some differences on Mac. Please let me know if you don't find those. </blockquote> </blockquote> The file on the Webmfiles.org page plays, and my about:config media encoders are both on true. Exactly what should I look for in the inspector?

Question owner

cor-el said

Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used. You can check that via the right-click context menu in the Inspector.

Yes, I'm using the .webm tag. Until this week, I'd just click on the URL and it would start playing.

''cor-el [[#answer-671480|said]]'' <blockquote> Note that Firefox only plays WebM media files internally with the HTML5 media player if the video (or audio) tag is used. You can check that via the right-click context menu in the Inspector. *https://developer.mozilla.org/Tools/Page_Inspector </blockquote> Yes, I'm using the .webm tag. Until this week, I'd just click on the URL and it would start playing.

Question owner

I've downloaded a fresh version of Firefox 34.05, and under Applications, the webm video format isn't even listed.

I've downloaded a fresh version of Firefox 34.05, and under Applications, the webm video format isn't even listed.
jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

Helpful Reply

In Preferences > Applications, you will see mostly associations that Firefox learns from outside sources. On Windows, that's initially drawn mostly the Registry; I don't know whether that information is stored on Mac. Over time as you choose different applications to handle different kinds of downloads, those will show up on that tab.

Is the website with the problem one that you manage or administer? If you can give a link to the problem page, that would be helpful.

In Preferences > Applications, you will see mostly associations that Firefox learns from outside sources. On Windows, that's initially drawn mostly the Registry; I don't know whether that information is stored on Mac. Over time as you choose different applications to handle different kinds of downloads, those will show up on that tab. Is the website with the problem one that you manage or administer? If you can give a link to the problem page, that would be helpful.

Question owner

jscher2000 said

...Is the website with the problem one that you manage or administer? If you can give a link to the problem page, that would be helpful.

I administer my sites with WordPress, which has a default HTML5 video player. But here are the pages where I've placed the URLS of WEBM videos from my server:

http://rocktivity.com/index.html

http://www.drycounty.com/jovitalk/showthread.php?p=1184280&postcount=2

http://www.democraticunderground.com/?com=view_post&forum=1002&pid=4797602

''jscher2000 [[#answer-672701|said]]'' <blockquote>...Is the website with the problem one that you manage or administer? If you can give a link to the problem page, that would be helpful. </blockquote> I administer my sites with WordPress, which has a default HTML5 video player. But here are the pages where I've placed the URLS of WEBM videos from my server: http://rocktivity.com/index.html http://www.drycounty.com/jovitalk/showthread.php?p=1184280&postcount=2 http://www.democraticunderground.com/?com=view_post&forum=1002&pid=4797602
jscher2000
  • Top 10 Contributor
7869 solutions 64153 answers

Helpful Reply

Hi rocktivity, on the first link, the server at njnation.us does not appear to be correctly configured to host .webm files. It is sending a content type of "text/plain" (first screen shot).

Similar for rocktivity.com on the second link (second screen shot).

Maybe try: https://www.google.com/search?q=apache+configure+webm

Hi rocktivity, on the first link, the server at njnation.us does not appear to be correctly configured to host .webm files. It is sending a content type of "text/plain" (first screen shot). Similar for rocktivity.com on the second link (second screen shot). Maybe try: https://www.google.com/search?q=apache+configure+webm

Chosen Solution

jscher2000 said

...(Your) server(s)... do...not appear to be correctly configured to host .webm files...Maybe try: https://www.google.com/search?q=apache+configure+webm

Mystery solved, and Firefox wasn't the culprit -- I didn't take into account that I changed web hosts in the past week. Updated my htaccess files as per an article at your link and it's back to normal. An excellent piece of sleuthing, sir -- I salute you!

''jscher2000 [[#answer-673804|said]]'' <blockquote> ...(Your) server(s)... do...not appear to be correctly configured to host .webm files...Maybe try: https://www.google.com/search?q=apache+configure+webm </blockquote> Mystery solved, and Firefox wasn't the culprit -- I didn't take into account that I changed web hosts in the past week. Updated my htaccess files as per [http://www.webcoder.de/2010/06/04/how-to-configure-your-webserver-for-webm-video-and-audio-files/ an article at your link] and it's back to normal. An excellent piece of sleuthing, sir -- I salute you!

Modified by rocktivity