Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Search engines have disappeared from search bar/field 34.0.5

  • 4 replies
  • 7 have this problem
  • 2309 views
  • Last reply by supmozilla

more options

I updated to 34.0.5 a few days ago, and just noticed that I no longer have any search engines in the search field (although all searches now go to Yahoo).

If I open the "Change Search Settings", it shows lots of engines there, but when I click OK, they still do not show as options in the magnifier popdown.

Very frustrated; it was exactly like I wanted it before with a selected default engine and others available in the pop down. How to fix?

Chosen solution

If you want to restore the previously used standalone window to manage search engines then you can toggle this pref to false with a middle-click on the about:config page.

  • about:config page: browser.search.showOneOffButtons = false

Close and restart Firefox to the change effective.

Read this answer in context 👍 3

All Replies (4)

more options

The Search Bar in Firefox 34.0.5 is all new. Read about how it works. https://support.mozilla.org/en-US/kb/search-bar-add-change-manage-search-engines-firefox

more options

Oh crap. Are there any changes we can make in about:config to get it to work like before?

more options

Chosen Solution

If you want to restore the previously used standalone window to manage search engines then you can toggle this pref to false with a middle-click on the about:config page.

  • about:config page: browser.search.showOneOffButtons = false

Close and restart Firefox to the change effective.

more options

cor-el said

If you want to restore the previously used standalone window to manage search engines then you can toggle this pref to false with a middle-click on the about:config page.
  • about:config page: browser.search.showOneOffButtons = false
Close and restart Firefox to the change effective.

That worked like a champ. Thanks.