Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

my firefox doesn't show any content of the page ..

  • 2 replies
  • 1 has this problem
  • 3 views
  • Last reply by cor-el

more options

the firefox browser shows an empty page, no content is showing , i tried fixing it from sitting no way. i uninstalled it and re-installed it didn't help neither .

plz let me know how to fix this problem , coz i like this browser

All Replies (2)

more options

Was the entire browser blank -- no menus or toolbars -- or just the area where the web page usually appears?

It sounds like this affects your home page (the page you see at startup). Do you know whether Firefox can display other pages? You could try loading another page using the address bar or a bookmark.


When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

"3-bar" menu button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?


To rule out extensions as a possible culprit, could you try the site in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions, some advanced features, and some custom settings. More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using either

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

Note: Flash and other plugins still run

After Firefox closes, a small dialog should appear: click "Start in Safe Mode" (not Reset)

Any difference?

more options

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access to install for Firefox and the plugin-container process and the updater process.

See:


Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also: